Sacred 2 Gold

Sacred 2 Gold

AlCaPWN Feb 3, 2013 @ 10:35am
Game won't launch
So....the game won't launch from Steam. I click the "PLAY" button and a window pops up just long enough for me not to see a damn thing it says, and then nothing happens.
< >
Showing 1-15 of 16 comments
Aegison Feb 3, 2013 @ 6:21pm 
Try installing the latest physx from nvidia.

Also, you may want to post your system specs if you want technical help.
TitaniumExile Feb 4, 2013 @ 2:04am 
Also check the "Integrity of game cache" to check you've got everything dl'd.
add in the "properties" -> "launch options" -> "-skipopenal -nocpubinding"
In another topic someone said that the "-skipopenal" worked for him since it wouldn't start for him either
Krillgar Feb 9, 2013 @ 9:52am 
I tried SoulSpeed's suggestion, and it still doesn't work. I goes to start the First Time Launch, and it just closes on its own, even after setting the "launch options" and checking the "integrity of game cache". Is it just an issue of the AMD processor like so many other games?

Here's my system specs:

OS Name Microsoft Windows 7 Professional
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name BEN-PC
System Manufacturer To Be Filled By O.E.M.
System Model To Be Filled By O.E.M.
System Type x64-based PC
Processor AMD FX(tm)-4170 Quad-Core Processor, 4200 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. P1.40, 3/27/2012
SMBIOS Version 2.6
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "6.1.7601.17514"
User Name ben-PC\ben
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.98 GB
Available Physical Memory 6.29 GB
Total Virtual Memory 16.0 GB
Available Virtual Memory 13.0 GB
Page File Space 7.98 GB
Page File C:\pagefile.sys
Krillgar Feb 9, 2013 @ 11:52am 
Figured it out. There's nVidia's PhysX DLL that needs to be installed first. For some reason, the setup process won't do that.

If you go to C:\Program Files (x86)\Steam\steamapps\common\sacred2\support\physX and run the application in there first, that should allow you to install the game. It did work for me, as well as on a few other games.
AlCaPWN Feb 10, 2013 @ 9:25pm 
Not usre about this PhysX thing...I'm running and AMD graphics card. Sapphire 7950. And I didn't see the .exe or the support folder.
TitaniumExile Feb 12, 2013 @ 3:35am 
Glad you found the problem :)
I would suggest that you dl the latest from nVidia site, just to keep it up-to-date
Krillgar Feb 16, 2013 @ 9:20am 
Sorry AlCaPWN, I had uninstalled Sacred2 in a bout of frustration, and copied the path from another game.

For Sacred 2, the path is C:\Program Files (x86)\Steam\steamapps\common\Sacred 2 Gold\redist\PhysX\ and the file you are looking for is PhysX_9.10.0513_SystemSoftware.
AlCaPWN Feb 16, 2013 @ 8:35pm 
Thanks, Krillgar. I installed PhysX, but still have the same problem. Maybe a restart?
Krillgar Feb 17, 2013 @ 6:29am 
It's always worth a shot.
Sith'ari Stevonnie Aug 4, 2013 @ 4:33pm 
sweet! though weird as heck, I launched that .exe file and it started installing ,then it said that the one that I have is better than the one I'm trying to install. never the less the game launcher after it. awkward.
AlCaPWN Aug 19, 2013 @ 6:13pm 
Yeah, I finally got the game to work a while back. But it sux so whatevs.
CM721_F Nov 16, 2013 @ 3:43pm 
Ran the C:\Program Files (x86)\Steam\SteamApps\common\Sacred 2 Gold\redist\PhysX and it failed, but the game started working after that. So, FYI to anyone out there that this seems to work.
Zentastic Nov 28, 2013 @ 10:50am 
Have the same exact problem. PhysX is located in the same area as well. Went there, ran it, same results. Says I have a newer one installed. Still the game will not run.

My question to you did it create a file someone when it ran and exited that mine did not? Or perhaps you ran it from a different location other than the directory it is located in?

Have had this game forever, and still have been unable to get it to run.
Nidhoggr Dec 3, 2013 @ 3:00pm 
I thought I had this same problem last night after I tried to load it 2 times. I gave it one more shot for the hell of it and it worked. First time I played it in a few months.
The Main Man Dec 9, 2013 @ 2:03pm 
Sacred players United Sacred 1 n 2 Thats the group. Go there, look at the community patch. Download and put it in the files. Make sure you run the game first and wait for the silent crash. You need the community patch for anything to work on it.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Date Posted: Feb 3, 2013 @ 10:35am
Posts: 16