meanwhile Jan 26, 2013 @ 7:42pm
For those of you who do and don't crash, could you list your specs?
Was wondering if some people could list their specs and then specify if they do or don't crash. If you do crash, could you share how long you play before it happens? Like every 30 minutes to an hour etc. Also, could you share what settings you play at?

Was thinking we could try and find some commonality for the crashing, like if it's specific to NVIDIA or ATI users or something. Here are my specs:

OS: W7 Home 64bit
GPU: x2 580
CPU: 2600k 4.5ghz
RAM: 8GB

I'm crashing every hour or so on every setting (low, medium, high, very high).
Showing 1-14 of 14 comments
< >
Heinrich6745 Jan 26, 2013 @ 7:51pm 
OS Win 7 ultimate 64 bit
GPU 560 ti classified
CPU i7 860 @3.6
RAM 12gb 1600mhz
resolution 1920x1080
Mobo Asus p7p55d Deluxe

OS win 7 ultimate 64
GPU 560 ti
CPU e8400 @3.6
RAM 4gb 800mhz
resolution 1920x1080
Mobo Asus p5n-e sli

OS win 7 home edition 64 bit
GPU 670 FTW 4gb
CPU i7 920 stock
RAM 12gb 1600mhz
resolution 1920x1080
Mobo Asus Sabertooth x58

and another i have tested on, don't remember the specs either.
all of these have never crashed, a total of over 300 hours, both retail and steam copies just fyi.

I also know somebody with,

OS win 7 ultimate 64 bit
CPU i7 3770k @ 4.5ghz
GPU 680 3-way sli
RAM 16gb 1600mhz
resolution 5760x1080
Asus rampage IV Extreme

and has never crashed either.
Last edited by Heinrich6745; Jan 27, 2013 @ 7:49am
imortus Jan 26, 2013 @ 11:46pm 
One crash maybe in 125 hours aside from a corrupted character file:

OS: Win7 64-bit
CPU: i7 2.66GHz
GPU: nVidia 260 GTX
RAM: 6GB 1333
Res: 1920x1080
MB: MSI X58 Platinum

Edited for motherboard.
Last edited by imortus; Jan 27, 2013 @ 2:42pm
Shockara Jan 27, 2013 @ 7:18am 
You guys forgot to list your motherboards.
Here are my system specifications. Windows 8 x64
Runs great with no problems. 1920 x 1080

EVGA 012-P3-1470-AR GeForce GTX 470 (Fermi) 1280MB 320-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card

AMD FX-8120 Zambezi 3.1GHz Socket AM3+ 125W Eight-Core Desktop Processor FD8120FRGUBOX

CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 15000) Desktop Memory Model CMZ8GX3M2A1866C9

My System Drive is: Crucial M4 CT128M4SSD2CCA 2.5" 128GB SATA III MLC Internal Solid State Drive (SSD)

S2 is installed on this drive: Western Digital RE3 WD1002FBYS 1TB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

GIGABYTE GA-970A-D3 AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX AMD Motherboard

47” Class (46.96" Diag.) Full Array TRULED® LCD 3D HDTV with VIZIO Internet Apps™
Heinrich6745 Jan 27, 2013 @ 7:47am 
I will updated my comment with the motherboards
TitaniumExile Jan 27, 2013 @ 10:20am 
No chrashes so far. Only "driver stopped working" after a few days of playing

OS: Win7 Ultimate x64
MB: Asus Crosshair Formula V
CPU: AMD Phenom II x6 1090T BE @ 4Ghz
RAM: GeIL 8GB @ 2000Mhz
GPU: Ausu ATI HD6970

a) Turn UAC off (user account control)
b) .exe's in admin mode
c) Anti virus prog: add exe's to trusted processes and list the whole game folder to exeptions
d) Launch options: "-nocpubinding -skipopenal" (w/o "" and steam version)
There are lots of more OS tweaks but would be a massive list to list here.
Siddha Jan 27, 2013 @ 11:59am 
Dell Dimension
Core2 Duo 2.4Ghz
Nvidia gtx 560Ti
4Gb ram
(18/19 processes running before playing...ie 200Mb approx in ram)

Never get crashes
ScHwAntastic Jan 27, 2013 @ 12:09pm 
Dell Workststion 690
2 - Xeon 5150 processors @ 2.6Ghz
Nvidia GTX 550 Ti
8Gb ram

Hasn't crashed yet.
thomas-thorne Jan 30, 2013 @ 10:13am 
I can't even really launch the game. It brings up the screen with the all of the green ">processing xyz" for maybe 20-30 seconds, and then the game crashes.

Every, Single. Time.

Really not happy. I already paid for this game once before (on console), and I bought this version to get the expansion and be able to play on my laptop.

Specs: Windows 7 Premium 64 Bit 6 Gigs Ram
Nvida 360M i5 processer 2.6 ghz
Last edited by thomas-thorne; Jan 30, 2013 @ 10:13am
Aegison Jan 31, 2013 @ 9:11pm 
AMD Phenom II x4 940 OC to 3.6
Gigabyte GTX 660 w/ GTX 470 dedicated physx
4Gb ram
ASUS M3A78-T Motherboard
Windows 7 64-bit
Steam Gold Edition - with Elite textures from Collector`s edition.
Community Patch 1.40 installed.

No crashes yet with Gold. I put 130 hours into Fallen Angel on my 470 before the drm was removed with maybe 1 or 2 crashes. Been playing this week with no crashes.
CrazyNando Feb 1, 2013 @ 1:30am 
@ nekroturkey:

also important is the question, what layover do you use during Sacred 2!
I had big troubles for example with Xfire-Overlay! Since I deactivated it I had much less crashes!
Its crashs for me approx. every 10 - 15 hours!

here my specs:

CPU: Intel(R) Core(TM) i5-2400 CPU @ 3.10 GHz
MB: Asus P8P67
RAM: 8192 MB DDR3 1600 MHz CL8
Videocard: Sapphire Radeon HD 6870
OS: Windows 7 64bit Professional
Steam Gold Edition
CM 1.40hf installed
Last edited by CrazyNando; Feb 1, 2013 @ 1:31am
CrisisDog Feb 2, 2013 @ 3:40pm 
I have two DFI X48 / Core 2 systems running Nvidia cards, one has a GTX 670 and Windows 8 x64, the other a GTX 570 with Windows 7 x64. Both PhysX enabled, didn't try disabled. Crashes all the time in less than 30 minutes. Yanked the video card on the Windows 7 box and threw in a Radeon 5850 along with an older Ageia PhysX card (using the GenL hack to enable, as Nvidia PhysX will not play with ATI / AMD), no issues whatsoever. I've heard a lot of rumours that there's a memory leak with Nvidia / PhysX usage, I feel that it may be a GPU PhysX issue as my older PPU PhysX card works fine.
Nidhoggr Feb 2, 2013 @ 5:53pm 
Windows 7 Home 64 bit
4GB of RAM
Asrock H55M pro motherboard (w/ broken DIMM slot preventing me from adding more than the 4GB RAM I have...)
Intel i5-670
Nvidia GeForce 9800 GT 1GB (An oldie, but it still does the trick)

Running Sacred 2 gold with hardly any issues. The occasional studder, but that goes awway. Now, if I use Physx, I will crash at sometime, but sometimes I don't crash but I notice more frequent studdering when outdoors. With physx off I have never had a problem, and that's with everything maxxed out.
eckertt001 Feb 3, 2013 @ 12:51pm 
I built this system around 3 years ago, and everything is finally very stable. And it still runs great. Sacred 2 Gold from Steam has been the most stable it ever has been for me. I can play for hours on end, no crashes. I find though if I load the elite texture pack I have, crashes start happening when entering and leaving caverns and such. Since that pack really doesn't make the game look all that much better (everything just looks more vibrant, no real WOW factor), I just leave it as is.

OS: Windows 7 Ultimate 64-bit
CPU: Intel Extreme i7 980X 3.33Ghz
I have it set to auto overclock, messing with it too much causes far too many random issues.
MB: MSI Big Bang X-Power (Intel X58 Express)
RAM: 12GB
I've found that running the XMP profile is best for this configuration.
GPU: 2 x GTX580 1.5GB
Both cards are overvolted to 1.038V because the default of 0.963V is not enough voltage, and caused a lot of crashes with various games. Especially with DX11 games.
SOUND: Asus Phoebus Sound Card
Used to use Creative cards, but also lots of random crashes with various games. Surprisingly the random crashing has significantly decreased with the Phoebus card. Granted, it is still there, but happens less frequently.
TitaniumExile Feb 4, 2013 @ 1:55am 
Originally posted by CrisisDog:
(using the GenL hack to enable, as Nvidia PhysX will not play with ATI / AMD), no issues whatsoever. I've heard a lot of rumours that there's a memory leak with Nvidia / PhysX usage, I feel that it may be a GPU PhysX issue as my older PPU PhysX card works fine.

As far as I noticed, since I use a ATI HD6970, there should/would be memory leak in the PhysX. ATI uses their own hardcoded engine to use it.
Anyway I even need to play with that card w/o physx enable due the fact it stutters so much, barely getting even a stable 25-30fps. It hurts the eyes >_>
But the fact still remains that S2's PhysX is totaly out of bounds of what it should be.
Turn it off, it runs smoother than Vaseline xD
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Jan 26, 2013 @ 7:42pm
Posts: 14