Lav Jan 15, 2013 @ 7:37pm
Problems with Community Patch.
To start I'm using Windows 7 64bit, I have updated PhysX. I have run Steam, Sacred 2 and Community Patch as Admin, also used compatibility mode(Xp,Vista) for each. I have also let it do first time set up. To clarify I am using the Sacred 2 Gold edition.

Basically I want to play this game over Tunggle with a friend, but all the servers on Tunggle use the Community Patch. The problem i'm having is when I install 140hf it will not get past the start up screen(further more if there is no compatibility mode in use it won't start at all). It freezes at 'Setup Managers' on the start up screen and stops responding.

The game runs perfectly on ultra when the patch is not installed. I also cannot use the 'disable' exe that comes with the patch as it errors when I click it.

If anyone has anything I can try please help.

Edit: I made back ups of the fresh install of Sacred 2 Gold from steam before I installed the patch, now even with fresh install it is freezing at the same spot.

Edit2: Was able to get fresh install working perfectly again by actually uninstalling Sacred 2 Gold through Steam and it letting it index old files. Back to square one.
Last edited by Lav; Jan 15, 2013 @ 8:38pm
Showing 1-5 of 5 comments
< >
Gixxerdude Jan 16, 2013 @ 7:17am 
Did you try adding -nocpubinding -skipopenal to the launch properties of the game in steam? Also I am playing on Windows 7 64bit but did not need to set compatibility mode. Also didn't need to run it as admin, but I can't see admin affecting it at all.

If you are using nvidia and are forcing AA and other graphic settings, I would make sure your global settings are set to defaults and go in to the game and turn off AA in the game so that you are not forcing AA and other graphics on top of the game trying to set it's own settings.

This is the link I used to download the cm patch, it came from the discussion here labeled community update I think. Perhaps yours is corrupted.

http://xmas.ancaria.net/patches/cm-patch0140hf.zip
Lav Jan 16, 2013 @ 8:25am 
I just added the launch settings to the clean install worked fine, will try with patch installed. Not using nVidia, but there is a problem with Physx i've read where having it updated and installed fixes issues. Not forcing AA either, to reiterate this was from clean install, with first time set up done followed by patch install. Everything else I listed was done as troubleshooting and what has worked for others. I've downloaded the patch from two different locations so far and both give me the error on the disable. I will try yours though.
Lav Jan 16, 2013 @ 8:35am 
Yep that fixed it. Not sure whether it was the launch options or the different download, but it fixed it. Thanks!
Last edited by Lav; Jan 16, 2013 @ 8:35am
Gixxerdude Jan 16, 2013 @ 4:37pm 
Awesome dude, someone(s) else on the forums posted those glad they worked for you.
Lav Jan 16, 2013 @ 6:09pm 
All good, thanks for the original posters then! Hopefully someone will see this and fix it like I did.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Jan 15, 2013 @ 7:37pm
Posts: 5