Matthew Jan 10, 2013 @ 9:45pm
Crashing Fix.
I use the elite texture pack on top of maximum settings. And sacred 2 has been crashing constantly for me. If I lower the settings and/or remove the elite texture pack or disable physx. My game never crashes. However I want everything or nothing. So after trying every fix I could find on google, I decided it was impossible.

As a last resort I decided to mess around with the options.txt file, and according to user advice raised all the preloading settings to twice or three times their original value. This made the game have a lower framerate (due to more data being in memory) and crash far more often.

So I got that logic, and reversed it. And set all the memory preloading settings to 0. And now I have yet to see a single crash, with maximum settings, the elite texture pack, physx, and FXAA. The game stutters a lot less, and I get slightly higher framerates.

To do this, go to C:\Users\username\AppData\Local\Ascaron Entertainment\Sacred 2 and open the options.txt file, then look for this text

}
end
if not manager then
manager = {
animMem = 33554432,
grannyMem = 67108864,
pmsMem = 8388608,
secMem = 33554432,
sptMem = 8388608,
texMem = 209715200,
}
end

and CHANGE it to

}
end
if not manager then
manager = {
animMem = 0,
grannyMem = 0,
pmsMem = 0,
secMem = 0,
sptMem = 0,
texMem = 0,
}
end

Then rightclick on the options.txt, properties, and tick Read Only. This will prevent steam from resetting anything. So make sure any graphics options you want, are set PRIOR to editing the options.txt

If for any reason you want to go back to the default settings, simply delete options.txt, and steam will generate a fresh one.

With this fix the memory useage on the process has now gone from 1400mb or above to 450mb or slightly above, the reason for this is because everything is being streamed 100% as you see it. Which means you might want to have fast ram, or a SSD powering this game onwards.

I believe the memory cannot leak this way as well, as everything is streamed out as the new data is streamed in.

Most of you are probably running this without the elite texture pack and reduced settings, so there is a good chance you either crash a lot less, or never. As you will never get into the dangerous level of ram useage that cause crashes.

I also recommend you don't enable the ingame AA for this tittle, and enable FXAA for nvidia via the control panel, or MLAA via AMD's control panel. Sacred 2 also does not use Anistropic Filtering, so I recommend you FORCE that on via your AMD or NVIDIA control panel as well. Otherwise the elite texture's won't look nearly as good.


Last note:

If you are having crashing problems even without physx and the elite textures, this fix will likely help you as well.
Showing 1-15 of 17 comments
< >
Sneak0r Jun 6, 2013 @ 3:06am 
Thanks for your effort! I'll check this out asap cause my sacred mem reach 1,5gig very soon and the game crashs then...
I'll report my testings in here.

Edit 20:42
My memory usage of Sacred 2 Gold still goes to ~1,5GB but i have no crash for ~1,5hours or so

Edit 23:35
To set everything on 0 in options.txt does not help to me, i'll test it with 1.
The only thing, that realy cleans out the memory of Sacred 2 so far is pressing alt+tab... but for that you need to play *not* in windowed mode... That sucks and is annoying
Last edited by Sneak0r; Jun 6, 2013 @ 2:44pm
Shinzon Jun 8, 2013 @ 2:50am 
Pitty, that didn't helped. Only a few minutes of play and then Sacred 2 crashs :(. Tested with elite textures and maximum settings.

Edit:
Seems to work for me with standard textures and maximum settings. Memory was after 45 mins of play at 530 mb fixed.
Last edited by Shinzon; Jun 8, 2013 @ 3:42am
Sneak0r Jun 8, 2013 @ 5:54am 
I found out that with the memory settings to 1 Sacred 2 does not use more then 1GB of RAM but lags...
So I use the half of the standard values and it runs stable with less lags. I ended up at 3/4 of the values and played for more than 2 hours with no crashes. Memory usage of Sacred 2 was never above 1,3GB.
So for me was that the fix for my crashing problems

my pc settings:
Win7 Home Premium 64bit SP1
Intel Core i7-2600k CPU @ 3,40GHz
8 GB RAM
GeForce GTX 580

I have Sacred 2 Gold from Steam, so I have no access to elite textures so they are on standard, all max, PhysX active and AA on 2 (with AA on 4 the temple guard with aura causes lags)

All the other bullsthit like set admin rights or try compatibility mode of xp sp2/3 wont work.
pressing ctrl+f1 is also crap. Even to edit the files to use more then 2GB RAM doesnt work fo me - i wasnt able to start the game after that. To start Sacred 2 with startparameters doesnt help either.

How did your Sacred only use 530mb of Ram? If i start Sacred im at 700-800MB just in the menu oO
Last edited by Sneak0r; Jun 8, 2013 @ 5:58am
Shinzon Jun 8, 2013 @ 9:29am 
I don't know. After 45 mins i switched with ALT+Tab to desktop and opened taskmanager. And it shows there 530 mb at sacred2.exe.
What you can do is: what Matthew has already explained. Disable the ingame AA, instead enable in the driver menu FXAA, so the game needs less resources. Additonal i forced Anistropic Filtering in the driver menu. Sacred 2 settings are all at maximum, physx is enabled, too.

My PC settings:
Win7 Ultimate 64bit SP1
Intel Core i7 975 CPU @ 3,33 GHZ
12 GB RAM
Geforce GTX Titan

I have the retail Sacred 2 + Ice & Blood and bought a few months ago Sacred 2 Gold at Steam. So i have elite textures from the retail collectors edition, but with elite textures it will crash after a few minutes.
I have tested many things, but sacred 2 crahed all the time. I tested half values, how you explained and it works but was very laggy on some spots. With Matthews description it runs very smooth. So i hope that i finally can play sacred 2 without crash.
Sneak0r Jun 8, 2013 @ 9:53am 
Ah I see. You play Sacred in Fullscreen right? As I mentioned before, the game delete the trash in memory at the moment you press alt+tab! But I played in window mode. I also have 2 monitors (very good to check the taskmanager while gaming ;) )
I thought you checked your memory usage of Sacred 2 in window mode. Now its clear why you have only ~500MB memory usage.
Because of the lags at 50% memory values in options.txt, I set it on 75% of standard values.
Thats fine for me.

If you set all the memory values in the options.txt on 0 it means to Scared, that it can use your whole memory in theory. But Sacred is a 32 bit app and cant use more then 2 GB, so thats why it crashs if you reach ~1,5GB Memory.
Please do me a favor and check your memory consumption while you play in window mode.
Shinzon Jun 8, 2013 @ 10:05am 
When it crashs, i siwtch to desktop and it shows me arround 1,3 - 1,5 gb. Same thing i did with half values and there it was at 1,2 gb.
But yeah i can do.
Last edited by Shinzon; Jun 8, 2013 @ 10:05am
Sneak0r Jun 8, 2013 @ 10:32am 
Hmm ok so i have no solution for fixing the crashes yet :(
Except fullscreen mode and pressing alt+tab every 30-40 minutes...
Last edited by Sneak0r; Jun 8, 2013 @ 10:34am
Shinzon Jun 8, 2013 @ 10:34am 
ok you are right, it more than 530mb, it seems stable at 1,13 gb. is there a program, which i can log it?
Did you disable ingame AA?
Sneak0r Jun 8, 2013 @ 10:36am 
Yea and its my last test with the original settings of the topic. And this time I set a stopwatch and have a look to my memory.

Edit: crash after 25 minutes and ~1,33GB RAM usage -.-
Last edited by Sneak0r; Jun 8, 2013 @ 11:08am
Shinzon Jun 9, 2013 @ 2:19am 
Ok, it is still crashing :(. I played now one hour after try leaving a cave - crash. I run in the background ProcessExplorer and it shows at crash 1,5 gb.
Sneak0r Jun 9, 2013 @ 4:06am 
I've figured out something new. After reading over 6hours to find a good solution I tried something new. The good news is: I can play for 3 hours in a row with my shadow warrior with an army of minions on my ♥♥♥ without any crash!! *cheer*. The bad news is: I'm not 100% sure which of my 2 changes is the one, that fix the problem.

So here we go:
No1. my event log of windows told me the most time, that my mss32.dll in the sacred 2 folder cause a problem. With the last official patch of Sacred it has version 7.2e which should solve the memory leak.... I've downloaded a newer version (7.2g) of this file and replaced it (make a backup before).

No2. in %HOMEPATH%\AppData\Local\Ascaron Entertainment\Sacred 2 (the place where you can find the options.txt) I've created an "optionscustom.txt" which following text in it:

-- video
-- video.fullscreen = 1 -- Vollbild
video.fullscreen = 0 -- Fenstermodus

-- textures
-- manager.texMem = 201326592 -- 192MB
-- manager.texMem = 209715200 -- 200MB
manager.texMem = 268435456 -- 256MB
-- manager.texMem = 402653184 -- 384MB

-- granny 3d system
-- manager.grannyMem = 67108864 -- 64MB

-- animations
-- manager.animMem = 33554432 -- 32MB

-- trees
-- manager.sptMem = 8388608 -- 8MB

-- sectors
-- manager.secMem = 33554432 -- 32MB

-- genericmgr 16MB
-- shadermgr 4MB

-- meshes
-- manager.pmsMem = 8388608 -- 8MB

-- soundbuffer 0MB-255MB
-- sound.memorybudget = 80 -- 80MB
-- sound.memorybudget = 96 -- 96MB
-- sound.memorybudget = 128 -- 128MB
-- sound.memorybudget = 192 -- 192MB

I'll do some test with this config later on with PhysicX on and maybe AA 2x and switch to
"manager.texMem = 402653184 -- 384MB" in the "optionscustom.txt" if i get some troubles.

So far I can say it was my longest journey ever without any crashes since I've got that game :)
Last edited by Sneak0r; Jun 9, 2013 @ 4:14am
Shinzon Jun 9, 2013 @ 4:43am 
Did you change the options.txt or did you let it by default? And Sacred 2 reads the optionscustom.txt?
Last edited by Shinzon; Jun 9, 2013 @ 4:45am
Sneak0r Jun 9, 2013 @ 6:17am 
I let it by default. Sacred 2 ignores it supposedly on startup so you need to create a custom file like optionscustom.txt
Shinzon Jun 10, 2013 @ 9:13am 
Is it nessecary to skip "manager.texMem = 268435456 -- 256MB", because in front of it the "--" are missing. In addition sacred 2 runs in windowed mode, if i set in front of "video.fullscreen = 0 -- Fenstermodus" "--" it starts in fullscreen. Did you test in windowed mode?
Last edited by Shinzon; Jun 10, 2013 @ 9:16am
Sneak0r Jun 11, 2013 @ 12:45am 
for the moment I only play in windowed mode, yes. In the whole file are only 2 options activ.
That are "video.fullscreen = 0 -- Fenstermodus" and "manager.texMem = 268435456 -- 256MB".
Every entry with "-- " in front of it is disabled.
Actually I have "manager.texMem = 402653184 -- 384MB" enabled (delete -- in front of it and switch them in front of "manager.texMem = 268435456 -- 256MB"

Imho I guess that the main problem was the old mss32.dll. But if you don't replace it yet you can still try out only the optionscustom.txt and tell my what happend :)

For further researches it is also important that you have a look at the windows event log at every crash of sacred 2 that occur.
Last edited by Sneak0r; Jun 11, 2013 @ 12:48am
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Jan 10, 2013 @ 9:45pm
Posts: 17