Sacred 2 Gold > 一般討論 > 主題細節
belgarathmth 2012 年 12 月 31 日 @ 下午 4 時 42 分
CM patch says "language not supported" for English
Hi, I was going to possibly overwrite my 1.20 CMP version of Sacred2 Ice and Blood, with version 1.40, but, when I started to run the .exe, it said that my language was not supported. Both versions 1.30 and 1.40 appear to be for German speakers only at this point. I do not want to risk screwing up my install.

Is any other English speaker running either versions 1.30 or 1.40 with no language or stability problems?

Thanks.
顯示 1-13,共 13 則回應
< >
King_Kosher 2012 年 12 月 31 日 @ 下午 10 時 39 分 
Im playing the Game in english & am using the CM Patch so..no problems like you describet here
belgarathmth 2013 年 01 月 1 日 @ 上午 6 時 45 分 
Thanks, I got it to work properly by switching to the Steam version of the game. I'm not sure why it was having a problem with the old Deep Silver version.
Harlequin 2013 年 01 月 7 日 @ 上午 11 時 15 分 
@belgarathmth:

I'm having a hard time figuring out how to find the correct CM patch to install for the recent released Sacred 2 Gold version here on steam. If you could help that would be great! I assume it will be easy to install once I have the correct file. As mentioned above all I see is german stuff.
Fade 2013 年 01 月 7 日 @ 下午 1 時 18 分 
Harlequin 發表:
@belgarathmth:

I'm having a hard time figuring out how to find the correct CM patch to install for the recent released Sacred 2 Gold version here on steam. If you could help that would be great! I assume it will be easy to install once I have the correct file. As mentioned above all I see is german stuff.
http://allsacred.ru/cm-patch/ 1.40
belgarathmth 2013 年 01 月 7 日 @ 下午 2 時 53 分 
This index page has all the versions. As far as I know now, they all work just fine with the Steam version of the game, in English.

http://allsacred.ru/cm-patch/

The most recent version is 1.40hf. I don't like it, because it takes away the regional level caps. I use version 1.20.
最後修改者:belgarathmth; 2013 年 01 月 7 日 @ 下午 4 時 57 分
Fade 2013 年 01 月 7 日 @ 下午 3 時 23 分 
what do you mean by regional level caps and what exactly was hotfixed as im using just 1.40
belgarathmth 2013 年 01 月 7 日 @ 下午 4 時 55 分 
In the vanilla game, each region of the map has a maximum level of monsters, regardless of survival bonus, that only increases as new difficulty levels are unlocked. I like it that way.

For example, in silver level, the maximum monster level in Tyr Lysia is level 54. If you try to do anything in Tyr Lysia past level 55, the monsters will come up with white circles, and will yield no experience to kill.

With Community Patch 1.40hf, you could theoretically play on bronze level and see monsters all the way up to level 200 without ever leaving Sloeford. That ruins the game for me.
最後修改者:belgarathmth; 2013 年 01 月 7 日 @ 下午 4 時 56 分
Alondrix 2013 年 01 月 12 日 @ 上午 1 時 31 分 
Hey guys, I'm having trouble with the CM patch on the Steam version of Sacred 2 Gold. I'm running Windows 8 and tried installing CM patch 1.40 and 1.40hf from the link in this post. The first error is that the language isn't supported (English) and the second is that that the Sacred 2 Fallen Angle 2.65.x could not be located on my system. Any ideas what's wrong?
belgarathmth 2013 年 01 月 12 日 @ 上午 7 時 08 分 
Did you change the install directory by any chance? Both of those patch versions installed correctly on my default Steam installation: Program Files (x86)/Steam/Steamapps/Common/Sacred2Gold

EDIT: I just saw the "Windows 8" part. That might be your problem. I can't help there, as I will not be using Windows 8.
最後修改者:belgarathmth; 2013 年 01 月 12 日 @ 上午 7 時 09 分
Kurion 2013 年 01 月 12 日 @ 上午 9 時 49 分 
I think if you right click the patch file and choose run as administer it will work.
Alondrix 2013 年 01 月 12 日 @ 上午 11 時 04 分 
Thanks for the comments, but disregard. I had only downloaded the game and tried to apply the patch. I had to run Sacred 2 one time - apparently there are more files that need to be setup the first time you launch the program. Afterwards, I set the Sacred2.exe to Windows XP SP 2 compatiblity and everything seems to be ok.
SevR 2013 年 01 月 12 日 @ 下午 7 時 50 分 
The Ice & Blood expansion was never released in the U.S.A., previous to Steam's Sacred 2 Gold, so we needed to buy a U.K. version and change 2 registry keys and re-name 1 folder temporarily to get them to cooperate. If your having trouble with the communty patch try looking at these instructions for making a U.K. retail Ice & Blood run with a U.S. version of Sacred 2 Fallen Angel...

http://forum.sacred2.com/showthread.php?t=67312
belgarathmth 2013 年 01 月 13 日 @ 上午 6 時 36 分 
It shouldn't be necessary to do the registry manipulation with the Steam version of the game. I've had no trouble installing and uninstalling the community patch with Steam's default install on my Windows 7 rig.

But @Alondrix said he solved his problem and didn't need any more help, I think. Actually, that might have been the same thing that happened to me when I first made this thread - I tried to install the CP before having run the game once to let it do its initial setup.
最後修改者:belgarathmth; 2013 年 01 月 13 日 @ 上午 6 時 38 分
顯示 1-13,共 13 則回應
< >
每頁: 15 30 50
張貼日期: 2012 年 12 月 31 日 @ 下午 4 時 42 分
回覆: 13