BlackJay Dec 28, 2012 @ 2:38pm
Mouse not responding
win 7 64bit
logitech g15 keyboard and mx laser mouse
Geforce gtx670
Game loads and the sacred mouse pointer shows but does not respond.
Have googled and tried solutions offered from this board and others without positive results.
Sigh
Showing 1-14 of 14 comments
< >
encogen Dec 28, 2012 @ 2:58pm 
Try alt-tabbing and going back into the game. If the screen remains black, move the mouse around - chances are you'll hear the "clicks" when hovering over the menu buttons. I get this occasionally - usually blind-click the "quit" button to force the game into showing the Y/N prompt, then continue on with the game.
Zidders Roofurry -{EAC}- Dec 28, 2012 @ 3:09pm 
Also try updating drivers.
Melonman67 Dec 28, 2012 @ 3:24pm 
Do you see the menu or just a black screen? I've had the issue of a visible but non-interactive menu screen for a while now. Sock's suggestion of alt-tabbing worked fine in the past.

I am thinking this is due to the intro videos because after installing the community patch, I no longer see the videos nor have this issue.
BlackJay Dec 28, 2012 @ 5:17pm 
I can see the screen. The game cursor does not move. I can move my mouse and watch for it to light up a command screen, like start game, and it will run but silll no mouse cursor.

Drivers are updated. Alt tabbing does not help.

Thanks for the suggestions. Will keep trying.
Zidders Roofurry -{EAC}- Dec 28, 2012 @ 5:38pm 
Try turning off hardware cursor in the mouse options. also, try running it in windowed mode.
judasace Jul 31, 2013 @ 7:39am 
And how are yous supposed to turn off the hardware cursor when you can't see the mouse pointer to select the option?
RitualMurder Jul 31, 2013 @ 11:43am 
having same issue
i realized tho that the mouse IS there we just cant see it
if i move my mouse around i can see it highlight the menu options but its invisible
which makes it almost impossible to use
yay for ♥♥♥♥ty games
lindhoffen Jul 31, 2013 @ 12:22pm 
I have the same problem. The mouse cursor is there but it's invisible. /facepalm
Cat Toaster Aug 1, 2013 @ 10:03am 
Same problem here, with and without Community-Patch, with and without PhysX, With and without XP SP3 Compatibility Mode. Running as Admin with UAC disabled. I use just the common WIndows mouse drivers (who installs mouse drivers nowadays since WIndows XP? - rhetorical question). Alt-Tabbing does not help as well. Looks like freeing up 13GBs will solve the problem forever.
lindhoffen Aug 1, 2013 @ 12:34pm 
Originally posted by Cat Toaster:
Looks like freeing up 13GBs will solve the problem forever.

I couldn't be bothered with the game so I uninstalled it.
Crazier Oct 20, 2013 @ 6:44pm 
I had the mouse problem as well and what solved it for me was changing the font size in Win 7. I run 2560x1440 on my monitor with the font normally at 150%. Changing it to 125% lets the mouse work in Sacred 2.
lindhoffen Oct 23, 2013 @ 9:32am 
I've switched to a 27" iMac since my last post so I won't be playing this crap game very soon.
tazamiga Oct 26, 2013 @ 11:24pm 
thanis so much , that did the trick changing font size. Really good game and a bargain at this price , Enjoying it alot. It actually looks quite stunning in 1440p
Showing 1-14 of 14 comments
< >
Per page: 15 30 50