FuZzNuG- Dec 25, 2012 @ 4:02pm
After downloading and installing on windows 7
Hello everyone. Alright I got the game working fine great. Theres no need to download any community patches if you are purchasing the Sacred 2 Gold Edition off of Steam. Lets start with the first thing you need to do after downloading and installing the game.
Step 1: Restart your computer.

Step 2: Find your Sacred 2 Gold File.. Its probably in Program Files (x86) and heres what you need to be in Computer > Local Disk (C:) > Program Files (x86) > Steam > Steam Apps > Commom > Sacred 2 Gold > System. Now once your here scroll down and fine the sacred2 application it should be around 3,296 KB..

Step 3: Right click the sacred2.exe you just found in step 2 and go to properties.. find the compatibility tab and click it... now check to "run this program in compatibility mode for:" and choose Window XP service pack 3.. also check to run as administrator.. apply the settings and click ok..

Step 4: Play the game and enjoy... And if you get an error about a physXloader or something.. just follow this process...

Find your Sacred 2 Gold Folder in steam.. you should open like this Computer > Local Disk (C:) > Program Files (x86) > Steam > SteamApps > common > Sacred 2 Gold > redist > PhysX > now just run the physx installer, install it and then the game should run fine...

These were my exact steps on my rig.. check out my profile for my rig specs.. Sacred 2 Gold is running perfect for me on Ultra High settings... Also like I said earlier... There is no need for any of the community patches... In-Game my sacred 2 gold says its version 2.65

UPDATE: I actually have to recommend the community patch after downloading it. For a simple reason.. More content!
Last edited by FuZzNuG-; Aug 1, 2013 @ 7:29pm
Showing 1-15 of 29 comments
< >
JustPorter Dec 25, 2012 @ 4:39pm 
Is this really required for the Steam version? I just installed my stand alone version yesterday and it ran first try without doing anything special. I was thinking about picking it up again on Steam just for the simple installation.
FuZzNuG- Dec 25, 2012 @ 4:55pm 
i dont think its the same for everyone... i know after i downloaded and installed i tryed to play and nothing happened. its not loading the game for some people.. this is what i had to do to play the game.. all i did was change the compatibility to windows xp sp3 and install the physxloader that the game needs in its files..
trulyepiclag Dec 26, 2012 @ 7:41am 
Thank you for this! Game would not work until I followed both of your steps to fix and now it runs perfectly!
FuZzNuG- Dec 26, 2012 @ 6:26pm 
Your welcome. Also, trulyepclag, or anyone playing this game for that matter. If your not liking the camera angle's try this. Go to you gameplay options in game and drag the min.max all the way to the right. This takes away from zooming in and out, but allows you to see more on the screen.. Im not too sure how this will work with other resolutions. I use 1920x1080 myself.. looks great like this. anyways hope everyone enjoys..

By the way i know the main 2 sacred 2 sites have been down since mid december.. if anyone needs help in game i can gladly answer questions you may have.
Reynolds Dec 27, 2012 @ 9:12am 
I have windows 7 64 bit and all i had to do is press play
Surikatus Hohotunus Vulgaris Dec 27, 2012 @ 10:46am 
That part about community patch is completely unnecessary, as it never addressed any technical issues, only gameplay stuff - if the game crashes on startup, it'll crash regardless of CP being installed or not.

That said, everyone should try running the game first to see if there are any issues to begin with. I'm on 32-bit Win7, and just fired up the Steam version without any compatibility modes or what have you.
Last edited by Surikatus Hohotunus Vulgaris; Dec 27, 2012 @ 10:51am
FuZzNuG- Dec 27, 2012 @ 4:14pm 
Like I said above.. It is NOT the same for everyone... Some people may already have the PhysXLoader from installing something else. Not all computers are the same. Some of us did not have the privelage of the game starting right up after installation. I just posted the way i had to fix mine because I noticed there are several post in regards to how to get the game to work.. About the part where I said theres no need for community patch.. Almost every reply for a "fix" suggest that you download community patches and install them in a specific order.. All I was saying is you dont need it.. The steam version is all patched up from I have seen so far.
Dolan:pls_GER Dec 29, 2012 @ 7:16am 
It's working! Thanks, man! UP.
Chika Ogiue Dec 30, 2012 @ 2:37am 
In my case, all I did to get the game to run on Win 7 64 was:

1 - Rename all redist exe files (PhysX installer, VC installer, DX installer) so Steam doesn't install them.
2 - Set Sacred 2 exes to run as admin.
3 - Deleted the Options.txt left over from a previous (non-Steam) version of Sacred 2 Gold.

The Options.txt if it exists will be found in C:\Users\USERNAME\AppData\Local\Ascaron Entertainment\Sacred 2.

Game ran within minutes. As opposed to the near hour it took to get the non-Steam version running. And the added bonus is that there's no need to fix the PhysX installer by reinstalling the Nvidia drivers.

If the memory leak problem is still present, that too should be fixable by halving mem values in the options.txt file, according to the following:

http://forum.sacred2.com/showthread.php?t=69858
SilverStar Dec 30, 2012 @ 7:38pm 
You really don't have to do ANY of that. Not even the physx stuff. It didn't install an old version of physx (just berified, still using 9.12.1031, installed from the latest nvidia drivers), didn't have to futz around with any permissions (as long as steam itself is set not to run with compatibility mode, as it was wont to do when Win7 first launched). Just click play, let it do its normal things for VC redist and specific DX dlls as it would on any game, and it'll play just fine.
Chika Ogiue Dec 30, 2012 @ 8:28pm 
Originally posted by SilverStar:
You really don't have to do ANY of that. Not even the physx stuff. It didn't install an old version of physx (just berified, still using 9.12.1031, installed from the latest nvidia drivers), didn't have to futz around with any permissions (as long as steam itself is set not to run with compatibility mode, as it was wont to do when Win7 first launched). Just click play, let it do its normal things for VC redist and specific DX dlls as it would on any game, and it'll play just fine.

For some, that will be correct. For myself and others, that won't let the game run.
SilverStar Dec 31, 2012 @ 5:00am 
Originally posted by Chika Ogiue:
Originally posted by SilverStar:
You really don't have to do ANY of that. Not even the physx stuff. It didn't install an old version of physx (just berified, still using 9.12.1031, installed from the latest nvidia drivers), didn't have to futz around with any permissions (as long as steam itself is set not to run with compatibility mode, as it was wont to do when Win7 first launched). Just click play, let it do its normal things for VC redist and specific DX dlls as it would on any game, and it'll play just fine.

For some, that will be correct. For myself and others, that won't let the game run.
Are you sure you're running Sacred 2 GOLD? Regular Sacred 2 needs all the horrible tweaking to make it run nicely on Win7, but GOLD does not. A friend of mine made that very same mistake, not realizing this is the version with the expansion that was not available in north america previously, and what they were using was just regular Sacred 2 (which runs like crud on Win7, even if you do enable compat mode)
Chika Ogiue Dec 31, 2012 @ 6:05am 
Originally posted by SilverStar:
Are you sure you're running Sacred 2 GOLD? Regular Sacred 2 needs all the horrible tweaking to make it run nicely on Win7, but GOLD does not. A friend of mine made that very same mistake, not realizing this is the version with the expansion that was not available in north america previously, and what they were using was just regular Sacred 2 (which runs like crud on Win7, even if you do enable compat mode)

Considering that I purchased Sacred 2 on Steam at release, then Sacred 2 Gold on GamersGate a while later and then got a gift of Sacred 2 Gold on Steam, yes. I'm very sure I'm playing Sacred 2 Gold. I'm also very sure that the non-Steam version of Sacred 2 Gold has a lot of issues and some of those issues are still in the Steam version. I know this, as the first time I ran the Steam version of Sacred 2 Gold, it crashed. As did it on the second and third time, until I implemented the steps I stated above, where the crashes ceased and the game became playable. And FYI, I don't need to use compatibility modes to run Sacred 2 Gold either the GamersGate or Steam version.

Like most games what works for some PC configurations, will not work for others.
Quilldragon Jan 4, 2013 @ 1:22am 
im trying to follow this guide, but i run into a brick wall on step 3. after right clicking the .exe and hitting properties, there is no so-called "compatibility" tab. and i cant figure out how to proceed from here. ive been waiting many many months for sacred 2 to be released in gold on steam, have been waiting since release for gold to play it. i finally buy it, and when i click play after install after the first time set-up, nothing happens. its very frustrating.
FuZzNuG- Jan 4, 2013 @ 8:49pm 
Sorry about your troubles Quilldragon. Have you got the game running yet?
Showing 1-15 of 29 comments
< >
Per page: 15 30 50
Date Posted: Dec 25, 2012 @ 4:02pm
Posts: 29