tawnos76 Apr 1, 2013 @ 11:28pm
How to Get your Sacred 2 Gold to work on Windows 7
Most users have had problems with this games compatibility and it freezing on the loading screen. This should work in getting it to work for most Users.

First go to the executable file usually found in your SteamLibrary - SteamApps - Common - Sacred 2 Gold - System
Put the Sacred2.exe file into your desktop as a shortcut.
Right click and go into properties and change it to Windows XP (Service Pack 3) mode
Then add this to the end of the executable: -skipopenal -nocpubinding
Should look something like this:
"G:\SteamLibrary\SteamApps\common\Sacred 2 Gold\system\sacred2.exe" -skipopenal -nocpubinding

Oopen up steam as usual but now just use this shortcut link to play the game instead.

This should get your game working.

I have been playing this since Win XP and once I moved to Win 7 I had to change the file up this way to get it to work. I purchased the Steam version as it was one of the few ways to get the expansion for it so I have had to go back and do the same thing again to my executable file and now it works like before.

I hope this helps for those who have not gotten it to work before.
Last edited by tawnos76; Apr 1, 2013 @ 11:30pm
Showing 1-3 of 3 comments
< >
Helvetica Apr 2, 2013 @ 6:48am 
Also, if your game is stuttering, try turning PhysX off.
MadOrange64 Apr 2, 2013 @ 9:49am 
mine work just fine
King_Kosher Apr 2, 2013 @ 3:17pm 
How to avoid a lot of Hassle: Rightclick the Game in your Library--> pick "Properties"---> pick " set launch options" and there paste things like "-skipopenal -nocpubinding".

No need for Shortcuts...its 2013 ;)
Last edited by King_Kosher; Apr 2, 2013 @ 3:18pm
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Apr 1, 2013 @ 11:28pm
Posts: 3