ihsirig1 Mar 13, 2013 @ 11:58am
Sacred 2 Gold won't start
I'm asking for help! I'm pretty much at the end with my nerves...I've tried everything what is written here but unfortunately, I can't start the game.I have deleted it several times and then downloaded again, manually started the .exe files in the "redist" folder - every time restarted the computer but no luck. When I want to start the game I get this message "Failed to start game (unknown error)". What I find strange is that in the "system" folder the sacred2 launch.exe does not exist - I have only a "sacred2-Game client" and a "sacred2-Game server" .exe and that's it.
Please, can someone help me ?
I apologize for my english, I'm in learning process :)

Windows xp64 sp2
geforce 8800 GT
Intel Core duo E8200 @ 2.80GHz
4 GB RAM
Showing 1-15 of 20 comments
< >
Siddha Mar 13, 2013 @ 2:38pm 
Hi. Also ask over on Darkmatters forum.
There must be a solution for your prob.
TheMidnightMeatTrain Mar 13, 2013 @ 3:14pm 
I just downloaded this last night and have the exact same problem.
Crispin Mar 13, 2013 @ 3:15pm 
Have you guys tried the compatible option ?
BurningTofu Mar 13, 2013 @ 6:57pm 
It has issue with Firewall I believe. This has been proven to work with Win7 32bit/64bit and also Win8 32bit/64bit.

First and formost, verify integrity for the game to download all missing files.
1) Goto C:\Program Files (x86)\Steam\SteamApps\common\Sacred 2 Gold\system
2) Find Sacred2.exe
3) Right click and Click properties
4) Click Capabilities tab
5) Change to Windows XP SP3 on drop down menu after checking the "Run this program in capability for"
6) Click okay and run the Sacred2.exe using Admin privilage.
7) Let it load and exit the game.
8) You should now see a new popup asking to allow the program to access firewall.
9) Choose allow or whatever you prefer
10) Change the capability mode back to your own OS so you can take advantage of SLI or CrossFire if you have such setup.
11) Run the game under Admin again and enjoy.
Last edited by BurningTofu; Mar 13, 2013 @ 7:01pm
ihsirig1 Mar 13, 2013 @ 11:06pm 
Thanks for the answer but the problem is that the Sacred2.exe does not exist. It should be in the "system" folder but it isn't. I checked the integrity several times, deleted 5 times the game and downloaded it again but the same issue...
D# Mar 13, 2013 @ 11:33pm 
search your computer
ihsirig1 Mar 14, 2013 @ 1:38am 
I try but no Sacred2.exe...:(
What is even more strange that the game shortcut on the desktop is not a sacred logo, it's an undefined icon like this: http://filext.com/images/icon_unknownassociation.gif
YuSuke Mar 14, 2013 @ 3:46am 
Did you try rebooting your computer?
ihsirig1 Mar 14, 2013 @ 4:24am 
Yes, every time after manually starting the .exe files in the "redist" folder and not just that, I made a new, fresh installing of windows just to be sure that it's not corrupted but no luck :(
HardyHero Mar 15, 2013 @ 6:26am 
Download this... http://www.nvidia.com/object/physx-9.10.0513-driver.html
and unisntall old version.
So... install the new version downloaded.


Afeter, Steam\steamapps\common\Sacred 2 Gold\system\sacred2.exe and use XP SP2 compatibility mode.

Works here.
SasukeOfTheLeaf Aug 1, 2013 @ 1:45am 
i purchased Scared 2 in the Humble Bundle and had the same problem, i got it to work in 5 mins just change the compatibility mode and added this below.
you can insert the parameters (-nocpubinding -skipopenal) into Steam shortcut (the one in your Library) by selecting Properties in context menu and typing them in "Set launch options".
It should work just as a modified shortcut on the desktop.
Murder Aug 3, 2013 @ 8:04am 
Oddly, I was able to open the game directly from the install folder. Every time I would run from Steam, it would run in the background, but I couldn't alt+tab to it. After that, I've been able to run it from steam every time. Not sure what exactly is going on here, but I don't think it's anything major to worry about.
wrockwilder Aug 4, 2013 @ 8:27am 
I get an error requiring the missing PhysXLoader.dll? Why a game would end up on steam and not work on high spec machines. I have 7970 2GB 32 GB Ram AMD A10-4600. And I am surprized the game runs into a problem.
Ols Aug 4, 2013 @ 10:22am 
I had the same problem for the first time i run the game, but this solution helped me:

Browse to your Sacred 2 Gold installation folder (Usually C:\Program Files\Steam\steamapps\common\Sacred 2 Gold\)

Run the following installers:
...\Steamapps\common\Sacred 2 Gold\redist\DirectX\DXSETUP.exe
...\Steamapps\common\Sacred 2 Gold\redist\VC\vcredist_x86.exe
...\Steamapps\common\Sacred 2 Gold\redist\PhysX_9.10.0513_SystemSoftware.exe

Reboot your computer.

(source: https://support.steampowered.com/kb_article.php?ref=8367-QYJC-1351 )
King_Kosher Aug 4, 2013 @ 11:11am 
Originally posted by wrockwilder:
I get an error requiring the missing PhysXLoader.dll? Why a game would end up on steam and not work on high spec machines.
Yes,why does a game end up on steam where you have to install additional dependencies.How dare they
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Mar 13, 2013 @ 11:58am
Posts: 20