MancVanDaL Oct 24, 2013 @ 4:36pm
For those having trouble running the game ...
I had this issue tonight. I went into the game folder and into the REDIST folder. In there are three files, DirectX, PhysX and VirtualC (VC). I tried the PhysX first, but it's an old version and the install was aborted because I have a newer version. Try that first, but if it installs you're better off getting the new version afterwards. Next I tried the VC Redist and that installed fine. The game then worked fine.

Give that a try, if not try the DirectX as a last resort and see what happens.

GL!
Showing 1-3 of 3 comments
< >
Never Go Full Derpy Oct 25, 2013 @ 9:53pm 
The game would not event start up for me and immediately exit. Windows 7 64-bit.

I had to set the compatibility of Sacred2.exe all the way to Windows 2000. (Right click on Sacred2.exe, go to Compatibility tab)

I skipped over PhysX, DirectX, and VCRedist, as I already have all that installed.

I am playing the game, and it is stable, on the highest setting with everything maxed. The game simply does not recognize Win7 or latest OS.

MancVanDaL Oct 26, 2013 @ 1:58pm 
I didn't have to do that to get it going. I'm on Windows 8.1. Still, s'long as you got it going, that's the main thing. Something else for others to try :)
Hurleyinoz Oct 26, 2013 @ 2:14pm 
Ive tried all of the suggestions and it is still not opening. I get a brief glimpse at the steam 'starting for the first time' screen before i closes. Im not getting any error messages. Not particualrly impressed after a 13gb download!
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Oct 24, 2013 @ 4:36pm
Posts: 3