xg_k_gaming Oct 24, 2013 @ 1:14pm
Game refuses to open.
I tried opening it from my Documents, from the Library and from Start->team(Drop down) then to the game, it comes up with the varification window , i press yes.. then thats it, Steam says that my last play time is "today" when i press it, but it doesnt even open, tried it atleast 2x a week, every week for the past month or two.. and just WILL NOT open. Any1 got any ideas on how to fix?
Showing 1-13 of 13 comments
< >
Jammy Bastard Oct 24, 2013 @ 1:16pm 
Steam -> Steamapps -> Common -> Sacred 2

Set Sacred2.exe and S2GS.exe to compatibility for Windows XP, check the run as admin box too.
mosqueira Oct 24, 2013 @ 3:09pm 
Install nvidia physis x even if you have amd video card. Should work! =D
MancVanDaL Oct 24, 2013 @ 4:25pm 
I had this issue. Go into the game folder in Steam and look for the REDIST folder. Make sure all those are installed. It was the VC (virtual C) that was stopping mine from running. Once installed, it worked fine.
Kasia Oct 26, 2013 @ 6:15am 
Try to run as administrator in system files. I was have the same problem and it was work for me.
Mike Oct 27, 2013 @ 3:18pm 
Also go to device manager and disable your Intel HD 4000 or whatever secondary graphics card you may be running. It worked for me.
Cordell Oct 29, 2013 @ 12:58pm 
This worked for me (after a reboot), my HD crashed so I must have lost the Physx after formatting. Thanks!
Originally posted by mosqueira:
Install nvidia physis x even if you have amd video card. Should work! =D
Mike Oct 29, 2013 @ 2:09pm 
Originally posted by Cordell:
This worked for me (after a reboot), my HD crashed so I must have lost the Physx after formatting. Thanks!
Originally posted by mosqueira:
Install nvidia physis x even if you have amd video card. Should work! =D
Also go to device manager and disable your Intel HD 4000 or whatever secondary graphics card you may be running. It worked for me.
Jammy Bastard Oct 29, 2013 @ 2:12pm 
Originally posted by Mike:
Also go to device manager and disable your Intel HD 4000 or whatever secondary graphics card you may be running. It worked for me.

You already said that and it's not always a surefire solution. It could potentially lead to other issues.

This game doesn't properly support anything past XP, you have to run compatibility mode and check the admin box to get it to boot.
Last edited by Jammy Bastard; Oct 29, 2013 @ 2:12pm
mart19880121 Oct 29, 2013 @ 2:54pm 
same issue...not playing
mart19880121 Oct 29, 2013 @ 3:00pm 
Changed to XP compatibility mode and run as admin. Now says the program can't run because PhysXLoader.dll is missing from the computer.

Anyone else encounter this?
mart19880121 Oct 29, 2013 @ 5:55pm 
Originally posted by MancVandaL:
I had this issue. Go into the game folder in Steam and look for the REDIST folder. Make sure all those are installed. It was the VC (virtual C) that was stopping mine from running. Once installed, it worked fine.

This fixed my problems and now it's playable. Thanks
Mike Oct 30, 2013 @ 1:59am 
Originally posted by mart19880121:
Originally posted by MancVandaL:
I had this issue. Go into the game folder in Steam and look for the REDIST folder. Make sure all those are installed. It was the VC (virtual C) that was stopping mine from running. Once installed, it worked fine.

This fixed my problems and now it's playable. Thanks
http://youtu.be/m6IjiZjyuLg
Holst Nov 1, 2013 @ 6:35pm 
Originally posted by xg_k_gaming:
I tried opening it from my Documents, from the Library and from Start->team(Drop down) then to the game, it comes up with the varification window , i press yes.. then thats it, Steam says that my last play time is "today" when i press it, but it doesnt even open, tried it atleast 2x a week, every week for the past month or two.. and just WILL NOT open. Any1 got any ideas on how to fix?

Did you have the old version installed prior to buying Sacred 2 Gold? If so, I have tip that may help.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Oct 24, 2013 @ 1:14pm
Posts: 13