Sacred 2 Gold

Sacred 2 Gold

katlyn71449 May 14, 2014 @ 7:17pm
Can't open game
I just finished downloading it and now everytime I try to play, a message comes up saying "Do you want the following program from an unknown publisher to make unknown changes to this computer?" when I press yes, a steam window comes up for less than a second, disappears and then nothing happens. Does anyone know how to fix it? I would prefer not to have to reinstall it because I literally just spent fourteen hours downloading it due to slow wifi. Thanks!
< >
Showing 1-15 of 32 comments
katlyn71449 May 14, 2014 @ 7:18pm 
Oh, and I forgot to mention that I have Windows 7 if that helps.
katlyn71449 May 14, 2014 @ 7:58pm 
I tried to run it as an administrator and now it says "The program can't start because orcSystem.dll is missing from your computer. Try reinstalling the program to fix this problem." :/ Anyone know a fix other than reinstalling?
Glorious Catbug May 15, 2014 @ 3:21am 
The same happens to me, went through a long download and now I'm really angry cause I can't play
0rigins May 15, 2014 @ 4:02am 
I have the same problem...
Locke May 15, 2014 @ 4:45am 
Same problem. I noticed in my Task Manager "Sacred 2 - Game Client (32 Bit)" is running in the background.
HazMatt( ͡° ͜ʖ ͡°) May 15, 2014 @ 5:14am 
me too :(
georgli May 15, 2014 @ 5:48am 
me too
Plinky May 15, 2014 @ 6:19am 
goto : http://www.dll-download-system.com/home/o-dlls-not-system-/orcsystem.dll/details.html

download and extract the orcsystem.dll to your steamapps/common/sacred 2 gold/system folder then register as the link says.

give that a go
seville57 May 15, 2014 @ 8:12am 
Workin for me, usin win 7 64 bits.
Smeghead May 15, 2014 @ 8:19am 
I have the same issue
ZjebanyChuj May 15, 2014 @ 9:44am 
same here
Lego2 May 15, 2014 @ 10:57am 
Hi everyone ! I had the same issue.(sorry for my english)
- Go to local folder. (steamapps>Sacred2)
- Right click on Sacred 2 then properties
- Compatibility tab and select windows xp (service pack 3)
Worked for me !

katlyn71449 May 15, 2014 @ 2:36pm 
steve, now it says MemMgr.dll is missing from my computer. *Sigh*
stuff.zip, unfortunately that didn't work for me!
Thanks for trying to help guys!
katlyn71449 May 15, 2014 @ 2:39pm 
Wait... I removed the new Orcsystem that steve told me to download, put the old one back and started browsing the internet again and suddenly the game popped up! Hopefully it will continue to work! :)
Plinky May 15, 2014 @ 3:18pm 
lol.. well at least something worked 4 u :D
< >
Showing 1-15 of 32 comments
Per page: 15 30 50

Date Posted: May 14, 2014 @ 7:17pm
Posts: 32