Sacred 2 Gold

Sacred 2 Gold

Bardo May 13, 2014 @ 11:24pm
Game won't start
Anyone else having trouble launching this game? Tried compatibility mode, running as administrator, etc. No matter what, game gets stuck loading engine and crashes. Using W8
< >
Showing 1-15 of 28 comments
Yumgumbo May 14, 2014 @ 8:10am 
The Sacred 2 game client runs in the background, but the game never starts for me. I am also running Windows 8, btw.
apeofset May 14, 2014 @ 8:30am 
Same problem here. starting it in admin mode also does noet help
KapteinKush May 14, 2014 @ 8:53am 
Yea same problem :( The client is running in the background but the game wont start, im also using win8... Hope someone can come up with a fix for this bc i really wanna play this game :D
Fenauri May 14, 2014 @ 8:57am 
Same problem but with compatibility mode and running as administrator it worked. Windows 8.
TheHolyOne May 14, 2014 @ 11:58am 
Same prob here. I got it started but everything is black. Looks like this http://i.imgur.com/U7ieBZJ.jpg
Last edited by TheHolyOne; May 14, 2014 @ 12:05pm
Bardo May 14, 2014 @ 12:29pm 
Ok game fixed after actualizing Pshyx driver. Worked for Risen 1 and 2 and this game :D
Jazman2k May 14, 2014 @ 1:39pm 
How do i actualize physX drivers? I have the same issue. Game wont start, or starts, but is just on backround.
THA HOOP GAWD May 14, 2014 @ 3:45pm 
I got the game to launch after installing the fan patch (see http://steamcommunity.com/app/225640/discussions/0/828939163601565843/) but once the game launches past the main menu, the resolution gets all screwy. (win8)
Last edited by THA HOOP GAWD; May 14, 2014 @ 4:02pm
TheMRAlvaro97 May 14, 2014 @ 4:00pm 
ihave the same problem and i use w8
CrimzonRazor May 14, 2014 @ 4:08pm 
are you useing W8 or 8.1 because 8.1 is much more stable when it comes to games. Alot of stuff I had that would not run on W8 started working when I updated to 8.1. Might be worth a try if you havent upgraded yet. Other then that all I had to do is set it to run xp service pack 3 and it ran no problem.
Last edited by CrimzonRazor; May 14, 2014 @ 5:34pm
Gus May 14, 2014 @ 4:15pm 
My problem says driver:nvd3dum.dll
nxcreatephysicssdk failed
setup failed
d.j.h_95 May 14, 2014 @ 5:23pm 
i had the same problem all i did was go into the properties the browse local files go to redlist then physX the click the folder inside it should install the latest software and before all this i did verifty all my files then it worked
TheHolyOne May 15, 2014 @ 7:50am 
I have AMD not nivida so physx will lag the game.
Andi May 15, 2014 @ 7:59am 
I got the game to run by updating physX .. now it's stable.
KapteinKush May 16, 2014 @ 8:49pm 
Originally posted by R4gegamingstudios:
I have AMD not nivida so physx will lag the game.
Yea update your phsyX driver.. That was the thing i had to do to play it. I have W8 and amd gpu if thats help you :)
< >
Showing 1-15 of 28 comments
Per page: 15 30 50

Date Posted: May 13, 2014 @ 11:24pm
Posts: 28