Retro Bliss Jul 7 @ 2:03pm
What I did to get this game to FINALLY work!
I have a Lenovo I7-4700MQ 2.40GHz
with a GeForce GT 755M card
8gigs of ram on 64 bit running Windows 8

I first went into Steam\SteamApps\common\Sacred 2 Gold\system and then changed the file "s2gs" and "sacred2" to run in compatiblility mode for "windows XP (Service Pack 3)" and also checked to run both as an administrator.

Then I went to my Library tab in steam and went to the Sacred 2 Gold properties and put this "--nocpubinding --skipopenal" on the lunch options (without the quotation marks).

After that I went and download the legacy Physx drivers becasue the new Physx drivers don't want to work for this game.
http://www.nvidia.com/object/physx-9.12.1031-legacy-driver.html

Hopefully these steps help someone else. I have been trying for days and thanks to a lot of other people on this forum I was able to get it working.
Last edited by Retro Bliss; Sep 2 @ 10:00am
Showing 1-6 of 6 comments
< >
sbviper Jul 7 @ 2:06pm 
I never put in the launch options to mine working. They're probably not needed.
Retro Bliss Jul 7 @ 2:09pm 
For some reason I just needed all those 3 things in tandem I guess. I didn't think everyone would need them all just thought it would be useful to have them all together.
Last edited by Retro Bliss; Jul 7 @ 2:11pm
sbviper Jul 7 @ 3:48pm 
I guess bottome line is getting the game going. kudos!
UABBlazers Jul 7 @ 6:49pm 
I have perhaps the same computer (at least the same specs) and all I had to do was have Win 8 set the compatibility for the program. Sacred 1 was more difficult for me to get working properly (had to change settings in GPU control panel).
tekhedd Jul 13 @ 3:15pm 
XP Compatibility mode (XPSP3) with -skipopenal worked for me (Win7/64/AMD/X-Fi). Oh, and I also did the trick where you rename the Laptop DLLs, but I doubt that's needed.

Of course, now I get the "welcome to the Ice and Blood expansion" popup every single time I load a game, but I guess that's life. :)

Mine was stable for about 10 hours then would repeatedly crash at the same point. Not sure which part of the fix fixed it, but there it is.
Last edited by tekhedd; Jul 14 @ 9:11pm
LazyFly Jul 14 @ 5:23pm 
I have the same setup as the parent and all I had to do was change the compatability (I just used the compatability wizard when right-clicking the two files mentioned above).
Showing 1-6 of 6 comments
< >
Per page: 15 30 50