Sacred 2 Gold

Sacred 2 Gold

ShiveringSun Jul 4, 2014 @ 3:33am
Bluescreen error... maybe related to having a X-Fi Titanium?
This can happen with Path of Exile and is fixed by adding -swa to the launch options in the Steam client. Does anyone have any experience with Sacred 2 and this issue?

Maybe it has nothing to do with X-FI, but it felt similar to what happened in POE.

Relevant info: I have set both s2gs.exe and sacred2.exe to XP SP3 compatability, renamed the 2 "laptopgaming" .dll's to .bak, made a shortcut to sacred2.exe and added -nocpubinding -skipopenal, and installed the community patch.

With this done, I played for a bit over an hour with graphics options maxed + physX on (crashed fairly quickly once in game before the above, though no bluescreen), then the bluescreen occurred.

I really don't like bluescreen errors... so I will wait to see if there is any advice out there.

Comp is win7 64, i72600k, 780 gtx, 8GB ram, P8Z68-v Pro mobo, Corsair HX 850 power supply, and the X-Fi Titanium.

Edit: This must have been the bluescreen.

Log Name: System
Source: Microsoft-Windows-WER-SystemErrorReporting
Date: 03/07/2014 4:33:52 PM
Event ID: 1001
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: ...
The computer has rebooted from a bugcheck. The bugcheck was: 0x00000019 (0x0000000000000022, 0x2000000000000000, 0x0000000000000000, 0x0000000000000000). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 070314-17019-01.
Event Xml:
<Event xmlns="">
<Provider Name="Microsoft-Windows-WER-SystemErrorReporting" Guid="{ABCE23E7-DE45-4366-8631-84FA6C525952}" EventSourceName="BugCheck" />
<EventID Qualifiers="16384">1001</EventID>
<TimeCreated SystemTime="2014-07-03T20:33:52.000000000Z" />
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Security />
<Data Name="param1">0x00000019 (0x0000000000000022, 0x2000000000000000, 0x0000000000000000, 0x0000000000000000)</Data>
<Data Name="param2">C:\Windows\MEMORY.DMP</Data>
<Data Name="param3">070314-17019-01</Data>
Last edited by ShiveringSun; Jul 5, 2014 @ 11:21am
< >
Showing 1-1 of 1 comments
ShiveringSun Jul 5, 2014 @ 11:21am 
So, apparently this was related to PhysX, even though I have the legacy drivers installed. After de-selecting the physx option I have successfully played for 4 hrs straight with no problems, at otherwise maximum settings.

Not a big loss... leaves blowing around is nice, but the game looks good without it.
< >
Showing 1-1 of 1 comments
Per page: 15 30 50

Date Posted: Jul 4, 2014 @ 3:33am
Posts: 1