Duke Nukem 3D: Megaton Edition > Γενικές συζητήσεις > Λεπτομέρειες θέματος
termit  [δημιουργός] 5 Οκτ, 2013 @ 11:38πμ
Multiplayer BETA (Public Beta)
We have pushed MP BETA. Please have a look and give us a feedback. Just note that this is not the final version. Also note that it's a p2p multiplayer, so you will get better experience if you play with local players with small ping.

How to switch to beta:
Right click on the game in Library->Properties->Betas->Public Beta

http://i.imgur.com/cs7vxHM.png

1.1.2 BETA

- Min ping changed to 200
- Added some mp maps from Duke Xtreme
- Added respawn markers option in lobby setup screen
- Filtering off non-english symbols from nicknames
- Trimming nicknames on statusbar and score screen
- Removed non-exiting maps from lobby map select screen
- Blocked level changing in DM
- Blocked multiple click on "Start" button
- Blocked start MP game with 1 player
- Removed fraglimit/timelimit 1
- Fixed COOP settings reset
- Fixed problem with friends invite
- Fraglimit now consider suicides
- Other bug fixes and improvements

1.1.3 BETA

- Multiplayer for expansions (except NW).Invites doesn't work properly for expansions for now
- Separate x/y mouse sensitivity sliders
- Smother mouse aiming switching
- Fixed saves loading
- Not saving game when player dead
- Save files now uploaded to cloud right after game saved
- Force respawn in DM
- Fixed layout for lobbies list screen
- Filters for lobbies list
- SPACE to refresh lobbies list
- Fixed: message sending causing activation of inventory item
- Some netcode improvements
- Other bug fixes and improvements

1.1.4 BETA

- Now a player can disconnect without breaking the whole multiplayer session (unless the player is a server). Still WIP
- Fixed Linux usermaps issue
- Fixed lobby list issue
- Fixed wrong map loading in expansions SP after playing MP
- Fixed menu sounds playback in multiplayer game when pressing right mouse button
- Coop fixes, also "insta-kill" bug should be fixed too


1.1.5 BETA

- Now a player can disconnect without breaking the whole multiplayer session (for both client and server)
- MP achievement not counting coop kills
- Added to notify changes in lobby
- Finally fixed SP usermaps issue for Linux
- Checking if player logged in Steam
- Some other bug fixes and improvements

1.1.6 BETA

- fixed "Time out" issue and issue with starting second mp game
- fixed some coop mid-game crashes
- some other bug fixes

1.1.7 BETA

- Initial Workshop support for maps (works fine for SP and partially for MP)
- Added command-line tool for Workshop maps publishing
- Fixed crash on level change in COOP
- Other bug fixes and improvements

1.1.8 BETA

- Lobby chat
- Fixes for Workshop support
- Bug fixes

1.1.9 BETA

- Fixed multiplayer info issue
- Ping check for invited users
- Other fixes

1.1.10 BETA
- Polymost lighting/shading from EDuke32

1.1.11 BETA
- Added ogg music support for workshop maps. Ogg file should be named like the map. Works only for newly downloaded/subscribed maps.
- Fixed issues in command-line publishing tools

1.1.12 BETA
- MP stability fixes
- Force resync to avoid out of sync
- As an experiment ping limit is set to 300
- Added "-noanim" launch option to skip all cutscenes/cinematics
- Added "delete-saves" launch option to remove all save files both from cloud and locally

1.1.14 BETA
- MP stability improvements and fixes

1.1.15 BETA
- MP stability improvements and fixes

1.1.16 BETA
- Lighting/shading fixes

1.1.17 BETA
- MP stability improvements and fixes

1.1.18 BETA
- Fixed issues with retro/smooth texture, that appeared after 1.1.16 BETA

1.1.19 BETA
- MP stability improvements and fixes
- Added logs generation. So if you have a crash or freeze, provide us stdout.txt and stderr.txt files
- Fixed issue X Axis scale sensitive set to 0 for some users

1.1.20 BETA
- Fixed "Time out" issue, but probably broke some other stuff, so you maybe should wait for next version

1.1.21 RC1
- Fixed the issue when while starting a new game sometimes all players being kicked out to singleplayer
- Fixed crash during workshop map download when joining a lobby
- More stability fixes

1.1.22 RC2
- Reliably packets delivery
- Attempts to reduce lags
- Fixed client disconnect issues
- Fixed issue with negative ammo
Τελευταία επεξεργασία από termit; 24 Ιαν @ 4:58μμ
Εμφάνιση 1-15 από 1,556 σχόλια
< >
گᖾއᑯວ 5 Οκτ, 2013 @ 11:41πμ 
Nice can't wait to try it out :)
haha nerds... 5 Οκτ, 2013 @ 11:41πμ 
Finally, will try it
Shaggy 5 Οκτ, 2013 @ 11:42πμ 
Let's rock!
گᖾއᑯວ 5 Οκτ, 2013 @ 11:45πμ 
Hm seems i keep getting stuck at "Retrieving Lobby Info" when i try to join a lobby.
termit  [δημιουργός] 5 Οκτ, 2013 @ 11:46πμ 
Αναρτήθηκε αρχικά από گᖾއᑯວ:
Hm seems i keep getting stuck at "Retrieving Lobby Info" when i try to join a lobby.
Try to restart the game
Τελευταία επεξεργασία από termit; 5 Οκτ, 2013 @ 11:46πμ
Matt 5 Οκτ, 2013 @ 11:46πμ 
Try another game

One thing of note: When I joined this lobby the "loading faces of death" screen showed up three times
termit  [δημιουργός] 5 Οκτ, 2013 @ 11:47πμ 
Αναρτήθηκε αρχικά από Matt:
Try another game

One thing of note: When I joined this lobby the "loading faces of death" screen showed up three times
screenshot?
Matt 5 Οκτ, 2013 @ 11:49πμ 
Αναρτήθηκε αρχικά από termit:
Αναρτήθηκε αρχικά από Matt:
Try another game

One thing of note: When I joined this lobby the "loading faces of death" screen showed up three times
screenshot?

Don't have a screenshot sorry, but it was just the loading screen, faces of death being the level I was playing on of course

I basically had the loading screen, then some in-game noise with Duke saying "Yeah, Piece of Cake" then returning to the loading screen, in a loop, on the third time however, the in-game graphics rendered and the game began fine
Matt 5 Οκτ, 2013 @ 11:55πμ 
Another small bug I found - when exiting the game (back to desktop), the stat's screen of the previous game you were in is displayed, pressing a key at this stage will then exit the game (Windows)
MrTrololosh 5 Οκτ, 2013 @ 11:56πμ 
It's a bit laggy, but it's still rocks!
So, what can i say.
I saw pretty much bugs in there, but it dose'ht mean i doesht haved fun.
I played DM with some guys.
First bug i saw in the lobby, when all players set to ready, the Start button shows not only at Host player, but on a Client player as well. Or was this planned? I not sure.
Second one - low framerate and high ping at the match beginning. Perhaps, i't should be working this way, because Duke servers compiling information before running normal.
Third one - visual bug with player that used Steroids. He clonned. He clonned AS HELL MANY TIMES.
And last one - match was stopped, no exit message, just one frame on the screen. But when i tryed to exit to lobby, he did that vell and showed scores screen. BUT, WHEN I QUIT TO SESCTOP, GAME SHOWED SAME SCORE SCREEN AGAIN.
I hope this will help you, dear fellas. Thanks for letting us testing it!
Matt 5 Οκτ, 2013 @ 11:58πμ 
The Steam Overlay also does not work during the score screen, which prevents screenshots from being taken, there is also a small bug where the server list is still active after searching (on the Retriving lobby info screen) - Currently unable to find what's causing it, appears to be random

Screenshot of Lobby bug - http://steamcommunity.com/sharedfiles/filedetails/?id=183750233

Edit: Lobby bug appears to be caused by moving through the menus with the mouse fast - using the keyboard does not seem to cause issues

Video: http://www.youtube.com/watch?v=8jE0WjN-vac&feature=youtu.be
Τελευταία επεξεργασία από Matt; 5 Οκτ, 2013 @ 12:03μμ
گᖾއᑯວ 5 Οκτ, 2013 @ 12:02μμ 
Αναρτήθηκε αρχικά από termit:
Αναρτήθηκε αρχικά από گᖾއᑯວ:
Hm seems i keep getting stuck at "Retrieving Lobby Info" when i try to join a lobby.
Try to restart the game
I think i figured it out i think it was my nickname گᖾއᑯວ

Also evreytime i launch the game it glitch (never ending loading) and mouse get stuck at the top left corner until i press windows key and now the game loads.
Τελευταία επεξεργασία από گᖾއᑯວ; 5 Οκτ, 2013 @ 12:06μμ
haha nerds... 5 Οκτ, 2013 @ 12:06μμ 
I've only been able to actually join a lobby two times. One time we got a game started, and the other time it was like I was the only person in the lobby. All the other times I've just been stuck on the "Retrieving lobby info" message.
Matt 5 Οκτ, 2013 @ 12:06μμ 
Αναρτήθηκε αρχικά από Shado:
Αναρτήθηκε αρχικά από termit:
Try to restart the game
I think i figured it out i think it was my nickname گᖾއᑯວ

Also evreytime i launch the game it glitch (never ending loading) and mouse get stuck at the top left corner until i press windows key and now the game loads.

That's a steam glitch iirc, unfixable by General Arcade
Druaga 5 Οκτ, 2013 @ 12:08μμ 
Αναρτήθηκε αρχικά από haha:
I've only been able to actually join a lobby two times. One time we got a game started, and the other time it was like I was the only person in the lobby. All the other times I've just been stuck on the "Retrieving lobby info" message.
Same here, except i've only been able to join one lobby so far. But when I joined, i think the other player left and the lobby was just sitting there empty, in limbo. My name wasn't even in the list. When I tried hosting though, a guy came in for a few seconds and left. Not sure if he actually made it in or not.
Εμφάνιση 1-15 από 1,556 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 5 Οκτ, 2013 @ 11:38πμ
Αναρτήσεις: 1,641