Duke Nukem 3D: Megaton Edition

Duke Nukem 3D: Megaton Edition

View Stats:
Lee Jan 30, 2014 @ 8:04pm
Unstable Connection... Every time
I have closed everything on my computer that uses the internet, but every time I try to join a lobby I get 'Unstable Connection'. I have tried joining about 40 different lobbies now and it's always 'Unstable Connection'. Just now I tried playing a co-op game with my brother who lives 20mins away by train. But every time we try to join one another's lobby, 'Unstable Connection'. It just seems completely impossible to play any multiplayer at all.

I'm curious if anyone else is getting this same error over and over again and if you've found a way to fix it.
< >
Showing 1-14 of 14 comments
Vocal Luminary Jan 30, 2014 @ 8:58pm 
Try joining mine, I seem to have stable connection. Many people have been able to join an play with me. Good Luck and NUKEM!
Lee Jan 30, 2014 @ 10:32pm 
If I friend you could you maybe invite me to join your lobby?
Sexy T-Rexy Jan 31, 2014 @ 5:00am 
doesnt happen to me
schloegi Jan 31, 2014 @ 5:45am 
could be that the players are too far away, as the game relies on p2p for multiplayer
H 4 Z E Jan 31, 2014 @ 9:26am 
tthis game laggy as hell even though i have a stable connection and 130mb up internet speed.
>M@tEo$< Jan 31, 2014 @ 1:51pm 
Originally posted by e'MoTiiOnZz:
tthis game laggy as hell even though i have a stable connection and 130mb up internet speed.

Keep in mind it also depends on the other players connection quality (and not speed).
Lee Jan 31, 2014 @ 6:35pm 
I give up. I'll just wait for the next update before I try again.
Vocal Luminary Jan 31, 2014 @ 9:27pm 
I wish the best for you.
Sixty Four Jan 31, 2014 @ 11:25pm 
I can try to play with you bud. Friend me and we can play
pagb666 Feb 1, 2014 @ 7:56am 
The quality of the connection is the real thing, I can join 90% of the games at home... but when I try from my job (worse connection, higher overall latency despite its speed) I can't join a single lobby no matter how much I try.
Lee Feb 2, 2014 @ 1:29am 
Okay. So my brother changed some of his router settings and we tried again. It worked. We played through Episode 1 on LR difficulty, and started a CGS difficulty coop for Episode 2. The game froze during E2M2 and we were forced to close our games. Besides the game freezing everything was working perfectly.
>M@tEo$< Feb 2, 2014 @ 3:10am 
What did he change?
Lee Feb 2, 2014 @ 3:15am 
He says DMZ & NAT settings.
Canog Jul 10, 2014 @ 2:58pm 
The same problem here... How can I fix it?
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Date Posted: Jan 30, 2014 @ 8:04pm
Posts: 14