Brothers - A Tale of Two Sons

Brothers - A Tale of Two Sons

View Stats:
shiivas Jun 30, 2014 @ 2:22pm
i cant launch the game
every i try launch it doesn't work. help me :(
< >
Showing 1-5 of 5 comments
danieleferris Jul 29, 2014 @ 12:34am 
i've had the same issue but i solved repairing the framework. In this link the instruction https://www.youtube.com/watch?v=gHqjTSI0TlY
Fox Oct 3, 2015 @ 4:57pm 
I tried that fix, didn't help at all. I also can't get Terraria to launch either if that helps. Every other game seems to work just fine though. Trying to play it on a dedicated gaming rig.

I have yet to be able to give this game a chance and see what the hype is about. :(

Any help would be appreciated.
Last edited by Fox; Oct 3, 2015 @ 4:58pm
Fox Oct 11, 2015 @ 7:36pm 
It's been over a week... no one at all is around to help me? Is the community here completely non-existant now?
IamPANDAMAN Oct 16, 2015 @ 1:51pm 
I have the same issue :( Anyone??
Fox Oct 19, 2015 @ 8:42pm 
I just figured out the issue and the game runs now.

It was a .NET Framework issue, but that video was useless for me, after failing to load Sony Vegas Pro and giving the reason why it failed, I decided to try and re-install the .net framework which didn't work cuz I already had it installed, so I just repaired the one that was already installed and both the game and video editor works perfectly now.

This link should fix it for you: http://www.microsoft.com/en-us/download/confirmation.aspx?id=30653
Just download and install / or you can try to repair the .NET Framework you likely already have installed. (go to Control Panel / Programs and Features and look for "Microsoft .NET Framework 4.5.2" or similar).

Hope this helps.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50