Spectromancer > 一般討論 > 主題細節
Sohon 2012 年 10 月 31 日 @ 上午 7 時 03 分
need update.
right now.
顯示 1-11,共 11 則回應
< >
h4 2012 年 10 月 31 日 @ 下午 8 時 30 分 
I agree. Its a fun game to play once in a while but it seems forgotten by the devs.

EDIT: oh you meant the new Gathering of Power expansion. Yeah 6 days ago and no mention on steam. dunno if its a steam issue or they do not prioritize steam version.
最後修改者:h4; 2012 年 10 月 31 日 @ 下午 9 時 05 分
Viebator 2012 年 11 月 2 日 @ 上午 1 時 18 分 
+1
Scorpiuscat 2012 年 11 月 2 日 @ 下午 10 時 16 分 
Seems you can just download it from the website and install it in your Steam file and it works just fine...no need to pay for anything apparently.
davidevolta 2012 年 11 月 4 日 @ 上午 1 時 26 分 
You need to pay, you need to pay... Updating the game or installing it by zero will grant you only the warrior priest for free, but the update cost $10!!!

The setup file downloadable from the official site is not good for the steam version

Don't understand why steam don't say a word about this new expansion
경금속 2012 年 11 月 13 日 @ 上午 5 時 38 分 
srsly need update.
kerzain 2012 年 11 月 13 日 @ 上午 8 時 06 分 
pallor 發表:
srsly need update.
Yes. Still waiting for it to hit Steam before I update my two household copies.
Stubbie 2012 年 12 月 12 日 @ 上午 11 時 19 分 
Still no ability to add the expansion through Steam.
Come on Valve. We've waited long enough.
Zadkiel 2012 年 12 月 15 日 @ 上午 11 時 33 分 
i bought truth and buety, league of heroes, but it hasn't sent me the activation codes... how do i get them to work

Spectromancer  [開發人員] 2012 年 12 月 18 日 @ 下午 12 時 41 分 
The update is coming soon.
Quitch 2013 年 01 月 26 日 @ 下午 4 時 44 分 
The Steam version still appears to only install 1.21, you need to sign-on to the Online League to get 1.3.
Mahuloq 2013 年 01 月 27 日 @ 上午 2 時 06 分 
This worth getting?
顯示 1-11,共 11 則回應
< >
每頁: 15 30 50