OmniShift Jan 28, 2013 @ 8:25am
How do I get this game to start?
I may be asking something really ♥♥♥♥♥♥♥♥, or maybe I've got a problem, but when I start the game with steam, Dosbox opens saying "DOSBox version SVN. Copyright 2002-2010 DOSBox Team, published under GNU GPL" and it does absolutely NOTHING. I can't type any commands, I can't open the TOMBRAID.EXE file manually due to compatibility. I deleted it and reinstalled it, but the same problem persists. What do I need to do to get this game running?
Showing 1-8 of 8 comments
< >
Showtime, Synergy! Jan 28, 2013 @ 11:19am 
No idea. Can you grab a standalone version of Dosbox and see if that starts up okay, lets you type commands, etc?

http://www.dosbox.com/
OmniShift Jan 28, 2013 @ 11:45am 
Ok, I've downloaded it, checked out how to use it, I've mounted the TOMBRAID directory (for which I had to copy the files to a directory that didn't had any spaces), and when I execute the tomb.exe file in boxdos, it says "ERROR: Please insert the TombRaider CD"
Showtime, Synergy! Jan 28, 2013 @ 3:28pm 
Oh, I didn't intend for you to actually run TR from the new Dosbox installation. I was just saying you could troubleshoot by seeing if Dosbox does "absolutely nothing," like the Steam installation seemed to.

Anyway, if you're trying to run the game from the new Dosbox, you need to mount the game's CD. Try this command, modifying the path to game.dat if necessary:

imgmount d ".\game.dat" -t iso -fs iso

That will put the game's disc into the virtual D drive, like the game expects.

I anticipate another problem though; the standard Dosbox 0.74 distribution does not include GLIDE-wrapping support, which the Steam version of Tomb Raider uses. For that you can grab what's called an SVN version, which often includes a GLIDE wrapper and various other enhancements.The one I personally use is Dosbox Daum, available at http://ykhwong.x-y.net/. Alternately, another one with GLIDE support is Gulikoza's build.
OmniShift Jan 29, 2013 @ 10:13am 
I've tried to follow those instructions for as much as I understood them (sorry, Im really not used to use anything like this and I have no idea what all these commands do) and I don't see how I'm supposed to start the game. I've mounted the game.dat file to a virtual drive, but how do I start it? It doesn't show up as a drive on My Computer (like programs such as Daemon Tools do). If I did something wrong, could you try to explain it to me like Im 10? :P
Showtime, Synergy! Jan 29, 2013 @ 11:21pm 
Ah. Well, I don't want to lead you too far down the rabbit hole, then.

When you mount a virtual drive in Dosbox only Dosbox will see it as a drive. You won't find it out in Windows.

It'd be a lot easier if I could see your screen. My best advice is to delete the local files and re-download. If it's still messed up your system seemingly has a problem with something TR's installation of Dosbox is trying to do. Sorry I can't be more helpful.

Here's one last idea. After you've redownloaded TR1 go in steam\steamaps\common\Tomb Raider (I)\tombraid and rename the current tomb.exe to tomb3dfx.exe (or whatever) and rename tombno3dfx.exe to tomb.exe. See if the game works then. That will make it use the software renderer instead of the 3dfx GLIDE renderer. Not as pretty, but maybe it'll at least work?

Okay, really the last one: maybe your computer is having an issue with the Dosbox renderer setting. Go into the dosboxTR.conf and find the "output=[something]" line. I don't remember what Steam has it set to by default. If it says direct3d change it to openglnb; if it says openglnb change it to direct3d, and see if the game works then. If you read the commented lines above that section you can find other possible values to try for the "output" setting, too.
Last edited by Showtime, Synergy!; Jan 29, 2013 @ 11:27pm
OmniShift Jan 30, 2013 @ 7:06am 
I tried all of that, but still no luck :(
Thanks for trying though.
Showtime, Synergy! Jan 30, 2013 @ 9:52am 
No worries. Maybe try asking on another TR forum?

official TR classic tech help forum:
http://forums.eidosgames.com/forumdisplay.php?s=623bc93a092016a37666c57c67a90cd3&f=107

other oldschool TR community forums, some quite busy:
http://tombraiders.net/stella/community.html
OmniShift Jan 31, 2013 @ 4:01am 
I've also contacted Square Enix support for this problem and I've just received a solution that works for me. For everyone else who has this problem: I was told to make a new user account with admin rights and run steam in compatibility mode (95/98 doesn't work, so I got it to work in NT) and as admin. Without creating a new user account, that didn't work. No idea why this turns out to solve it though. I've replied with questions on if I can make it run on my normal account, to which I will hopefully receive a reply soon.

Also, I have very minor audio problems (sometimes audio switched back and forth between 2 sources, making it very hard to hear the right audio track, but this usualy fixes itself after a couple of seconds, and there's a slight audio delay of about 1 second). I've asked if they know a solution for that as well. Other than that, it seems to work like a charm. I'll keep people posted on the solutions of these 3 remaining questions.


EDIT: They've responded, telling me that all they can tell me is that it's a difference in settings of the different user accounts. What exactly, they don't know, but the only way to find out is to change settings until it's fixed or to reinstall Steam.
As for the audio: they've recommended me to change my system audio output to 16-bit 44,1kHz or to try other options if that doesn't work.
Last edited by OmniShift; Jan 31, 2013 @ 8:04am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50