Temujin May 29, 2013 @ 8:35pm
some achievements not working?
anyone else got problems with certain achievements that don't unlock such as the xerg fighter one and several more?
Showing 1-15 of 41 comments
< >
Azatoth Oct 1, 2013 @ 3:12am 
I am having problems with some as well. I managed to get some by deleting the saves and config files then restarting the computer. I still get issues though. Currently all my medals have disappeared and it seems I am not getting achievement for 500 salvage.
Vano47 Oct 4, 2013 @ 2:13am 
Same thing here: can't get achievement for fully upgrading korean ship. I'll try deleting save once I complete game
Azatoth Oct 4, 2013 @ 2:34am 
I think I found the solution. You will need to exit the game and restart it. Either begin a new game or select a level where you know you should have gotten an achievement, continuing will not work. Play through again and DO NOT look at stats on the pause menu. It seems checking progress stops achievements and medals from registering.
Try it and let me know how it geos.
Mgr. fullBlue Oct 17, 2013 @ 10:29am 
I´ve got the same problem. Restart of game didn´t work. Either reinstall didn´t help. I tried to find and delete all files of this game located on my computer, but my saves are still active. Can you tell me please, where can I find and delete saves? I didn´t find them in C:/Program Files/Steam/SteamApps/Common/Iron Sky Invasion... :-(
Azatoth Oct 17, 2013 @ 12:01pm 
They are in your documents folder. For Win7 it is Users\{you}\AppData\Local\Iron Sky\
Mgr. fullBlue Oct 18, 2013 @ 10:20am 
I have Win8 x64, there is nothing corresponding to Iron Sky Invasion in my documents folder... :-(
Paindemonium Jan 21 @ 9:34am 
Same problem here... I unlock 4 achievements and sundly when I destroy Hermman crusier, and get spirfire, I didnt get nothing... I try 2-3 times and nothing.
Conrad Jan 23 @ 9:42am 
There are 9 achievements I was unable to unlock for this game. They were all in chapters 2 & 4, so I am assuming the problem is with those levels in particular. I have tried deleting and re-installing the game, deleting save files and starting from the beginning. Nothing seems to work for me.
Black Rapist Jan 24 @ 3:48pm 
Maybe this is a time for spam to game support? More ppl=higher attention.
Paindemonium Jan 25 @ 6:49am 
I think ill just play this game and finish it at all... support will do nothing for this game becouse its just licence game, just for fast sell and make money. Thats all :/. Bad, becouse game have fun...
Black Rapist Jan 25 @ 11:53am 
But still we can please for remove some not working achiv.
Azatoth Jan 25 @ 11:59am 
Try looking for a folder called 224900, this is the app id. Maybe files there that need removing.
The important bit to remember, dont look at stats. No point clearing, then checking them to see if its working as it is likely to break it again.
gerne93 Feb 1 @ 4:09pm 
worked fine here ... did they patch somethig?
Dromedarius Feb 3 @ 8:56pm 
I need to achieve complete all the missions of the American president.
In the last of their missions, capturing a ship Walkyr, I get the mission completed when captured, but when I leave the area the ship is directed only to the space station UUS, and when it gets blocked I get to the mission , and I can not complete the achievement. I tried to take it to Earth but can not ...
I need help and advice to complete this mission because I've tried everything.
Dromedarius Feb 4 @ 4:16am 
Solved. They have to be the active panel medals.
Showing 1-15 of 41 comments
< >
Per page: 15 30 50