Super House of Dead Ninjas

Super House of Dead Ninjas

View Stats:
 This topic has been pinned, so it's probably important
LastSide Aug 6, 2013 @ 12:08pm
Low FPS
Anyone else having problems with the game when its on fullscreen?

It runs like less than 30 fps! I dont remember having this problem when the game came out.
< >
Showing 1-15 of 48 comments
nded03 Aug 6, 2013 @ 1:02pm 
Yup, game is supper choppy in fullscreen mode now.

Edit: Wait, now it's running fine for me. Weird.
Last edited by nded03; Aug 6, 2013 @ 1:03pm
Bitmap Bureau  [developer] Aug 6, 2013 @ 1:05pm 
Originally posted by LastSide:
Anyone else having problems with the game when its on fullscreen?

It runs like less than 30 fps! I dont remember having this problem when the game came out.

It could be that the game's "renderMode" isn't set to the best setting for your particular setup - I know I was playing around with it during testing in an attempt to improve the performance for all users, and I assumed that setting renderMode to "auto" would be the best option. Give this a go and see if it helps:


To begin with go to your SHODN directory, for example:

C:\Program Files (x86)\Steam\SteamApps\common\super house of dead ninjas\META-INF\AIR

...and edit "application.xml" in your text editor of choice. Now try changing the setting on the line below from "auto" to "direct", "cpu", or "gpu".

<renderMode>auto</renderMode>

...and see if it has any effect. I was hoping this setting could be changed in-game, but I'm pretty certain that it can only be set in the application.xml file. Let me know if you have any luck, but I'll see if I can do anything else to help too!
nded03 Aug 6, 2013 @ 1:14pm 
Setting it to "cpu" seems to yield the best performance for me, but now whenever I switch to fullscreen I get crazy screen tearing.
Bitmap Bureau  [developer] Aug 6, 2013 @ 1:34pm 
Originally posted by nded03:
Setting it to "cpu" seems to yield the best performance for me, but now whenever I switch to fullscreen I get crazy screen tearing.

Ah, any chance of a screenshot?
LastSide Aug 6, 2013 @ 2:02pm 
In my experience you are bound to have slow down on all modes(cpu seems ok) but, for me the best is direct.

It takes a lot of time before I get a drop on fps. Reached the first boss, no problem. When starting the second area had a bad slowdown, way bad for about 30 secs then it went back to normal.

Killed the second one and on the third area had random slowdowns (the slowdown option is off).

On the final boss there was a permanent slowdown, , I could actually doge the energy balls, killed Abargus on Hard mode...

On cpu, the game graphics were a bit choppy and the game looked like it wasnt running to its full potential like it does on direct. On gpu, had more and more slowdowns than direct.

Im gonna try a full run on cpu. On cpu didnt had a single problem on slowdown. The game runs a bit choppy but I think its doable.
Last edited by LastSide; Aug 6, 2013 @ 2:16pm
Tetsuo9999 Aug 6, 2013 @ 6:03pm 
I'm also experiencing framerate problems, while I've never had that problem before on this computer. I assume it's due to a change in the code with the DLC update. Is there any way I can fix this, or will I have to wait for a patch? I run the game in windowed mode, if that's any help.
Packrat Aug 6, 2013 @ 6:07pm 
I've been getting framerate drops ever since the July update. Try playing in windowed mode with smoothing turned off. That helped a lot for me: still get noticeable slowdown at times, but not bad enough to negatively impact gameplay.
Bitmap Bureau  [developer] Aug 6, 2013 @ 6:08pm 
Originally posted by Tetsuo9999:
I'm also experiencing framerate problems, while I've never had that problem before on this computer. I assume it's due to a change in the code with the DLC update. Is there any way I can fix this, or will I have to wait for a patch? I run the game in windowed mode, if that's any help.

I think I'm going to switch the renderMode back to direct for the next update (probably tomorrow) as that's what Adobe recommend, and it seems to give most players the best performance. You can do that for yourself in the meantime though by following the instructions above, editing the application.xml file. I'd be interested to know if it helps!
Mir Aug 7, 2013 @ 3:06am 
The renderMode fix worked absolute wonders for me. Thanks so much to everyone who figured it out!

Personally, setting it to cpu works best for me in conjunction with making absolutely sure I set SHODN.exe's task priority to High in Task Manager (and setting pretty much all nonessential processes to low or closing them outright). Realtime helps to speed things up as well, but this comes at the price of heavily distorting the game's sound. I have to do this every time I boot the game since it starts out set at Low priority. With this setup I average about 50 FPS, as opposed to the 30 or so I've been pulling since February. It's not perfect, but the game feels playable to me for the first time in a loooong time.

Seriously, thank you so much and sorry if any of my posts ever came off as ♥♥♥♥♥ing. Couldn't have come at a better moment, since I just bought the DLC too. I'm so glad I can enjoy this game again <3
Bitmap Bureau  [developer] Aug 7, 2013 @ 4:01am 
Originally posted by Makura Sensei:
The renderMode fix worked absolute wonders for me. Thanks so much to everyone who figured it out!

Personally, setting it to cpu works best for me in conjunction with making absolutely sure I set SHODN.exe's task priority to High in Task Manager (and setting pretty much all nonessential processes to low or closing them outright). Realtime helps to speed things up as well, but this comes at the price of heavily distorting the game's sound. I have to do this every time I boot the game since it starts out set at Low priority. With this setup I average about 50 FPS, as opposed to the 30 or so I've been pulling since February. It's not perfect, but the game feels playable to me for the first time in a loooong time.

Seriously, thank you so much and sorry if any of my posts ever came off as ♥♥♥♥♥ing. Couldn't have come at a better moment, since I just bought the DLC too. I'm so glad I can enjoy this game again <3

Not at all - you pay money for a game, so you should expect it to work nicely on your machine! I think that renderMode setting is pretty important though, and it would be handy if users could alter it in-game rather than having to open up the application.xml file. I'll see if there's a way of doing that, but in the meantime you could make your life a little easier by creating a batch file to run SHODN at high priority; just create a batch file in the game's folder (where SHODN.exe can be found), call it "SHODN.bat" or whatever and then paste this line in:

start "SHODN" /high SHODN.exe

Running that batch file will always run the game at high priority then - let me know if you have any problems!
Bitmap Bureau  [developer] Aug 7, 2013 @ 6:26am 
Hmmm...is the slowdown happening after you reach Abarghus or when you play Transdimensional Leakage I wonder? I'd also be interested in knowing if you're returning to the title screen at the end of each game, retrying immediately, or going through the lodge? As for supporting the game, I think it's something that all developers should do really, and I enjoy talking with the community anyway, unless you're reporting nasty bugs. ;) Best of luck at uni - are you hoping to go straight in to game design, or perhaps start in QA?
Woop I deleted the post to make my own thread whilst you where answering so I'll put it back :)

Mmm I still have the problem of the game slowing down after a few hours of game play or re-launching the game mutiple times. Restarting steam does nothing however restarting my PC works great and things run smooth again... It’s very interesting I get the feeling memory isn’t being emptied correctly somewhere and restarting steam doesn’t help so it’s most probably a Flash thing.

The most interesting thing is if it starts running slow and I go do something else work on Eclipse for 30min or so and launch SHODN again the slowness is gone. This reinforces my theory something isn’t being emptied or reset until I launch another application or a default timer is clearing/resetting the data.

I know nothing about Flash as a language sooo I can't really theorize any further

I have tried the solutions suggested in other threads, using a .bat file to allocate high priority lowering setting just for the lolz (my rig Dxdiag posted in my "My finding thread" it’s more than adequate)

BTW great work with the support MegaDev, I’m actually studying Game Design and Entertainment at Uni and you are one of the Developers In a way I aspire to being like with your devoted support to the players and dedication to bettering the game you make etc… :3


Originally posted by Megadev:
Hmmm...is the slowdown happening after you reach Abarghus or when you play Transdimensional Leakage I wonder? I'd also be interested in knowing if you're returning to the title screen at the end of each game, retrying immediately, or going through the lodge? As for supporting the game, I think it's something that all developers should do really, and I enjoy talking with the community anyway, unless you're reporting nasty bugs. ;) Best of luck at uni - are you hoping to go straight in to game design, or perhaps start in QA?

It can happen anywhere dosent matter TDL, Adomain or just normal tower. and I re-try immediately unless I feel like switching up my gear or going chaos mode etc.. I can't see any pattern to the slow down that could help you debug sorry.

As for Uni well I have done an Adv,Diplomer in Network Security then I started to do my Bachelor in it, but after long deliberation I strongly believe I will enjoy game design more as I have played around with making games in python and such. I received much more joy from that then designing a network. The option for game design I have is Bachelor in game design and entertainment that’s just about the only one I have for game related stuff in the Australian Unis, What’s QA ? lol
Last edited by Sys.out.println("Hi")™; Aug 7, 2013 @ 6:38am
Bitmap Bureau  [developer] Aug 7, 2013 @ 7:02am 
Oh, "QA" is "Quality Assurance" - it's a fancy term for testing. ;) That's how I got started, and it's a good way of getting in to the games industry, if you can hack playing the same game every day for the best part of a year or maybe more!
junkboy Aug 7, 2013 @ 9:28am 
I had not played for some days, today i logged in and had an automatic update of about 35Mb i guess. And at the moment my gameplay is choppy as well. At windowed mode. No problem at full screen mode. Was not happening before that update neither at windowed nor full screen mode. Any chance we will be getting any fix for that?

Last edited by junkboy; Aug 7, 2013 @ 9:43am
Boog Aug 7, 2013 @ 10:17am 
My game runs pretty smooth, until I get killed or kill a boss. During the death of myself or a boss, the game slows to a crawl (5-7 fps) while the death scene is playing out. Once all the powerups and blood are out, the game returns to normal.
< >
Showing 1-15 of 48 comments
Per page: 15 30 50