DCT 10 jul 2013 om 8:09vm
Game updated, now runs so slow it's unplayable
What happened? the game was running fine before the update dropped and now no matter what I do settings wise, run in a window, turn everything down. The game just plays at a snails pace. I am talking about 5 frames per second here.. It's things like this that make me detest Steam's auto-patching system now I can not play a game which ran fine just one update ago.
Laatst bewerkt door DCT; 10 jul 2013 om 8:12vm
1-15 van 133 reacties weergegeven
< >
Megadev  [ontwikkelaar] 10 jul 2013 om 8:18vm 
Sorry to hear about that - can you tell me some more about your machine's specs? And you can you tell me what CPU percentage the game is using?
RK Cola 10 jul 2013 om 8:20vm 
Try turning off V-Sync in you video card settings because my game runs fine but I have V-Sync off in my video card, see if it helps. Beside that I would not know anything else.
DCT 10 jul 2013 om 8:24vm 
Origineel geplaatst door Megadev:
Sorry to hear about that - can you tell me some more about your machine's specs? And you can you tell me what CPU percentage the game is using?

well it's a old peice of crap that so a pentium dual core 2.5 ghz with a standard gma(x4500hd) as for cpu it's using about 25-31% when running. Again not the best thing in the world but it was above what the games minunium requirements were and pre-patch ran beautifully. Guess I may just chalk it up to a game I won't touch again till my gaming rig is done
Megadev  [ontwikkelaar] 10 jul 2013 om 8:30vm 
Well the game shouldn't run much slower before - updating the game to use a 16:9 aspect ratio means that more pixels are being drawn, but I wouldn't have thought that would be the cause, especially if the title screen seems sluggish too. Sometimes AIR runs at a crappy framerate even though CPU usage is less than 1%. If you've got any browsers open containing Flash components then I'd recommend closing them, and a good old restart never hurts. Let me know if you have any luck - there's a few other things we can try.
monsterpancake 10 jul 2013 om 8:32vm 
Also just for fun, please close and restart your Steam client. We saw this issue earlier and it "fixed itself" with the update. Keep us posted.
Ellis in Wonderland 10 jul 2013 om 8:34vm 
Got the same slow down issue, although it seems to run fine in window mode (though i hate playing in windowed mode). In fullscreen it uses up to 10 % of cpu percentage, in window somewhat between 5 and 6 %.

System specs:
CPU: i5-2450 CPU 2,50 Ghz
video card: Nvidia geforce GT 630M (it doesnt let me disable vsync)
zeroxxx 10 jul 2013 om 8:39vm 
I think I already reported it somewhere.

This game sometimes slows itself down. I'm sure my spec is way overkill for the game.

i7 3517u, 1.9 Ghz, 6 GB RAM, IntelHD 4000 and GT 635m

Note: I've tried with both graphic cards. Slowdown occurs mostly in Windowed Mode.
Laatst bewerkt door zeroxxx; 10 jul 2013 om 8:40vm
Megadev  [ontwikkelaar] 10 jul 2013 om 8:56vm 
Ok, here's a few things to try out - I'd be interested to know if changing any of these settings has an effect. Tto begin with go to your SHODN directory, for example:

C:\Program Files (x86)\Steam\SteamApps\common\super house of dead ninjas\META-INF\AIR

...and edit "application.xml" in your text editor of choice. Now try changing the "gpu" in this line:

<renderMode>gpu</renderMode>

to either "cpu" or "direct" to see if it has any effect. You might also want to try changing "resizable" to false, like so:

<resizable>false</resizable>

Please let me know if these changes work for you - if not then I might try reverting the game back to an older version of AIR. I run the game on a fairly modest machine with an onboard graphics card and it still runs at 60 fps despite the update to 16:9. Hopefully we can get to the bottom of this!
Emfour 10 jul 2013 om 9:03vm 
Same problem here. Running on a Intel Core2 Quad from a few years ago (but still, Far Cry 2 runs just fine), the framerate dropped dramatically since the update.
DCT 10 jul 2013 om 9:10vm 
Origineel geplaatst door Megadev:
Ok, here's a few things to try out - I'd be interested to know if changing any of these settings has an effect. Tto begin with go to your SHODN directory, for example:

C:\Program Files (x86)\Steam\SteamApps\common\super house of dead ninjas\META-INF\AIR

...and edit "application.xml" in your text editor of choice. Now try changing the "gpu" in this line:

<renderMode>gpu</renderMode>

to either "cpu" or "direct" to see if it has any effect. You might also want to try changing "resizable" to false, like so:

<resizable>false</resizable>

Please let me know if these changes work for you - if not then I might try reverting the game back to an older version of AIR. I run the game on a fairly modest machine with an onboard graphics card and it still runs at 60 fps despite the update to 16:9. Hopefully we can get to the bottom of this!

tried everything suggested so far and no change what so ever, tried uninstalling and reinstalling, tried making sure all unesscarry apps were closed out, tried restarting my computer, tried playing around with the settings in Application.xml thought for sure that would work or at least made some diffrence but nope it still runs really slow. it's the damnest thing but eh that's working with computers for you. Doesn't matter how many rigs and builds you test on there are always going to be ones that end up having some issue or another.
Laatst bewerkt door DCT; 10 jul 2013 om 9:10vm
apples, man 10 jul 2013 om 9:11vm 
I'm using an Nvidia 560ti and an Intel 2500k to give you an idea of my GPU and CPU and the latest update gave me the perpetual slowdown issue as well.

I tried changing between gpu, cpu and direct within application.xml and the only difference is using cpu made the game run at proper speed but was dropping frames, making it very choppy. In gpu and direct, the game is in constant slowdown instead.
Megadev  [ontwikkelaar] 10 jul 2013 om 9:22vm 
Something else which could be worth a go is increasing the priority for the SHODN.exe in taskmanager, and also changing the processor affiinity, as detailed here:

http://www.techrepublic.com/blog/window-on-windows/change-the-processor-affinity-setting-in-windows-7-to-gain-a-performance-edge/5322

Let me know if that helps. Failing that I might try reverting the game back to an older version of AIR.
DCT 10 jul 2013 om 9:26vm 
Origineel geplaatst door Megadev:
Something else which could be worth a go is increasing the priority for the SHODN.exe in taskmanager, and also changing the processor affiinity, as detailed here:

http://www.techrepublic.com/blog/window-on-windows/change-the-processor-affinity-setting-in-windows-7-to-gain-a-performance-edge/5322

Let me know if that helps. Failing that I might try reverting the game back to an older version of AIR.
still no diffrence
apples, man 10 jul 2013 om 9:27vm 
Ditto, priority and affinity did nothing.
_Rafael1989_ 10 jul 2013 om 9:31vm 
It runs slow for me as well.

It ran slow for me at first, so I restarted my computer and restarted steam.

Now it runs fast at the beginning(faster than the previous version actually) however it starts to slow down the longer I play, by the time I reach the first boss the game is running super slow and I just can't play it any longer.

I have all my settings turned off or at their lowest except for blood and I am still having this problem.

What could cause the game to slow down with continued use? When I exit and restart; the game is fast again, and then it gradually slows down.
1-15 van 133 reacties weergegeven
< >
Per pagina: 15 30 50