Packrat Feb 24, 2014 @ 5:16pm
Still no fix for the slowdown? :( [Resolved: turns out there is!]
I started experiencing performance issues with this game around the time it was patched in preparation for the DLC. I put it aside for a while in hopes it would be fixed, but I'm still having problems with the framerate. Boss fights are basically in slow motion.

I used to be able to run the game fullscreen on maxed settings without issue, but now with everything turned down as far as it'll go, I get noticeable slowdown just from moving the character.

Is there any hope of this ever being fixed, or am I just SOL?
Last edited by Packrat; Feb 24, 2014 @ 5:41pm
Showing 1-7 of 7 comments
< >
Megadev  [developer] Feb 24, 2014 @ 5:21pm 
It could be that the game's "renderMode" isn't set to the best setting for your particular setup - I know I was playing around with it during testing in an attempt to improve the performance for all users, and I assumed that setting renderMode to "auto" would be the best option. Give this a go and see if it helps:


To begin with go to your SHODN directory, for example:

C:\Program Files (x86)\Steam\SteamApps\common\super house of dead ninjas\META-INF\AIR

...and edit "application.xml" in your text editor of choice. Now try changing the setting on the line below from "auto" to "direct", "cpu", or "gpu".

<renderMode>auto</renderMode>

...and see if it has any effect. I was hoping this setting could be changed in-game, but I'm pretty certain that it can only be set in the application.xml file. Let me know if you have any luck!
Packrat Feb 24, 2014 @ 5:40pm 
Interestingly, the file didn't have it set to auto. On a hunch, I set it to auto, and now it's running quite possibly faster than it used to! Still can't play it in fullscreen without the framerate dropping, but I can run it windowed with the graphics options on just fine.

Thanks for the help!

Edit: I noticed a curious thing: low detail mode results in worse performance than high detail mode.
Last edited by Packrat; Feb 24, 2014 @ 6:12pm
Megadev  [developer] Feb 25, 2014 @ 3:08am 
Originally posted by Packrat:
Interestingly, the file didn't have it set to auto. On a hunch, I set it to auto, and now it's running quite possibly faster than it used to! Still can't play it in fullscreen without the framerate dropping, but I can run it windowed with the graphics options on just fine.

Thanks for the help!

Edit: I noticed a curious thing: low detail mode results in worse performance than high detail mode.

Now that is strange...I'd be interested in seeing a video of that, if possible!
Packrat Feb 25, 2014 @ 8:12am 
Unfortunately I don't really have the equipment to do that: my computer can only run the game under specific circumstances as it is, and trying to run video capture software simultaneously with it isn't feasible.

Another oddity I noticed while playing around with the settings, though, was that if I left things set in a way that produced framerate drops, extended play would gradually improve performance. It might start where the framerate would drop anytime the character moved, but eventually improve so that issues only occured when there were a number of enemies and/or projectiles moving onscreen simultaneously, with the number required gradually going up as playtime increased.
KenHalo Feb 27, 2014 @ 12:41pm 
The problem for me lies with flash, and restarting without ever opening my browser, and running the game allows it to run flawlessly. I think the controller support is what pushed the game to be so demanding on Flash.
Toothless Mar 2, 2014 @ 1:03pm 
I am running on a nvidia 6150se nForce430 128MB graphics card, and you're telling me you can't run this game without slowdown...?
Packrat Mar 2, 2014 @ 3:12pm 
Originally posted by Sorvasi:
I am running on a nvidia 6150se nForce430 128MB graphics card, and you're telling me you can't run this game without slowdown...?
Hence why I posted about it here instead of presuming that my hardware was insufficient, particularly because from just after the game was released until the update to prep the game for the DLC I had no trouble. I was able to get it running like greased lightning when windowed by changing the render mode -- so fast that I at first thought it was running too fast, but I figure that's just me having become unaccustomed to to it running at full speed because it had been months since I was able to play the game without issue.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50