Pressure > General Discussions > Topic Details
mrTag  [developer] Mar 27, 2013 @ 4:05am
Problems and solutions
If you have a problem with Pressure, please have a look at this list of problems before posting. Maybe we already have a solution.

--------------
Problem: The game has strange visual artifacts in the cutscenes and the shop! (see this thread for examples: http://steamcommunity.com/app/224220/discussions/0/828934424270086442/ )
Happened only on AMD cards so far.

Solution:
The problem seems to be forced anti aliasing and anisotropic filtering settings in the AMD Control Center. If you set this to "Application controlled" instead of "Override application settings" Pressure should run fine.

A quick guide how to get there:
- open the AMD Vision Engine Control Center
- go to Gaming > 3D Application Settings > System Settings
- switch "Anti-Aliasing Mode" to "Application controlled"
- also switch "Anisotropic Filtering Mode" to "Application controlled"

--------------
Problem: The game displays the errormessage "Failed to initialize the engine." and doesn't start.

Solution:
There was a bug in early versions of the game, which very rarely produced that errormessage, but that was fixed on 31th March 2013. If you still have problems let us know about it and in the meantime run it in windowed mode with this workaround:
Pressure should have created a config file here:
C:\Users\YOUR-USERNAME\Documents\My Games\Pressure\game.cfg
Please edit that file and input this:
fullscreen = 0
resolutionX = 1280
resolutionY = 720
(you can also try different resolutions)


-------------
Problem: The game runs slow on my notebook, even though it has a nice dedicated nvidia / AMD graphics card!

Solution:
The game was probably started with your integrated Intel graphics card. Please make sure to add the Pressure executable to the nvidia optimus / AMD Dynamic Switchable Graphics settings:

nvidia: Open the NVIDIA Control Panel, go to "Manage 3D Settings". Select the "Program Settings" tab and add pressure.exe located in the Steam Library folder (normally Steam\SteamApps\common\pressure\bin\pressure.exe). Then switch the "preferred graphics processor for this program" to "High-performance NVIDIA processor". And don't forget to press the Apply button!!

AMD (I don't have a AMD notebook here, so this description is from screenshots and could be slightly different...)
Open the AMD Vision Engine Control Center and go to the Power category. Go to the "Switchable Graphics" subcategory and click on the "Browse" button to add pressure.exe, located in the Steam Library folder (normally Steam\SteamApps\common\pressure\bin\pressure.exe). Switch the setting for pressure.exe to "High Performance". And don't forget to press the Apply button!!



If your problem is not listed, just open a new thread and we'll look into it.

cheers
Dominik
Last edited by mrTag; Apr 2, 2013 @ 3:44am
Showing 1-15 of 28 comments
< >
RΞV [A] StonedBooM Mar 30, 2013 @ 2:32pm 
thx for a Fun game
BigBodZod Mar 31, 2013 @ 11:16am 
Anyway to get a vsync options as my mouse lags in game.

I assume this is due to a forced vsync.
mrTag  [developer] Apr 2, 2013 @ 3:43am 
@BigBodZod: because of the fast vertical movement in the game you'll see a nasty horizontal streak without vsync. That's why we didn't even offer an option.
But you can switch it off in the config file, which you can find in your Documents directory:
C:\Users\YOUR-USERNAME\Documents\My Games\Pressure\game.cfg
just append the following line:
vsync = 0

I'd love to do something about your lagging mousecursor, but we update the mousecursor position just before rendering, there is nothing we can do there...
But I haven't noticed a mouse-lag on our test computers. You can also control the whole game via keyboard, so I hope the lag is bearable.

cheers
Dominik
ssahnan Apr 2, 2013 @ 10:26pm 
just gave it a whirl, windows 8 pro user, multi monitor setup, everything booted up just fine. assuming you have squashed quite a few of the bug complaints from launch.

My request would be for a more robust resolution support. I run at 2560x1600 and while I would love to have support at that resolution natively without manually tweaking files, to not have 1900x1080 means I get black bars, would atleast like full 1080p support.

Interesting game, been looking for co-op local same screen games to play with my son so this one will do just fine. best of luck on the launch of this title.
BigBodZod Apr 2, 2013 @ 11:40pm 
Originally posted by mrTag:
@BigBodZod: because of the fast vertical movement in the game you'll see a nasty horizontal streak without vsync. That's why we didn't even offer an option.
But you can switch it off in the config file, which you can find in your Documents directory:
C:\Users\YOUR-USERNAME\Documents\My Games\Pressure\game.cfg
just append the following line:
vsync = 0

I'd love to do something about your lagging mousecursor, but we update the mousecursor position just before rendering, there is nothing we can do there...
But I haven't noticed a mouse-lag on our test computers. You can also control the whole game via keyboard, so I hope the lag is bearable.

cheers
Dominik

Thanks for the tip, just tried it, mouse lag is gone and the tear is not very noticable.

I will play around with some of the game tweaks and see if I can make the mouse lag go away.

I have a Logitceh G700 Gaming Mouse, works great in most games but if there is any lag I usually diable the vsync to get things working again.

I will pot more info once I test some more.
Cosmos Jester Apr 24, 2013 @ 1:06am 
Not sure if a bug or made by design, but the campaign saves erase themselves when you beat the game
Thoben Apr 24, 2013 @ 1:33am 
It's not a bug, it's a feature :-) After you finished the campaign, there is no more level to play. You can revisit every level in freeplay mode.
Cosmos Jester Apr 24, 2013 @ 10:48am 
So there's no way to replay the game with your beefed-up improved car is there? :C
Pook and Pie May 5, 2013 @ 11:24am 
Well, I'm having an issue if anyone cares to help. I'm having a crash about 2 minutes into game play (almost immediately after the third enemy pops up from behind on screen) where my graphics card driver crashes.

My GPU is an nVidia GTX 295, drivers are the latest available. I've tried about 3 separate workarounds from different websites when their cards crash but to no avail.
Lebowski May 6, 2013 @ 2:19am 
Hi Pool and Pie!

That's strange! I've installed the newest nVidia Driver and tested different configurations but I couldn't reproduce the crash. Everything's running fine! Could you please post the error message and your system specs (CPU/RAM/OS/additional integrated graphics/...)!
That would help a lot!

Btw: Ensure that you your '3D-settings' like AA and AF are 'application controlled'!

Cheers,
Daniel (Chasing Carrots)
Pook and Pie May 12, 2013 @ 12:07pm 
The error is:

ERROR: Could not reset the Direct3D Device!
'Could not change display settings (error:-1).'

That dialogue pops up around when the third enemy vehicle pops up onscreen, and the game begins to freeze, the monitor then shows "No signal" because the GPU driver has crashed, and then it pops up this error.

My setup is:

Intel i7 920 CPU at 3.0GHz
10GB RAM
nVidia GTX 295 GPU
XFX X58i Motherboard
Windows 7 64-bit OS

There's no integrated graphics card, it's just the GTX 295. I can play things like Battlefield 3 on High just fine, I can play Borderlands 2 okay, but for some reason I have issues with Pressure. =/

Edit: Oh yes, one thing I forgot to clarify: Most of my settings in the nVidia manager are set to application controlled, anti-aliasing and anisotropic filtering included.
Last edited by Pook and Pie; May 12, 2013 @ 1:40pm
Lebowski May 15, 2013 @ 3:14am 
We've tried to reproduce your error with four different nVidia Cards with the actual nVidia drivers but couldn't reproduce this error.

Could you please start the first level without moving the buggy so that you don't cross the first checkpoint!? Leave the controls untouched and wait some time to see if the game crashes.

Cheers,
Daniel
Pook and Pie May 16, 2013 @ 9:04pm 
Well, if I leave the vehicle sit at the starting point for a while, the crash doesn't occur until I make it move (I let it sit about 5 minutes, which is well longer than it takes while moving). It crashes right before the second sign you can drive past, so a little before the first enemies appear.

So, to summarize: If I begin driving immediately, the GPU driver crashes right when the third enemy appears onscreen. If I wait a while, it crashes before any enemies appear onscreen. Hopefully this information helps determine what the cause is.

I've tried uninstalling and reinstalling; I can't figure out what it might be. I appreciate all the help thus far and look forward to your response.
Last edited by Pook and Pie; May 16, 2013 @ 9:05pm
Lebowski May 22, 2013 @ 2:53am 
To be honest, I don't know what causes that error! I've tested it on a GTX295 and it worked with the actual nVidia driver! Couldn't find any problems with this hardware/drivers. Try to reset your nVidia settings to 'Standard' and delete the following file:

C:\Users\YOUR-USERNAME\Documents\My Games\Pressure\game.cfg

Maybe this will work...

Btw: What's your screen resolution?

Cheers Daniel
Pook and Pie May 25, 2013 @ 8:37pm 
I tried deleted said file and changing settings to Standard as mentioned, still having the issue.

My resolution is 1440x900. That's as much as my monitor can do; I've been meaning to get a new one, lol.
Showing 1-15 of 28 comments
< >
Per page: 15 30 50