Ys II > General Discussions > Topic Details
Jan 24 @ 4:04am
Will not install
Will start to install when it gets to 6% will stop and say "update required". Have deleted the content and tried again but get the same message. Not sure what to do now.