Ys I > General Discussions > Topic Details
Valkyon Jul 23, 2013 @ 2:54pm
Game won't launch?
Well, not exactly. I open the game, and click on "Play Ys I." I wait about five seconds, after which a small window opens that states "DirectX initialization failed." Ive attempted to fix it by going into program files and re-installing directx through the game in Steam/Steamapps/Common/Ys I/dxredist, but nothing works. can anyone help me?
Showing 1-15 of 43 comments
< >
Sara  [developer] Jul 23, 2013 @ 2:55pm 
Try taking a look at the game's settings, running it in Windowed mode, etc. It may be that somehow none of the defaults are working on your PC.
Valkyon Jul 23, 2013 @ 2:58pm 
Have any other ideas? I opened the configuration, but the settings dont seem to apply. I run widows xp, but it says thats the minimum on the store page...
Sara  [developer] Jul 23, 2013 @ 2:59pm 
Try disabling the Steam Cloud for the game, if the settings don't seem to be applying correctly.
Valkyon Jul 23, 2013 @ 3:06pm 
still nothing. the configuration doesnt save either way, or so it seems, plus the directx popup still, well pops up when i try to play it.
Sara  [developer] Jul 23, 2013 @ 3:08pm 
Sounds like permissions issues. You may need to run Steam as admin. (Not the game's fault, but just something that crops up with Steam games sometimes when they don't have enough permissions... The fact that even the first-time install won't finish isn't related to the game itself at all.)
Last edited by Sara; Jul 23, 2013 @ 3:08pm
Valkyon Jul 23, 2013 @ 3:31pm 
maybe thats it, but I will mention that Ys II works just fine.
Sara  [developer] Jul 23, 2013 @ 3:37pm 
Even weirder. The config program code for the two games is almost identical, and they use the exact same first-time install script.
Valkyon Jul 23, 2013 @ 4:02pm 
I didnt have to do the first time install for Ys II actually. which doesnt make sense, if the first time install is the problem with the first one.
any other ideas? Its fine if theres none, but I would like to play the first game rather than read a walkthrough...
Sara  [developer] Jul 23, 2013 @ 4:04pm 
Have you tried running Steam as admin like I asked initially? Or is that not an option in your current setup? First-time setup problems are usually avoided that way, so it's just a logical step to take if you think the first-time install is to blame.
Valkyon Jul 23, 2013 @ 4:04pm 
yeah, it asks for a password that I dont remember setting up, so running as an admin is a no-go.
Sara  [developer] Jul 23, 2013 @ 4:07pm 
Hmm... I'm not sure what to say here, then. You are trying to run Steam as admin through the right-click menu when selecting to open Steam, right? Not trying to change users? The way the first-time setup process works, it knows that it is done if three DWORD registry keys are set to "1". These are "ConfigTool", "DirectX", and "VC2008Redist", all under "HKEY_LOCAL_MACHINE\SOFTWARE\Valve\Steam\Apps\223810". But you wouldn't be able to edit those by hand without admin abilities either, so probably a moot point to mention. Hmm... It's hard to debug first-time setup issues since that's part of Steam, not part of the game itself.
Valkyon Jul 23, 2013 @ 4:10pm 
I right click, select "run as..." then try to run as administrator, but it says that the user doesnt exist or is a bad password. I doubt its the former, but if there is a password then I dont know it. my user on my computer is considered a computer admin tho, but that doesnt seem to change anything.
Sara  [developer] Jul 23, 2013 @ 4:12pm 
Sounds like something's messed up with your OS install. That kind of worries me and I'm not sure how to approach the issue in this case. Hmm...
Valkyon Jul 23, 2013 @ 4:13pm 
Thanks anyways then. whats even more messed up is that all of those three registry things are set to 1, but the default is unregistered, if that makes a difference.
Sara  [developer] Jul 23, 2013 @ 4:14pm 
It doesn't. So that means it shouldn't be trying to run the first-time setup at all... Have you tried restarting Steam?
Showing 1-15 of 43 comments
< >
Per page: 15 30 50