DCS World > General Discussions > Topic Details
Tominator Feb 8 @ 4:42am
Controls not working
Ever since the last update my controls havnt been working ( joystick and keyboard). I am able to change the controls in the menu and it sees my joystick, but when I start the game I am unable to control anything. Please help
Showing 1-6 of 6 comments
< >
kazereal Feb 8 @ 10:56am 
More information would be useful.

First, if you bind joystick controls check which aircraft you are binding them to. Some have 'game' and 'simulation' modes separately also so double-check that.

Second, you might need to power up the aircraft before hydraulics start working: before then joystick would not do much anyway..

Try one of "instant action" modes where plane is already in air, that would tell quickly if it is a matter of bindings or not.
Hudsane Feb 8 @ 6:24pm 
I am having the same issue my joystick works in the options, but when i load up a game there is no keyboard except esc button no mouse and no joystick
Hudsane Feb 8 @ 6:27pm 
Also, I have DCS installed on my Cdrive non steam version and Flaming Cliffs 3 works fine the joystick keyboard and mouse all respond but it seems that on steam there is a issue, almost like once I load up the game the joystick mouse and keyboard are non responsive. When I go through the settings I can change all the keys commands and I can tinker with my Joystick axis, but then nothing once I load up a game.
Last edited by Hudsane; Feb 8 @ 8:41pm
Tominator Feb 8 @ 10:38pm 
Hudson that is exactly my problem also. Found someone else with our problem who reinstalled and it solved the problem, so I'm busy reinstalling now so fingers crossed.
Hudsane Feb 9 @ 8:23pm 
--UPDATE-- Hey Tominator, thanks for the info I deleted and installed it twice and the second time of manually going into the steam folder and deleting DCs world, and then right click on Dcs world and deleting local game caches while steam was running, the controls, mouse and joystick all worked like a charm after it finished downloading. Thank you for the info.
Tominator Feb 14 @ 9:09am 
Yep I deleted the local files and redownloaded and installed, now works 100% :)
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Feb 8 @ 4:42am
Posts: 6