Cry of Fear > General Discussions > Topic Details
º¿HèAdshôT?º Apr 25, 2013 @ 5:20pm
How to play Co-op with your friends! (With and Without Hamachi)
(IF YOU HAVE PROBLEMS WITH CRY OF FEAR, VISIT http://www.cry-of-fear.com/forum/ )
----------------------------------------------------------------------
People are having problems playing Co-op with a friend - either through the, "Host Server" option or, "Dedicated Server" tool. The "Dedicated Server" tool gives out an error, "....offset for is_donator!" and crashes the server, while "Host Server" just doesn't allow connections. This will change if ruMpel or James look into the problem, and a tutorial will be posted here.
-----------------------------------------------------------------------

Here are 2 ways to connect and play Co-op in Cry of Fear:

Playing Co-op (WITH HAMACHI)
You will need:
  • Hamachi (duh)

If you didn't start your browser up and continued reading, here is the link [download.cnet.com] (Your friend needs Hamachi as well) After downloading Hamachi, start Hamachi up, and setup a network (Hamachi > Network > "Create a new network" > Fill in the blanks with whatever you want) and tell your friend to get in the network (Tell him the name and password).

After he joins the network, copy your Hamachi IP (located next to the Power Button Icon [ex. 5.xxx.xx.xxx] ) and don't forget it, you are going to give it to your friend in a bit. Start up Cry of Fear and start a server like usual (Host Server > etc...) BUT make sure LAN is checked before starting.

Now, you are going to give your Hamachi IP to your friend in this form....
connect <hamachi IP here>
.... and he will type that into the console (~ key) to connect. Now you should be able to Coop, if he couldn't connect with LAN on, then type in your console (without quotes), "sv_lan 0".

-----------------------------------------------------------------------
Playing Co-op (W/O HAMACHI)
You will need:
  • a Static IP Address
  • Port Forwarding

That is all you need really - if you don't know your Static IP, type in Google, "find my static ip" and a black-bolded number should appear above your first search, copy that. If you do not have a Static IP, then you will need to set one up by finding some good tutorials on how to do that (anyone finds a good tutorial and you will be credited).

To find the ports you need, go https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711. If you do not know how to port-forward, then look at tutorials (you need to know the information about your router before doing this) - you can use this program as well. http://portforward.com/

Start up Cry of Fear and host the server (Host Server > etc...) with LAN off. After you're in the Co-op lobby, tell your friend to type this in his console (~ key) to connect:
connect <static IP here>:27015

Hopefully, this should work - if not then you have to wait for the developers to find and fix the problems.

If none of the above steps work, then let your friend try hosting, following either steps (with or without Hamachi).

[EDIT: Forgot one step in Playing Co-op (w/o Hamachi) ]
[EDIT 2: Corrected mistake under Playing Co-op (with Hamachi), this was probably the reason nobody could use Hamachi, sorry guys!]
Last edited by º¿HèAdshôT?º; Jun 23, 2013 @ 4:13pm
Showing 1-15 of 62 comments
< >
Robo-Tywin Lannister Apr 25, 2013 @ 5:40pm 
we played a few seconds and got "steam validiation error" using hamachi
DAT RENDAR Apr 25, 2013 @ 5:44pm 
Every time my friend and I try to open the game with console we get error missing executable and we have both verified integrity of game cache anyone have a solution?
Sagara Sousuke Apr 25, 2013 @ 5:52pm 
If you are using a PC and don't know how to do the static ip thing, hosting and joining. Read a little. is the most basic stuff for any gamer on PC.
º¿HèAdshôT?º Apr 25, 2013 @ 6:05pm 
Originally posted by Revolver Ocelot:
we played a few seconds and got "steam validiation error" using hamachi

Restart your computer and internet and try again.

Originally posted by Dash Rendar:
Every time my friend and I try to open the game with console we get error missing executable and we have both verified integrity of game cache anyone have a solution?

Can you copy down what the error said?
FISH KILL Apr 25, 2013 @ 6:09pm 
Hey folks this is headshots friend if for some reason the static IP isn't working then try hamachi. Though it should work considering we played an hour of co-op :P
NKstyle ♪ cc Apr 25, 2013 @ 6:11pm 
post this ♥♥♥♥ does not work
NKstyle ♪ cc Apr 25, 2013 @ 6:11pm 
not serve anything
º¿HèAdshôT?º Apr 25, 2013 @ 6:25pm 
Originally posted by NKstyle:
post this ♥♥♥♥ does not work, not serve anything

You tried everything in the post, including the Port Forwarding and Hamachi?


Raisin God Apr 25, 2013 @ 6:53pm 
im getting a error code LAN servers are restricted to local clients (class C)
Ryntek Apr 25, 2013 @ 6:54pm 
when making a game with hamachi, dont click the lan option, worked for me and my friends
º¿HèAdshôT?º Apr 25, 2013 @ 6:55pm 
Originally posted by Thecrazz:
when making a game with hamachi, dont click the lan option, worked for me and my friends

Glad it worked.

Originally posted by Raisin God:
im getting a error code LAN servers are restricted to local clients (class C)

Are you trying LAN on or off through the console? Are you restarting the server and checking/unchecking LAN to see if it is turning off/on properly?
Last edited by º¿HèAdshôT?º; Apr 25, 2013 @ 6:58pm
Raisin God Apr 25, 2013 @ 7:00pm 
thank you thecrazz it worked, headshot me and my friend just taked turns hosting it, turns out i cant host it but he can
edit:this is hamachi btw
Last edited by Raisin God; Apr 25, 2013 @ 7:00pm
º¿HèAdshôT?º Apr 25, 2013 @ 7:04pm 
Originally posted by Raisin God:
thank you thecrazz it worked, headshot me and my friend just taked turns hosting it, turns out i cant host it but he can
edit:this is hamachi btw

Updated post with letting your friend trying to host.
Teddy Bonkers Apr 25, 2013 @ 7:25pm 
Don't use the link in the OP for Hamachi. You'll get a bunch of crap downloaded with it along with changing your homepage without asking.
Robit Wangisimo Apr 25, 2013 @ 7:26pm 
It didn't change mine, you just have to use custom download settings it tells you to. I chose not to use homepage/tool all that crap.
Showing 1-15 of 62 comments
< >
Per page: 15 30 50