Fallout 3 - Game of the Year Edition
darklordsdaughter Jan 5, 2013 @ 6:56am
Fallout 3 fix for Quad core systems.
Fallout 3 wasn't working for me untill I applied this fix.
Fallout 3 is incompatable with systems that use a quad core processor, but there is a method of forcing it to use just two cores instead.

Fix can be found here: http://www.sevenforums.com/gaming/20199-fallout-3-windows-7-w-quad-core.html

Copy and paste from the link above, below:

"Vista SP2 with a dual core worked fine. After upgrading to a quad core and Windows 7, I was lucky if I could play more than 5 minutes without a freeze.

A fine gentleman named Nicholas Head posted this solution on his blog. Along with several others, I can confirm this fix works! (YRMV)

Fallout 3: Video/Display Freezes, sound keeps going

by Nicholas Head 7. February 2009 00:35

Ever since Bethesda came out with the 1.1 patch for Fallout 3, I couldn’t play the game anymore. Once I got into the game and started wandering around, I’d randomly “freeze” up… the video would stop updating, but the sounds/music would still play. Keyboard clicks and mouse clicks did nothing, requiring me to ctrl+alt+del and kill the task manually.
It looked like I was SOL until the next patch, but I found some help online:

The game engine has some issues with processors that have more than 2 cores. You can force the game to only use two of them and it will stop the freezing. I haven't had it freeze once since I did this several days ago.
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2
This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

Surprisingly, this worked like I charm. I do indeed have a quad core processor, so it sounds like this was the culprit. Why 1.1 broke the game for me.. I have no idea. It sounds like Bethesda needs to do some better testing on multi-core processors."


Unfortunatly I don't know whether this file is in the same place for Fallout 3 on steam as I brought my copy on disk. Could someone route around and find out if FALLOUT.ini is still put in My Documents\My Games\Fallout3 by steam? And if not, where steam has put it so people can try this fix?
Showing 1-15 of 19 comments
< >
darmstr3 Jan 5, 2013 @ 11:13am 
It is, but it didn't fix my problem.
cANAL DESTROYER Jan 5, 2013 @ 11:24am 
didnt work for me either
darklordsdaughter Jan 5, 2013 @ 11:40am 
Sorry to hear that, it worked fine for me. I wish you both better luck in your search for a fix.
Last edited by darklordsdaughter; Jan 5, 2013 @ 11:41am
(O.N.)Pikaboo Apr 15, 2013 @ 3:09pm 
God it worked for me for a while, then it crashed every hour or so. Now I can't even play for five minutes before it freezes. I changed the game to work on 2 cores but as you can see, it's not working anymore.
darklordsdaughter Apr 15, 2013 @ 4:57pm 
Originally posted by Bags:
God it worked for me for a while, then it crashed every hour or so. Now I can't even play for five minutes before it freezes. I changed the game to work on 2 cores but as you can see, it's not working anymore.
That freezing sounds like a separate isssue, one I haven't encountered. Good luck with finding the cause.
You could try reinstalling the game but other than that I'm not sure what might be causing that.
(O.N.)Pikaboo Apr 15, 2013 @ 5:04pm 
Originally posted by darklordsdaughter:
Originally posted by Bags:
God it worked for me for a while, then it crashed every hour or so. Now I can't even play for five minutes before it freezes. I changed the game to work on 2 cores but as you can see, it's not working anymore.
That freezing sounds like a separate isssue, one I haven't encountered. Good luck with finding the cause.
You could try reinstalling the game but other than that I'm not sure what might be causing that.
It seems to be a mix of both. Sometimes it crashes and sends me back to the home screen but my mouse won't work. Other times the music continues but not the game, and the only option for both is to turn off my PC manually....
I've thought about reinstalling, but I don't see how it will affect the game as like Bethesda says, it was not made to run on several cores.
Nienhuus`nl Apr 28, 2013 @ 4:58am 
ive got the intel core i7 920, it works for me :D thanks for the info!
Crix Apr 28, 2013 @ 4:05pm 
I have a quad core and didn't need to do this.
darklordsdaughter Apr 29, 2013 @ 4:20pm 
Originally posted by Nienhuus`nl:
ive got the intel core i7 920, it works for me :D thanks for the info!
Awesome! :D
Racisttacoxx1519 Apr 29, 2013 @ 7:59pm 
What is the line i need to rewrite under,
darklordsdaughter May 2, 2013 @ 2:04pm 
Originally posted by mattpappas13:
What is the line i need to rewrite under,
It's hard to find in the notepad, I ended up searching for it using ctrl F
Zodasaur Sep 3, 2013 @ 8:22pm 
All you need to do is go into your bios and disable hyperthreading.
deeper SS-Oberführer Sep 5, 2013 @ 3:49pm 
I find interesting that when I launched the game it straight ran as it should,
Steam says the game have problems with Windows 7 - Not for me
And I have an eight core processor, the game ran like a charm.
BenWah Sep 8, 2013 @ 3:20pm 
This info has been in the pinned sticky thread at the top of this forum section for ages, how do people miss that
elric Sep 12, 2013 @ 8:47am 
i have this as my system
Operating System: Windows 7 Ultimate 64-bit SP1
System Model: GA-970A-DS3
Processor: AMD FX(tm)-8150 Eight-Core Processor , ~3.6GHz
Memory: 8192MB RAM
DirectX Version: DirectX 11
nvidia gtx 650
i know steam said that the game was not windows 7 compliant.
i have never had an issue of a freeze, or crash to desktop. i bought the fallout 3 goty ed.
did the game auto fix itself. because i've sit here running mods like crazy, and no issues to report? and never changed anything in the .ini file. guess i am lucky . since i read so many with the issues..
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Jan 5, 2013 @ 6:56am
Posts: 19