Fallout 3 - Game of the Year Edition
xgillett Dec 31, 2012 @ 9:33pm
Windows 8 Fix <--- There you go
First
Open up the fallouta_default.ini file in: steamapps\common\fallout 3\
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

Then download the Games client from http://www.xbox.com/en-US/LIVE/PC/DownloadClient

After installing the client, set compatability mode to Windows Vista SP1

Finally download the d3d9.dll file from https://www.dropbox.com/s/5ot8tm7szvlnuks/d3d9.dll and place the file in your fallout 3 folder

Haven't had a single crash since doing this, and its been running smoothly.
Tweak as needed
Showing 1-15 of 106 comments
< >
Xtrapol8 Jan 2, 2013 @ 6:49am 
Just the edit of the .ini might be enough. I've done this on both Fallout 3 and New Vegas to fix frequent crashes.

Although, this is the location I use;

Open the folder My documents / My Games / Fallout3
* Edit the file FALLOUT.ini.
* Inside FALLOUT.ini look for a group called [general].
* Inside the general group, after all the configuration parameters, just copy and paste the following 2 lines:

bUseThreadedAI=1
iNumHWThreads=2

Now close and save the Fallout 3 configuration file.

Source:
http://trebleclick.blogspot.com/2009/04/fallout-3-crash-fix.html

This worked for me previously on 32bit XP and now on 64bit Windows 7.
Smilodon Jan 2, 2013 @ 8:54am 
I love how this fix keeps popping up as the end-all fix for everyone.
MrStealYoLaptop Jan 2, 2013 @ 10:12am 
Changing the Fallout_default program codes made my launcher crash and now I cant even run it.
Charlie Shen Jun 5, 2013 @ 12:12pm 
Oh my god, thank you so much
I tried to run this game in 3 computers with windows 7 and never worked
Now this computer with windows 8 and 64 bits version...
I though i was never going to play this game
A million thanks for this fix (and sorry, i know my english sucks)
Shiro Jun 15, 2013 @ 8:18pm 
It Asked Me For My Game Key, Which I Dont Know :(
Charlie Shen Jun 15, 2013 @ 8:29pm 
Shatner, i added you, but i'm going to forget this tomorrow, so message me when you add me
BenWah Jun 16, 2013 @ 2:47am 
This same fix already in the pinned threads up top.

P.S. no one should use the d3d9.dll without first testing to see if the other fixes resolve the problem. Only use if you have to.
Last edited by BenWah; Jan 6 @ 9:17pm
Kurtzer0 Jul 14, 2013 @ 3:24pm 
this didn't work for me. i loaded in and it crashed even faster lol
Rusty Jul 18, 2013 @ 2:57pm 
Originally posted by xgillett:
First
Open up the fallouta_default.ini file in: steamapps\common\fallout 3\
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2

Then download the Games client from http://www.xbox.com/en-US/LIVE/PC/DownloadClient

After installing the client, set compatability mode to Windows Vista SP1

Finally download the d3d9.dll file from https://www.dropbox.com/s/5ot8tm7szvlnuks/d3d9.dll and place the file in your fallout 3 folder

Haven't had a single crash since doing this, and its been running smoothly.
Tweak as needed


For me it`s works, thanks a lot. [Windows 8, 64Bit, Corei5, Intel HD)
Caesar420 Jul 18, 2013 @ 7:53pm 
thanks so much i had my doubts because im not that computer savy but this did work on the first attempt just take your time
Lone Wanderer Jul 19, 2013 @ 2:56am 
Thanks you!!
Echo-locate Jul 19, 2013 @ 2:14pm 
thanks it helped alot.
Astro Sloth Aug 6, 2013 @ 12:34pm 
thanks so much i just bought the GOTY edition for fallout 3 and i was having frequent crashes
Jack Mormon Aug 25, 2013 @ 10:49am 
It says access is denied and won't let me modify the file. Right click gives no option to run as administrator...
mstr_sgt_steve Sep 1, 2013 @ 4:56pm 
at first i didnt think it would work but i just got goty edition without even knowing windows 8 wasnt compatible but i did the steps and i got so happy now i can play. :) thx for the help.
Showing 1-15 of 106 comments
< >
Per page: 15 30 50