Monsi May 24, 2013 @ 2:38pm
Fallout 3 GOTY keeps freezing while playing (Windows 7)
Hi.
I recently purchased Fallout 3, but i keep having issues with the game. When i clicked new game, my game crashed. I searched for topics all over the net, and i changed the numer of cores to 2, deleted the intro video, installed the d3d9.dll file and lowered my graphics, and now i am able to play for a brief time, like 3-4 minutes, but the game keeps freezing while i'm playing. It doesn't come up with an error or anything, just freezes. Can anybody help me, i'm stating to get desperate. My PC is on windows 7, and certainly has high enough specs to run the game properly.
Showing 1-15 of 19 comments
< >
Elek3103 May 24, 2013 @ 2:39pm 
Fallout 3 is not optimised for Windows 7
Dr. Shocks . DO May 24, 2013 @ 2:42pm 
Freezing, as in it freezes or stutters when you exploring new areas?

If so, that's the new areas loading from your harddrive. Like Elek, FO3 isn't optimized for newer hardware [can't take advantage of it. Compare it to Skyrim, which runs beautifully on new hardware compared to FO3].
Monsi May 24, 2013 @ 2:44pm 
The picture just freezes, and i'm still onlt in vault 101 at the birthday party (The farthest i've been able to come without a crash)
I know it's not optimized, but i just feel that it's rubbish if i have to play it on windows xp. There must be a solution, i just don't know what to do anymore.
BenWah May 24, 2013 @ 3:07pm 
Did you do this?

4) Stop multicore crashes by editing with notepad: (THIS SOLVES MOST CRASHES!)
My Documents\my games\Fallout3\FALLOUT.INI
find (control F) bUseThreadedAI=0
CHANGE to bUseThreadedAI=1
Immediately after this line, ADD this new line:
iNumHWThreads=2


Another thing that might help you is to instlal a KLITE codec pack.
It sounds odd, but the built-in sound driver for windows 7 (and vista) conflicts a fair bit with fallout 3.

http://codecguide.com/download_kl.htm

More fixes at:

http://steamcommunity.com/app/22370/discussions/0/828937546147175081/
Last edited by BenWah; May 24, 2013 @ 3:09pm
Too Much Coffee Man May 24, 2013 @ 5:51pm 
Originally posted by BenWah:
bUseThreadedAI=1
iNumHWThreads=2

I saw this tip somewhere else on the Internet but these two properties certainly make Fallout 3 much more stable. Now if I can just rid my configuration of the odd left click that minimizes Fallout 3 to the task bar ...
Sir Thunderbuns Oct 29, 2013 @ 12:48pm 
I'm running into the issue too but I do not have the line bUseThreadedAI=0 in my fallout.ini, header is it under?
RadicalTactican Oct 29, 2013 @ 4:55pm 
Does this title work with windows 8?
Too Much Coffee Man Oct 29, 2013 @ 7:54pm 
Originally posted by Entropy81:
I'm running into the issue too but I do not have the line bUseThreadedAI=0 in my fallout.ini, header is it under?
Add the bUseThreadedAI property to the General section.
Last edited by Too Much Coffee Man; Oct 29, 2013 @ 7:55pm
looser machine Nov 28, 2013 @ 11:46pm 
why so ♥♥♥♥ing dificult
Stele Nov 29, 2013 @ 3:37pm 
Originally posted by Too Much Coffee Man:
Originally posted by Entropy81:
I'm running into the issue too but I do not have the line bUseThreadedAI=0 in my fallout.ini, header is it under?
Add the bUseThreadedAI property to the General section.

i dont even have a "general section"
King Beans Nov 29, 2013 @ 11:41pm 
Hey guys, had the same problem, did everything and NONE of them worked... then i found this ONE solution, its a bit of a hassle but worth it if you really want to play this game..

1. Press start
2.Type in msconfig
3.click boot
4.click advanced options
5.Check the box "number of proccessors
6.click one
7. resart computer
8.Enjoy your game

when you restart only ONE of your cores in your CPU will run so if you want to do anything afterwards go back to MSCONFIG and uncheck the box you checked and restart.

I hope i helped
You can't even Dota, Bro. Nov 30, 2013 @ 2:17am 
Originally posted by BenWah:
Did you do this?

4) Stop multicore crashes by editing with notepad: (THIS SOLVES MOST CRASHES!)
My Documents\my games\Fallout3\FALLOUT.INI
find (control F) bUseThreadedAI=0
CHANGE to bUseThreadedAI=1
Immediately after this line, ADD this new line:
iNumHWThreads=2


Another thing that might help you is to instlal a KLITE codec pack.
It sounds odd, but the built-in sound driver for windows 7 (and vista) conflicts a fair bit with fallout 3.

http://codecguide.com/download_kl.htm

^^^^^^^^^^^^^^^^^^^^

WARNING
If you download this, you'll be flooded with malware.
Last edited by You can't even Dota, Bro.; Nov 30, 2013 @ 2:18am
Monsi Nov 30, 2013 @ 2:20am 
Originally posted by Beans9222:
Hey guys, had the same problem, did everything and NONE of them worked... then i found this ONE solution, its a bit of a hassle but worth it if you really want to play this game..

1. Press start
2.Type in msconfig
3.click boot
4.click advanced options
5.Check the box "number of proccessors
6.click one
7. resart computer
8.Enjoy your game

when you restart only ONE of your cores in your CPU will run so if you want to do anything afterwards go back to MSCONFIG and uncheck the box you checked and restart.

I hope i helped

Holy ♥♥♥♥ dude, it worked for me! I had given up trying to fix the game, but this totally did it! Can't thank you enough!
Too Much Coffee Man Nov 30, 2013 @ 6:47am 
Originally posted by Stele:
Originally posted by Too Much Coffee Man:
Add the bUseThreadedAI property to the General section.

i dont even have a "general section"

My General section looks like this (ellipses mark omitted content):
[General]
SStartingCell=
SCharGenQuest=0001f388
SStartingCellY=
...
;-------------------------------------------------------------------------------
; 2013-05-16 Too Much Coffee Man
; Changed property bUseThreadedAI value from 0 to 1 and added
; property iNumHWThreads with value 2. Source:
;
; http://steamcommunity.com/app/22370/discussions/0/
; 828937546147175081/
;-------------------------------------------------------------------------------
bUseThreadedAI=1
iNumHWThreads=2
...
[Display]
...
Using an editor that features syntax folding can help make manipulating these files easier by reducing visual clutter. By collapsing all sections only the section names are visible.
Nicholarse Dingleberry Dec 29, 2013 @ 4:07pm 

Another thing that might help you is to instlal a KLITE codec pack.
It sounds odd, but the built-in sound driver for windows 7 (and vista) conflicts a fair bit with fallout 3.

http://codecguide.com/download_kl.htm

^^^^^^^^^^^^^^^^^^^^

WARNING
If you download this, you'll be flooded with malware.


Uhh no you wont. If you dont want the added support files, dont add them. This codec is solid.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: May 24, 2013 @ 2:38pm
Posts: 19