Kurt Cobain May 20, 2013 @ 11:50pm
l4d2 lag spikes (possibly bad sdl libraries?)
is there any way to set l4d2 to use openal instead of sdl audio? I keep having lag spikes and skipping audio, (they seem to be connected) Mint 13 64bit
Showing 1-12 of 12 comments
< >
Kurt Cobain May 21, 2013 @ 12:07am 
launching with -nosound option doesn't help, turning on/off vsync no change, gonna try swapping sdl library files and see what happens
Kurt Cobain May 21, 2013 @ 12:39am 
swapping out the libSDL2.so and libSDL2-2.0.so.0 files to 64 bit versions from my system didn't help, anyone know if i'm on the right track with this though?
saf May 21, 2013 @ 11:23am 
I don't; but are the lag spikes you're talking about manifest like an input delay? like lagged mouse? because if so I know what you mean, but didn't realize it was connected to the audio; arch 64bit
TheReaperUK May 21, 2013 @ 3:48pm 
Good luck with finding the problem, i have tried ATI/Nvidia cards also onboard sound and external usb soundblaster x-fi sound, different kernels 3.2 upto 3.8, allsorts of sound hacks/updates etc, changed motherboard settings in bios and re-installed xubuntu 12.04.2 LTS 32bit also tried Manjaro newest (based on arch) still same problem, i've tried all autoexec.cfg hacks and speed ups and command line commands, still runs with freeze's/lag/shuttering which all happen in the same place on a map each time i try a campaign, and it don't seem to matter if i'm at 1024x768 low detail all fx off or maxed at 1920x1080 all fx on, its the same so i'm not sure why or where the problem is.
Last edited by TheReaperUK; May 23, 2013 @ 4:04pm
EuPhobos May 22, 2013 @ 8:19am 
Same here, on steam under wine l4d2 works better.
TheReaperUK May 23, 2013 @ 4:06pm 
Originally posted by EuPhobos:
Same here, on steam under wine l4d2 works better.

Same here, plays better in crossover (wine), L4D 1 is fault less in crossover as well.
VOT May 28, 2013 @ 2:51am 
Same problem: I use an AMD graphics card, and using different kernels, different distros (Arch, Mint), different drivers (13.2-beta6, 13.3beta, 13.4) and -no-sound. Turning down quality to low does not make a difference, and the game works fine on Windows!
ESOTERiC Jun 10, 2013 @ 1:12pm 
im no expert at all on this but i disabled my ext. firewire RME card cause of the same issues in Windows. Now on linux, using default on-board audio, it still happends, i think it's the engine or something related
DerFury Jun 12, 2013 @ 5:23pm 
Same issue here. Arch 64, AMD 6870
Last edited by DerFury; Jun 12, 2013 @ 5:23pm
Tigrezno Jun 14, 2013 @ 12:51pm 
No lag at all for me, but sometimes just a segmentation fault when joining games
Showing 1-12 of 12 comments
< >
Per page: 15 30 50