Left 4 Dead 2 Beta > 일반 토론 > 제목 정보
TRololo 2013년 5월 14일 오후 5시 36분
Almost all textures are black or white L4D2 Beta Linux
Hi.
Im running L4D2 on linux and I have a problem; the game start but all textures are black or white as you can see in the images above:

http://cloud.steampowered.com/ugc/846953562096110615/C0210D80D5D5ED3FE6F299AE7566EDA1371AC15A/

http://cloud-2.steampowered.com/ugc/846953562096115659/92BC1942882856B31C6795ACC75E6F038A4DBF85/

I tried to change the video settings to severals combinations but I got the same results.

System Specs:

- Video: Intel HD4000
- Processor: Core i5 3210M
- System: Arch Linux x86_64
- Kernel: 3.9.2-1
- Mesa Driver: 9.1.2

Excuse me for my english but is not my native language.
7개 중 1-7 표시중
< >
WiRE 2013년 5월 14일 오후 6시 57분 
I am also having problems with my graphics. I see color but some times the walls become see-through. Sometimes this helps because I can see where the Tank is but I know it is not normal.

Have you tried to install the latest drivers to your graphics card? I did that but it did not help me, maybe it will help you.

I hope Valve is reading these comments and fix them.

-Video: ATI Sapphire Radeon HD 5770
-Processor: AMD Phenom II X4 965
-OS: Ubuntu 13.04
Casimer the Adequately Skilled 2013년 5월 14일 오후 7시 47분 
What version of Mesa are you using? One user reported that problem being fixed when they updated to Mesa 9.2.[github.com]
:(){ :|:& };: 2013년 5월 16일 오후 3시 19분 
I've been having some textures flicker invisible like WiRE too. Nice to know there's a solution.
TRololo 2013년 5월 16일 오후 5시 25분 
Thanks for the answer. Well... I'll wait until mesa 9.2 be in the arch's repositories, because the git version needs some unstable packages right now and they could break my system.
juliobritomg 2013년 7월 15일 오후 4시 44분 
My hd 3000 have this issues and im using the lastest mesa.
glxinfo output.

OpenGL version string: 3.0 Mesa 9.2.0-devel
OpenGL shading language version string: 1.30
TRololo 2013년 7월 15일 오후 7시 04분 
Hi juliobritomg, this issue seems to be fixed in that version(or maybe they are still working on that), in my case, I just installed libtxc_dxtn package and it fixed the problem. If you're running Linux 64bits you need to install libtxc_dxtn and lib32-libtxc_dxtn for 32bits applications. More info here: https://wiki.archlinux.org/index.php/Intel_Graphics (see Troubleshooting)
Drekyn 2014년 1월 8일 오전 1시 50분 
Got the very exact problem on a machine with intel i5 and integrated intel HD4000 running linux mint. this thread made my day: https://01.org/linuxgraphics/comment/358#comment-358

for me the solution was then to simply run:

sudo apt-get install libtxc-dxtn-s2tc0 libtxc-dxtn-s2tc0:i386

Hope this helps!
7개 중 1-7 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 5월 14일 오후 5시 36분
게시글: 7