Left 4 Dead 2 Beta > 일반 토론 > 제목 정보
PyGuy 2013년 5월 3일 오후 9시 45분
Issue Report - Xbox 360 Pad Not Functioning Properly
The title says it. The directional pad works in the menus and stuff, but not in a game. Now before all the unhelpful elitist comments flood in saying "YOU'LL BE AT A DISADVANTAGE WTF," some people prefer using a gamepad. I primarily use the standard mouse and keyboard setup, but this might cause some woes for people utilizing Big Picture Mode if this issue is left unaddressed.

I posted the issue on GitHub as well.
https://github.com/ValveSoftware/Source-1-Games/issues/428
17개 중 1-15 표시중
< >
Carpenter 2013년 5월 4일 오후 8시 47분 
This issue is happening to me too. I have a Logitech wireless gamepad F710 in X-box pad mode, and it works fine except for the two analog sticks, making the game unplayable. I am running Debian Wheezy, but it doesn't seem to be distribution specific based upon the multiple reports of the exact same problem at the link.

I have problems with my wrists that often make mouse and keyboard play a non-starter, please fix this Valve.
Carpenter님이 마지막으로 수정; 2013년 5월 4일 오후 8시 49분
obedlink 2013년 5월 4일 오후 10시 13분 
I have a xbox 360 wireless controller and I have the same problem
Benjamin 2013년 5월 4일 오후 11시 32분 
Same problem here. I commented on your github bug report.
Rayman1103 2013년 5월 5일 오전 6시 55분 
Are you all running on Linux? Because a 360 controller should function properly on Windows at least. Also, are any of the buttons functional when in-game, like (A) to jump? Because you may need to change some settings in the 360controller.cfg file.
Rayman1103님이 마지막으로 수정; 2013년 5월 5일 오전 6시 55분
Benjamin 2013년 5월 5일 오전 7시 28분 
All Linux here, I think. Basically everything works as expected except for the analog sticks. Manually binding them via config file or developer console has no effect.
Rayman1103 2013년 5월 5일 오전 7시 32분 
Linux Benjamin님이 먼저 게시:
All Linux here, I think. Basically everything works as expected except for the analog sticks. Manually binding them via config file or developer console has no effect.
If it's just the analog sticks that aren't working, I may be able to assist you. Make sure the joy_axis settings in your 360controller.cfg file are as follows:

joy_advaxisx 3 // x-axis controls GAME_AXIS_SIDE (strafing left and right)
joy_advaxisy 1 // y-axis controls GAME_AXIS_FORWARD (move forward and back)
joy_advaxisz 0 // z-axis is treated like a button
joy_advaxisr 2 // r-axis controls GAME_AXIS_PITCH (look up and down)
joy_advaxisu 4 // u-axis controls GAME_AXIS_YAW (look left and right)
joy_advaxisv 0 // v-axis is unused

I had to change some numbers around in order for my 360 controller to work, and I have Windows. Let me know if that helps.
Rayman1103님이 마지막으로 수정; 2013년 5월 5일 오전 7시 37분
cydharttha 2013년 5월 5일 오후 4시 54분 
May or may not be helpful.. I just came from playing a few hours of the Portal beta on Linux, was playing w/ a Logitech controller the whole time, no issue. Fired up L4D2 and found the same issues as reported above; no analog sticks. This controller doesn't have any XBox360 mode or such.
Benjamin 2013년 5월 5일 오후 6시 28분 
Yeah, I appreciate the help Rayman, but it appears to just be a bug. I guess that's expected, as it is a beta.
Rayman1103 2013년 5월 5일 오후 8시 24분 
Alright, just trying to help if I could. I hope the issue gets sorted out for you.
FullMetalAddict 2013년 5월 13일 오전 12시 24분 
I too wanted to add that I'm having trouble with the gamepad analog sticks with my wireless xbox 360 controller on Ubuntu LInux using the "xboxdrv --trigger-as-button" module.
[VALV3] GabeN 2013년 7월 8일 오후 5시 03분 
I'm having the same problem, buttons respond fine but the sticks don't work at all. I'm assuming it's a bug or something. And yes I'm also running Linux.
[VALV3] GabeN님이 마지막으로 수정; 2013년 7월 8일 오후 5시 03분
jonboyni 2013년 7월 22일 오전 4시 29분 
+1 that. Left 4 Dead 2, XBox 360 controller on Ubuntu Linux. Everything but the analog sticks is working.
Sykasaur 2013년 7월 28일 오전 6시 04분 
I am also having this issue with Ubuntu 13.04/Linux. The analog sticks do not work, and it is definitely a problem with the game. The analog sticks work in Half-Life 2, Half-Life 2: Episode One, Half-Life 2: Episode Two, Team Fortress 2, Portal, and Half-Life 2: Deathmatch. It seems to be affecting everyone using the Xbox 360 controller on Linux.
UbuntuAddicted 2013년 11월 28일 오전 6시 48분 
i too am having an issue with my xbox 360 wired controller. it works fine in bastion and seriuos sam 3 bfe but not in L4D2. any help would be appreciated. i am using xpad i believe. i even tried enabling the console and issuing exec 360controller but still not even my buttons or the dpad work in the menus.
Benjamin 2013년 11월 28일 오전 9시 20분 
This bug has been fixed. Do you have any updates pending? If not, try configuring the controller from within Big Picture mode, then launching L4D2.
17개 중 1-15 표시중
< >
페이지당: 15 30 50