Miasmata > General Discussions > Topic Details
snozzle21 Feb 8, 2013 @ 12:22pm
Can't play because of beast :(
The game doesn't play smoothly for me (have beta 3), which is fine for collecting plants and triangulating. I was really enjoying the game even though it was really jerky. But now the monster shows up frequently and I can't run away because the frame rate is so low. If the game ran smoothly I could run away. I wish I could just turn off the monster so I could play at least.

I tried turning my switchable graphics to use the discrete card only in my bios. Still laggy.

Any help with turning off the monster please?
Showing 1-6 of 6 comments
< >
[VGS]Lord_Of_Sabers Feb 8, 2013 @ 2:43pm 
mabye we can trade copys for some reson the monster does not show up in my game. :(
Vixie Feb 8, 2013 @ 7:58pm 
What are your computer specs, Snozzle? The IonFX guys can't really diagnose what's causing your playability problems without that information.
snozzle21 Feb 9, 2013 @ 9:13am 
Good point vixie. Was hoping for a no monster mode. I have a thinkpad t420s laptop running windows 64 pro 8gb ram with nvidia nvs4200m (I think). I know the graphics card isn't really for games, but shouldn't I be able to play at least on low settings?
MasterFail Feb 11, 2013 @ 1:18am 
Originally posted by snozzle21:
[...]but shouldn't I be able to play at least on low settings?

theoretically, yes. practically, the optimus drivers could prevent the card to work at its full potential.
Kanharn Feb 11, 2013 @ 3:50am 
This game is the Crysis of Indie games, So unless you have a good Gaming rig you will have issues.

Also have you downloaded the Beta patch, Irons out a lot of issues. Also you cant have this game without the creature or the story and ending would not make sense.
snozzle21 Feb 12, 2013 @ 5:24am 
Hm I shut the graphics switching off in the bios, and yes I did download beta 3.
:(
Showing 1-6 of 6 comments
< >
Per page: 15 30 50