Miasmata > General Discussions > Topic Details
IonFx  [developer] Dec 1, 2012 @ 1:01pm
From the Devs: Fix for some Laggy Laptops w/ switchable GPUs.
This has helped a few people. On some machines, running Miasmata has not triggered the discrete Nvidia or ATI GPU to activate. So instead, the integrated Intel chip ends up powering the game. You can force Miasmata.exe to use the Nvidia or ATI chip by going into your video driver settings.

This will not explain all slowdown people are experiencing. We are working on an update now to address optimization and other bug fixes. There is not time table yet, but we're shooting for sometime the week of Dec 2nd.
Showing 1-15 of 58 comments
< >
Nothing Goes Over My Head Dec 1, 2012 @ 1:34pm 
Thank you very much for working on this issue
IonFx  [developer] Dec 1, 2012 @ 1:49pm 
Originally posted by I'm Gentle:
Thank you very much for working on this issue
Of course! :) We really believe in our game and want to do everything we can to make it something we're really proud of.
Last edited by IonFx; Dec 1, 2012 @ 1:49pm
Mat - allansianadventurer Dec 1, 2012 @ 2:16pm 
This worked for me, but it's still got some lag. I'll wait for the patch, but I wouldn't be surprised if my laptop is just getting old.
Fireteam Yogurt Dec 1, 2012 @ 8:15pm 
Oh, my GOSH!!! THANK YOU!!

Works flawlessly now! I knew something wasn't right.

Amazing game.
Xeno Dec 2, 2012 @ 3:45am 
How would one do this?
stoneage414 Dec 2, 2012 @ 9:11am 
Originally posted by Klaxxi'va Xeno:
How would one do this?

Open the control panel for Nvidia, I just used the search function in the start menu. Go into "manage 3D settings" and click in program settings. You'll probably have to add miasmata.exe to the list of program files you get, it's located in the Steam folder on your hard drive. Once you've added it to that list select the preferred graphics processor as "High-performance NVIDIA processor" rather than "integrated processor"
This reduced the lag massively for me, there's still the odd bit here and there but I'm guessing the upcoming patch will solve that, thanks to the developers for addressing this so quickly and suggesting the above fix.
The Virgin Queen Dec 2, 2012 @ 10:15am 
Okay, how would one go about doing this in for ATI? I've got the AMD Vision Engine Control Center open, but I've got no idea what to do next. I made an Application Prpfile for the game, but that hasn't fixed the issue. Dying to play this, but it's just too laggy for me.
Last edited by The Virgin Queen; Dec 2, 2012 @ 10:22am
lasgalletas Dec 2, 2012 @ 10:58am 
that doesn't work for me. Looking forward to get a patch (and play, for sure). I've got vaio vpcz1 i7 2,67 Windows 7 64, 6 GB ram memory, nvidia gt330m. Works great with high resolution specs with 99,9% games (dishonored, black ops 2, dead space 2, mass effect 3 and bunch of 2012 and 2011 titles)
Last edited by lasgalletas; Dec 2, 2012 @ 11:11am
IonFx  [developer] Dec 2, 2012 @ 11:22am 
Originally posted by lasgalletas:
that doesn't work for me. Looking forward to get a patch (and play, for sure). I've got vaio vpcz1 i7 2,67 Windows 7 64, 6 GB ram memory, nvidia gt330m. Works great with high resolution specs with 99,9% games (dishonored, black ops 2, dead space 2, mass effect 3 and bunch of 2012 and 2011 titles)
Does Miasmata play at all with with you laptop? or just laggy?
lasgalletas Dec 2, 2012 @ 12:23pm 
Thanks for a quick reply! Yep, it works, but very laggy. I tried to play with configuration but this didn't help. I've got an updated video driver, added game to the list of programs in geforce menu, but don't know what to do else to get it work :\
Last edited by lasgalletas; Dec 2, 2012 @ 12:23pm
sloth101 Dec 3, 2012 @ 1:25am 
Originally posted by IonFx:
Originally posted by I'm Gentle:
Thank you very much for working on this issue
Of course! :) We really believe in our game and want to do everything we can to make it something we're really proud of.

Both of you should already be Very Proud, I just finished and must say Hats off to you both! That was simply awesome! That said I had some minor issues that I will try and post in the next couple of days as Constructive Criticism Only, I am very happy with what I bought and feel I got a good deal on the price!

Mind you my first video game was Pong so I have been playing for a while. :)
Last edited by sloth101; Dec 3, 2012 @ 1:30am
SabreXT Dec 3, 2012 @ 1:43am 
The many reports of performance issues on high end machines was what is stopping me buying this, so I hope it gets fixed.
I Am Groot Dec 3, 2012 @ 9:22am 
Originally posted by SabreXT:
The many reports of performance issues on high end machines was what is stopping me buying this, so I hope it gets fixed.

Agreed. I have the game onthe lowest settings and I can barely get between 15 and 20 FPS. Given I can run Arkham City and Skyrim up past 40 FPS on average, I should be able to handle this just fine.
Pred-JDAM Dec 3, 2012 @ 12:02pm 
I just DL'd the game and unfortunately the lag is pretty bad, on top of that I have no idea how to change the graphics setting because the menus are currently just blank lines, I pretty much had to guess which line was quit. Hope the game gets fixed soon. I'm not too upset over this, I just wanted to report my issue and show my support, this game seems pretty good.
<-L.O.L.-> =T-Rex= Dec 3, 2012 @ 12:48pm 
hello, your game work in win XP ?
Showing 1-15 of 58 comments
< >
Per page: 15 30 50