BRINK > General Discussions > Topic Details
Sir Sraimp Jun 21, 2013 @ 5:10pm
Brink crash to desktop with no error
Usually it crashes after about 5 mins of gameplay but when im in the menus trying to choose a mission and what not it crashes even sooner. Please help!

My system:

Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: To be filled by O.E.M.
Processor: AMD FX(tm)-6100 Six-Core Processor (6 CPUs), ~3.3GHz
Memory: 8192MB RAM
Available OS Memory: 8156MB RAM
DirectX Version: DirectX 11
Showing 1-11 of 11 comments
< >
inG.Dizzi Jul 1, 2013 @ 6:19am 
Good configuration ton run brink but precise your graphic card
Drivers problem i think
Sir Sraimp Jul 1, 2013 @ 12:16pm 
Originally posted by inG.Dizzi:
Good configuration ton run brink but precise your graphic card
Drivers problem i think
I went to AMD's website and downloaded the driver auto-installer and ran it twice, I really don't think it's that.
izzeisak Aug 16, 2013 @ 12:09pm 
Same ♥♥♥♥♥ problem, just bought it and frankly i´m ♥♥♥♥ed, 25 euro for nothing.
Last edited by izzeisak; Aug 16, 2013 @ 12:09pm
|JEZ| NeVeN {Cro} Aug 16, 2013 @ 4:37pm 
Last edited by |JEZ| NeVeN {Cro}; Aug 17, 2013 @ 1:12am
Supernautilus Aug 31, 2013 @ 8:10am 
I just reinstalled this game and I am having this problem. A couple minutes of gameplay and I get booted to desktop. It doesn't make sense, I have 181 hours played on this game, never had an issue before.

Anyone have any ideas?
Last edited by Supernautilus; Aug 31, 2013 @ 8:12am
|JEZ| NeVeN {Cro} Sep 25, 2013 @ 4:28am 
Originally posted by Supernautilus:
I just reinstalled this game and I am having this problem. A couple minutes of gameplay and I get booted to desktop. It doesn't make sense, I have 181 hours played on this game, never had an issue before.

Anyone have any ideas?
It seems to me like a problem solved long ago, I think there was an ATI card error. Download the latest Brink version again and update graphic drivers.
Supernautilus Sep 25, 2013 @ 9:25am 
Originally posted by |JEZ| NeVeN {Cro}:
Originally posted by Supernautilus:
I just reinstalled this game and I am having this problem. A couple minutes of gameplay and I get booted to desktop. It doesn't make sense, I have 181 hours played on this game, never had an issue before.

Anyone have any ideas?
It seems to me like a problem solved long ago, I think there was an ATI card error. Download the latest Brink version again and update graphic drivers.

This was just a month ago now, so everything is the latest of course. If it's a specific problem or bug causing an error, that I guess that could be it. But beyond updating all drivers, I don't know what else to try.
|JEZ| NeVeN {Cro} Sep 25, 2013 @ 10:41am 
You download Brink from steam? You have a 64bit win?
Supernautilus Sep 25, 2013 @ 12:36pm 
Originally posted by |JEZ| NeVeN {Cro}:
You download Brink from steam? You have a 64bit win?

Well Steam says I have 181 hours played in Brink, so yes I think I downloaded it from Steam. :)

And yes, I have Windows 7 64bit..
|JEZ| NeVeN {Cro} Sep 25, 2013 @ 2:55pm 
Try delete local contents for Brink and download and install game again. You certainly have an ATI card, so first install the latest drivers. This is tipical error for old ATI drivers or (and) Brink instalation without latest patches. Many problem is occured on Windows 7 32 bit, but you don't have this.

I have similar problem on one of my PC with ATI card but solved long time ago with Windows 7 64 bit and upper solution.

Some old threads which include this error with ATI card, but all solved with new ATI drivers and Brink patches:
http://forums.steampowered.com/forums/showthread.php?t=2267427
http://forums.steampowered.com/forums/showthread.php?t=2269064
http://forums.warchest.com/showthread.php/31603-Brink-crashes-to-desktop
http://forums.warchest.com/showthread.php/31661-Brink-crashing-to-desktop-mid-gameplay
Supernautilus Sep 25, 2013 @ 4:24pm 
Hmm, if the information in your post is accurate, then the real question is why the problem is still happening on a system with the latest drivers and game patches. According to you, I shouldn't be having this problem at all. Very strange.

Perhaps it's just a corrupt installation. I will try uninstalling, and then manually deleting any remaining files. Then I'll try reinstalling. We shall see. :)
Last edited by Supernautilus; Sep 25, 2013 @ 4:24pm
Showing 1-11 of 11 comments
< >
Per page: 15 30 50