Psychometric Oct 22, 2012 @ 5:29pm
Unable to start the game
EDIT: This issue had been fixed with an update, works fine now :)

When I try to launch the game I get an error message popping up in a window titled Microsoft .NET Framework. Has anyone else experienced this or found a solution? This comes up before the launcher appears, and after closing it the launcher comes up but clicking on anything on the launcher causes the same error and I cannot get past this. The text of the error is:


************** Exception Text **************
System.DllNotFoundException: Unable to load DLL 'GSDemoConfigUtilitiesDll.dll': The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (Exception from HRESULT: 0x800736B1)
at GSDemoConfig.ConfigData.GSControlsConfig.HasController()
at GSDemoConfig.UI.GSControlsUserControl.GetSelectedInputDevices()
at GSDemoConfig.UI.GSControlsUserControl.set_InputLayoutsPath(String value)
at GSDemoConfig.GSMainForm.InitializeComponent()
at GSDemoConfig.GSMainForm..ctor()
at GSDemoConfig.UI.GSLauncherForm.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4971 (win7RTMGDR.050727-4900)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
GSLauncher
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///D:/Games/Steam/steamapps/common/Giana%20Sisters%20Twisted%20Dreams/launcher/GSLauncher.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4977 (win7RTMGDR.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4971 (win7RTMGDR.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4980 (win7RTMGDR.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
GSLauncher.resources
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///D:/Games/Steam/steamapps/common/Giana%20Sisters%20Twisted%20Dreams/launcher/en/GSLauncher.resources.DLL
----------------------------------------
Last edited by Psychometric; Oct 22, 2012 @ 6:32pm
Showing 1-15 of 17 comments
< >
Grissi Oct 22, 2012 @ 5:35pm 
I have the same issue, seems to me that steam is unable to install some necessary game component when you start it. Steam goes instantly from ,,installing step 1/5" to the game launcher.
Last edited by Grissi; Oct 22, 2012 @ 5:37pm
Nocturnal Oct 22, 2012 @ 6:15pm 
i guess dotnet framework isnt installed maybe you should install it seperately yourself
Psychometric Oct 22, 2012 @ 6:18pm 
I tried reinstalling .NET myself, that still didn't help. And, like Grissi, after trying to run the game I see it going straight from 'Installing step 1/5' to immediately trying to launch and getting errors.
Grissi Oct 22, 2012 @ 6:22pm 
I have it installed, at least versions: 2.0 - 3.0 - 3.5 and 4.0. If you know what specific version/files it requires to run it would be helpful to know.
Grissi Oct 22, 2012 @ 6:27pm 
A update was just released on steam with the missing files. It runs perfectly fine now.
BFG Florian  [developer] Oct 22, 2012 @ 6:31pm 
Hi. I just uploaded some files that the install script needs ( 1/5 to 5/5 ) and steam should offer you an update. Hope this fixes the problem for you and that you can play undisturbed henceforth.

Have Fun
Psychometric Oct 22, 2012 @ 6:32pm 
Confirmed, kudos for the prompt fix :)
Arcane is bad for sure Oct 22, 2012 @ 6:51pm 
I still get this error. Happen when I have the settings set to DirectX 9. And when I change it to DirectX 10 or 11, I get this error. http://i.imgur.com/mpuHz.jpg Game just doesn't wanna work for me. :(
Mason Oct 23, 2012 @ 1:58am 
I still get an error aswell.
Last edited by Mason; Oct 23, 2012 @ 7:55am
karmington Oct 23, 2012 @ 7:05am 
Still locked up here as well.
Arcane is bad for sure Oct 24, 2012 @ 7:34am 
Yeah, I'm pretty sad I can't play this still. And I helped back the game. :/
Handl3vogn Oct 24, 2012 @ 10:42am 
Got it to work by installing all the files in Steam\steamapps\common\Giana Sisters Twisted Dreams\Extras
Arcane is bad for sure Oct 24, 2012 @ 11:39am 
Tried that, still not workin' for me. :/
DragonMagnus Jan 3, 2013 @ 3:04pm 
I get the same errors and I have tried everything and I can't play the game. Does anyone has found a solution??
melkathi Jan 3, 2013 @ 4:14pm 
the known wierd fixes for getting the game to run that have worked in various instances are:
installing a random other steam game - suddenly Giana Sisters worked
running the game from the admin account
uninstalling the demo
Showing 1-15 of 17 comments
< >
Per page: 15 30 50