cammelspit Feb 19, 2013 @ 3:48pm
Glitchey Giana sissterss and I need help to figure this out!
http://youtu.be/OnpOuxfl7WI I want to play this game really bad but there is this flickery glitch that seems to be persistent as I play! If anyone has any ideas please let me know. My deck is a 2.93Ghz Core 2 Duo E7500 overclocked to a 3.33 and six gigs of ram with one ATI Radeon HD 7770 for graphics. I am running in 1920x1080 in the video but it also is persistent with other resolutions as well. I know the video is low res but you can see the problem well enough. I will try and get a screen grab or two or maybe even another video in higher res if you guys this it could help. THANKS!
Showing 1-10 of 10 comments
< >
Ringo Feb 19, 2013 @ 5:52pm 
First things first, make sure you're running the latest drivers for your hardware and update your OS if needed. If you updated anything, check and see if that fixed the issue. If not, then verify integrity of game cache in Steam to make sure you nothing is missing or corrupted. If Steam downloads anything then check and see if the issue is still there.

After that, go to your graphic settings and turn every option off or as low as it will go. Run the game and see if it's still there. If it's not, then it's a simple trial and error process. Turn the options back on, or up, one at a time until you find the one that's causing the problem and leave that one off. Start with the Direct X option if you have it available.

If it's still there then make sure you aren't telling your graphics card to override application settings. If you don't know how to do that then odds are you aren't overriding application settings, but you should still check to be sure. You can find out how with google.

Failing that, I don't know.
Last edited by Ringo; Feb 19, 2013 @ 5:55pm
cammelspit Feb 19, 2013 @ 6:46pm 
My PC is a Fresh install of windows 7 and the latest cataliyst suite. Fully updated. I should have put in my OP that I had actually done all that you have suggested. I appreciate the input though. I was just hoping ssomeone may know of some... "Oh, thats the problem that can be fixed by standing on one foot, rubbing ones own belly and patting ones head singing the tea pot song and BOW! Fixed!" kind of thing. I will do more testing but if anything comes to mind please, let me know! :) THX
Ringo Feb 19, 2013 @ 7:49pm 
One other thing to check is your bios. See if there is an update for it even if the hardware is fairly new. Last year when I built my current PC I could play any game I wanted no problem except for Saints Row the Third, which had some in game issues. A simple bios update fixed it right up.

It isn't covered by typical updating procedures which is why I mention it separately. If you're using an ASUS motherboard (what I have), you can update it easily with their software. I'm sure other motherboards have something similar.

I'd suggest asking the company that made your graphics card or checking on their forums (if they have any). Could just be something they need to fix.
cammelspit Feb 19, 2013 @ 9:12pm 
thx for the input. I will do just that and see.
Bulldogs Feb 21, 2013 @ 6:57am 
Disable catalyst A.I.
cammelspit Feb 21, 2013 @ 8:19am 
catalyst ai had broken games in the past.... will try.... completely forgot about that one.
ElleNearMello Apr 6, 2013 @ 8:07am 
I have the same problem but WORSE, because those glitches are constantly on screen, in full screen, so I basically cannot play. It is like a new layer on top of the game. I think it is due to latest video drivers, becuase some months ago the game was OK.
Recently I just upgraded the video drivers, and boom.... broken game :(

My PC was running Giana fine, and no hardware was changed. THe only thing was video driver upgrade.

My pc is : core i3 530, 8gb ram, Sapphire 7850 2gb, windows 7 64bit.
cammelspit Apr 6, 2013 @ 10:43am 
and your card is also an ATI card... That stands to reason.... I just wish there were some way to fix this thing... My brother has an almost identical set up to me with the exception of the main chipo being a quad core and he has the exact same issue I do in the exact same way. At least this tells me it's no hardware issue.
ElleNearMello Apr 13, 2013 @ 5:36am 
Fixed: configure the game with direct x 9, instead of direct x 11. use the game control panel that appear on launch.
cammelspit Apr 16, 2013 @ 12:04pm 
I did do this and it does work but on my config it looks not nearly as good on DX9. Same with a few games that do 9/10/11 ut seems its just the way my card renders it. I may just HAVE to go with it to play this game, its a shame really as in 11 mode the game truely looks fabulous. thx for the input though!
Last edited by cammelspit; Apr 16, 2013 @ 12:05pm
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Feb 19, 2013 @ 3:48pm
Posts: 10