fpsobsessed Feb 7, 2013 @ 12:57am
Game is locked at 60 fps on a 120 hz monitor
With vsync on, is there a reason why the game is locked at 60 fps on a 120 hz monitor?
Showing 1-15 of 15 comments
< >
Mehbah Feb 7, 2013 @ 10:26am 
I'm just going to be unhelpful here and point out that your name is pretty amusing considering this thread.

Have you tried using the nvidia control panel or the AMD equivalent to get 120 FPS vsync?
Craiazy Feb 7, 2013 @ 11:41am 
First thing i would check is can your rig run the game at 120+ fps. If not vsync will put you at 60fps anytime your system would dip below 120 fps. same thing happens with a 60hrz monitor if you cant sustain 60fps vsync locks it at 30fps. Always halfing the amount based on performance.
fpsobsessed Feb 8, 2013 @ 12:15am 
I've messed around with the nvidia control panel. Doesn't work. My fps with vsync off never hits 120. It's around 110 or so. However, if I set the maximum frame rate to 110 or 100 and enable vsync, it's still locked at 60 fps.
Mehbah Feb 8, 2013 @ 7:40am 
Did you turn off vsync in the game when you tried that?
fpsobsessed Feb 8, 2013 @ 8:26am 
Yup. Did turn it off in the game. Oh well, no big deal.
NoVa Feb 8, 2013 @ 10:45am 
Isn't Triple Buffering supposed to fix the "frame rate halving". I haven't had this problem with frame rate halving with Vsync on lately though for some reason.

Not sure if this would apply to you, but..

I had a similar issue with the game locking to 60FPS when I installed my new Yamakasi Catleap 2B Extreme Overclock Edition 27" S-IPS Monitor @ 2560x1440.

Turns out that when I put the game in full screen, it would totally ignore the custom overclocked refresh rate of 118Hz I've set & used 60Hz regardless of what was set in the Game Launcher. This is fixed in a window however.

Basically to stop this from happening in full-screen, I actually had to "remove" 60Hz from being detected as a usable refresh rate (now 60Hz is unavailable in everything xD). Now the game gets locked to 118FPS instead of 60 in fullscreen like I wanted.
fpsobsessed Feb 8, 2013 @ 2:14pm 
Hmm, that sounds like it may work. Will have to try when I get home.
NoVa Feb 9, 2013 @ 11:27am 
So...How did that work out?
fpsobsessed Feb 9, 2013 @ 11:40am 
Actually, how do you go about removing the 60 hz option? I couldn't find a way to do that.
NoVa Feb 9, 2013 @ 11:52am 
Due to my Aspergers, I'm not sure if I can explain it. I have great difficulty in explaining things :/
All I can say, is that I used ToastyX's CRU to do it which I found off the 120hz.NET forums.
fpsobsessed Feb 9, 2013 @ 12:37pm 
No worries. I appreciate you trying to help. It's not a big deal. Maybe I'll try googling it, but again, it's not huge deal for me.
necrosan Feb 13, 2013 @ 4:40pm 
Originally posted by Craiazy:
First thing i would check is can your rig run the game at 120+ fps. If not vsync will put you at 60fps anytime your system would dip below 120 fps. same thing happens with a 60hrz monitor if you cant sustain 60fps vsync locks it at 30fps. Always halfing the amount based on performance.


Don't talk stupid.
Stop spreading disinformation.
Last edited by necrosan; Feb 13, 2013 @ 4:40pm
pollo Feb 13, 2013 @ 8:35pm 
Is there a reason why someone needs more than 60 frames?
fpsobsessed Feb 13, 2013 @ 10:16pm 
Because 120 fps is even smoother than 60. Try playing a first person shooter at 120 fps versus 60 fps. Big difference.
Big Hat Logan Feb 14, 2013 @ 6:56am 
You said with vsync off you are around 110fps, but never above 120. With Vsync on you will drop down to 60 (=120/2), unless the game supports something like triple buffering. Not sure if it does. If not, you will be limited to 60fps (vsync on) or need a faster PC. Third party tools might help, depending on graphics card manufacturer. Some are able to force triple buffering, but that does not work in all games. Cannot really test it, because my monitor is at 60Hz max.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Feb 7, 2013 @ 12:57am
Posts: 15