Monk on Fire Oct 26, 2013 @ 6:23pm
Stretch to Screen?
Hey guys I'm playing Morrowind with Overhaul 3.0 Installed (only mod I'm using) and even when I specified 1080p in the options it won't scale to my screen. I have cm black border around the game. I have GPU scaling turned on in my control center and for all other games it scales to my screen. But Morrowind isn't scaling, what can I do to fix this?
Showing 1-6 of 6 comments
< >
Killeri404 Oct 27, 2013 @ 1:31am 
Set MorrowindLauncher.exe and Morrowind.exe always run as administrator. If you don't, you're gonna have a bad time
Monk on Fire Oct 27, 2013 @ 4:49am 
I'm already running them as admin.

Basically I did all the graphical set up again and this time set it to windowed mode and didn't touch the in game resolution settings (I think I did the first time). It now runs fine in 1080p windowed mode, but in fullscreen it still doesn't fill my screen. Windowed stretches to my screen by full screen doesn't? Oh well I'm happy now anyway.

I'm a bit concerned about my FPS though, it sometimes dips to 25 when in a crowded city. Most of the time it's around 40. I'm playing on very high with 4x MSAA and 16x AA.

FX 6300 @ 4.1GHZ and 7850 (25% Overclock, so slightly better than stock 7870)

Last edited by Monk on Fire; Oct 27, 2013 @ 5:25am
Shadow Oct 27, 2013 @ 2:43pm 
To get the overhaul to run on a custom resoluton on some operating systems, you need to edit your registry. Normally, the overhaul does this itself, but for some systems, it edits the wrong registry key. You can go in and manually edit your registry, but if you dont know what you're doing, you can cause problems for your system.

Assuming you use Windows, to edit your registry you need to do a search for a program called 'Regedit'. Then you need to locate the key "Computer\HKEY_CURRENT_USER\Software\Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Bethesda Softworks\Morrowind". Then to set your display for 1080p, locate "Screen Height" and set it to "0x00000438 (1080)" and "Screen Width" needs to be set to "0x00000780 (1920)". The game should run in full screen after editing these settings, assuming your desktop resolution is set to 1920x1080.

Editing your registry should always be done with care, so don't do this if youre unsure. You could also go to the MGSO forums to find other potential solutions on there.
Monk on Fire Oct 27, 2013 @ 2:46pm 
Originally posted by Shadow:
To get the overhaul to run on a custom resoluton on some operating systems, you need to edit your registry. Normally, the overhaul does this itself, but for some systems, it edits the wrong registry key. You can go in and manually edit your registry, but if you dont know what you're doing, you can cause problems for your system.

Assuming you use Windows, to edit your registry you need to do a search for a program called 'Regedit'. Then you need to locate the key "Computer\HKEY_CURRENT_USER\Software\Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Bethesda Softworks\Morrowind". Then to set your display for 1080p, locate "Screen Height" and set it to "0x00000438 (1080)" and "Screen Width" needs to be set to "0x00000780 (1920)". The game should run in full screen after editing these settings, assuming your desktop resolution is set to 1920x1080.

Editing your registry should always be done with care, so don't do this if youre unsure. You could also go to the MGSO forums to find other potential solutions on there.

I think I'm fine playing on 1080p windowed so I won't mess with the registry. Are these fps dips in large towns (25fps in Balmora) usual?
Shadow Oct 27, 2013 @ 3:04pm 
The fps dips depend on your settings and system. Some settings, like the high quality shadows, have a larger effect than others. As to playing in windowed mode as you are now, I'm pretty sure that the game is just stretching the image to fit the screen, and not truly running the game at 1080p...but if that is the case, then you would get even larger fps dips in large towns. As for me, I use near-max settings and usually run at 15-20 fps outdoors, even in large towns. Indoors usually runs at 30 fps. The reason my fps is that low is because I use the high quality shadows feature, which tends to be buggy with many of the updated armors, causing fps loss.
Monk on Fire Oct 28, 2013 @ 6:11am 
The windowed 1080p looks exactly the same as the full screen one, it's just 1cm longer in every direction. I tried changing the res down to 720p and the detail went down so i'm 99.99% sure it's at 1080p it's just that on the full screen mode it leaves a 1cm border.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Oct 26, 2013 @ 6:23pm
Posts: 6