7 Wonders: Ancient Alien Makeover

7 Wonders: Ancient Alien Makeover

View Stats:
GirlyGirl Mar 22, 2013 @ 5:20pm
Game is running very sluggishly
I recently purchased this game but, while it does run, it does so very slowly. I have upgraded my video card drivers to the latest, I even updated directx, flash player and shockwave as I read that could effect things. Nothing has helped. I am running Windows xp with a AMD Athlon dual core 4200+ cpu. I have a Geforce GTX 560 video card and 3 gigs of ram. Hopefully someone will have some idea's for fixing this as I can't even seem to get Mumbo jumbo's website to accept a ticket to get help.
< >
Showing 1-14 of 14 comments
Kot Murzik Jul 17, 2013 @ 11:48pm 
You are using the AMD Dual-Core Optimizer?
CatPhoenix_GWJ Oct 26, 2013 @ 1:02pm 
Runs chopply and sluggishly slow full screen or in a window mode for me as well. And this is with an intel 4 core cpu and a amt 7950 card with 16 gigs of ram. Any idea why this is happenieng?

I'm guessing it's the super annoying custom cursor which apparently has no way to turn it off... why is there no way to turn this off?!? -sigh-
Last edited by CatPhoenix_GWJ; Oct 26, 2013 @ 1:12pm
i bought a mumbo jumbo bundle today and every one of the games runs in slow motion. anyone find a fix to this issue? what a waste of money. guess time to add mumbo to my list of blacklisted game companies.
GamerByDay  [developer] Oct 28, 2013 @ 9:26am 
Please reach out to us at support@mumbojumbo.com so we can see what the issue is. A few driver updates have caused this, and we have worked with manufactors to solve these issues. As most players experience no issues with our titles, we would love to figure out what is causing yours.

.oscilloscopa Feb 14, 2014 @ 12:13am 
with the new AMD Beta Driver 14.1 its fixed for me. (HD7850)

Furryka May 20, 2014 @ 2:13pm 
Windows 8
Core i7-3630qm / 8GB RAM / NVIDIA GeForce GT 635M

I don't know about very sluggishly, but i keep getting ~0.5 - 2 fps. I tired to update card, mess around with compatibility settings and still no response. Other MJ games seem to work just fine.

Any ideas?



I don't know what happened but today everything works fine. I'm starting to thing that the problem could hide in FullHD monitor. That's the only thing that was changed. 1080p monitor to 1600x900. I feel dumb >..<



And now everything works fine, even on that HD monitor. I don't get it, but the game is amazing and addictive.
Last edited by Furryka; May 21, 2014 @ 1:52pm
vanetz Jul 8, 2014 @ 2:31pm 
Weird. It ran fine until yesterday, and I launched it today and it's slow as hell. What the f is going on... Didn't change any settings or hardware, just POOF and it slowed to a crawl.
Daisysmurf Aug 21, 2014 @ 1:55pm 
Same here just crawls to 2 FPS , have the latest Nvidia Drivers installed and it seemed to happen overnight.
K0DeX Aug 26, 2014 @ 4:52pm 
I don't have any AMD hardware, but did install the latest NVidia Beta driver, and it seems like people who have the latest drivers for their NVidia cards are having the same issue.. Devs, any news on this? I have tried the game with the previous driver, but it still only ran at 2-3 frames per second. :(

Using Windows 7 ULT 64bit, NVidia 640, Quad Core 2.8mhz, 4GB RAM.
Janus Dec 19, 2014 @ 1:06pm 
Originally posted by vanetz:
Weird. It ran fine until yesterday, and I launched it today and it's slow as hell. What the f is going on... Didn't change any settings or hardware, just POOF and it slowed to a crawl.
Same here. It ran fine yesterday, no 2fps max.

Edit: Driver Update did the trick. It's running smootly again. Still odd, as it was running smoothtly before too.^
Edit 2: it's back to sluggish performance. I didn't change the drivers or anything just rebooted the system. Seems to be arbitrary.
Last edited by Janus; Dec 21, 2014 @ 4:58am
Janus Dec 21, 2014 @ 4:34pm 
Ok this is getting ridiculous. I tried it today and it ran fine, then it turned mid play into♥♥♥♥♥♥ This is definitely a bug and not driver related.
jello ツ Jul 30, 2016 @ 5:09am 
For me this game runs sluggish as hell, when I have Virtualisation [which is used to run virtual PCs within the current OS] activated in the BIOS. If I de-activate this setting, it runs fine.

I stumbled upon this “solution” when Assassin’s Creed III and Liberation ran like dogshit after I upgraded from Windows 7 to 10, and I just recently remembered how this game behaved a couple of years back. [Then still under Windows 7, though.]

I’m on an AMD APU, but as this seems to be a wider issue, people might wanna give it try anyway. I contacted Ubisoft about why this could be with their games, but, of course, no response.
ThreeSon May 21 @ 2:10am 
Has anyone found another solution besides disabling Virtualisation in the bios?
grimmute Sep 12 @ 5:59am 
I am also looking for a solution. Anyone has an idea? I can't play it at all.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50