Dead Pixels > General Discussions > Topic Details
Rincewind Ze Wizard Sep 29, 2013 @ 1:43pm
Dead Pixel XNA Error
When trying to launch I get this error
Dead Pixels Launcher has encountered an error.
Version:Steam 1.1.3

Could not load file or assembly 'Microsoft.Xna.Framework.Graphics.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)

at Dead_Pixels_Launcher.Game1..ctor(String[] args)
at Dead_Pixels_Launcher.Program.Main(String[] args)
I tried reistalling and installing XNA framework again
Anyone know of a fix
Last edited by Rincewind Ze Wizard; Sep 30, 2013 @ 8:06am
Showing 1-10 of 10 comments
< >
CantStrafeRight  [developer] Sep 29, 2013 @ 1:46pm 
Hey dev here

Sound like XNA may have gone corrupt

Could you try downloading and reinstalling these

.NET 4.0 Framework: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17851
XNA 4.0 Redistributable: http://www.microsoft.com/download/en/details.aspx?id=20914
DirectX 9.0c: http://www.microsoft.com/download/en/details.aspx?id=35

Hope that helps.
Last edited by CantStrafeRight; Sep 29, 2013 @ 1:47pm
Rincewind Ze Wizard Sep 30, 2013 @ 8:05am 
Tried all that but doesnt work Btw I have windows 8 would that make a difference
Last edited by Rincewind Ze Wizard; Sep 30, 2013 @ 8:05am
CantStrafeRight  [developer] Sep 30, 2013 @ 5:26pm 
It should run in Windows 8 fine. I've tried doing some reasearch and found nothing.

A few other things you could try.

The error makes it look like your xna install may be corrupt. You could try removing all versions of xna using control pannel, then re-install it. That might get it.

Could you try doing an integrity check through Steam
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Also try updating your graphics cards drivers.

If all else fails you could try getting a refund through Steam, but that is up to them.
Rincewind Ze Wizard Sep 30, 2013 @ 11:52pm 
It could be an entiely different problem as i had problems before (SysWow64)
and btw this is the quickest response Ive have from a dev:)
EDIT:I've tried other games with XNA and none work I'll try to get it fixed.
Last edited by Rincewind Ze Wizard; Oct 3, 2013 @ 9:40am
sMk record Oct 1, 2013 @ 2:44pm 
I got this game yesterday. and got same error. Afriend told me to disconnected Controller USB- Webcam USB . opened game . and worked ^^ hope it help you
Rincewind Ze Wizard Oct 2, 2013 @ 12:19am 
Thanks for the suggestion but I thinks its the XNA/.NET framwork that is the cause
(I tried that and it didn't work)
sMk record Oct 2, 2013 @ 10:09am 
ok goodluck with it.

cheers
Rincewind Ze Wizard Nov 2, 2013 @ 7:19am 
Finally got XNA to work:)
unicorn :> Nov 9, 2013 @ 12:43am 
how?
Rincewind Ze Wizard Nov 9, 2013 @ 12:59am 
I acutally went into Gnomoria's local files CommonRedist>DotNet>4.0 Client Profile and ran
Microsoft .NET Framework 4.0 Client Profile that then brought up a command promt and it work fine after NOTE If you dont have Gnomoria there is bound to be another of that file somewhere
Just checked and DLC Quest and that has the same
Last edited by Rincewind Ze Wizard; Nov 9, 2013 @ 1:02am
Showing 1-10 of 10 comments
< >
Per page: 15 30 50