Reus
Reus > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
AbbeyManuel  [developer] Jan 7, 2014 @ 11:28am
Game won't start/No suitable graphics card was found
If you're experiencing the error in the title, there are two possible solutions:

The current public branch of Reus is still the well-tested XNA version. As of now there's also a MonoGame version, which solves the error. This version is accessible in the beta branch. You can select this branch by Right-clicking Reus in your Library, selecting Properties and under the tab Betas, select the 'Protected beta' one. Reus should then update the game, although this might take some time. If Reus does not update, try using 'Verify Integrity of Game Cache' in the Properties menu.

If you're on your laptop, the following could also be the case;
You might have a graphics card that does meet the minimum requirement, but you also have a graphics card that doesn't meet the minimum requirement, and the standard settings is on the second graphics card.
SOLUTION: Switch to your more powerful graphics card. How that should be done depends on your laptop, and you're quickest of google-ing it. You can check your graphics cards in the device manager from Windows (Commonly under Display Adaptors).
Last edited by AbbeyAdriaan; Jan 7, 2014 @ 1:45pm
< >
Showing 1-15 of 63 comments
Rustis Jan 9, 2014 @ 2:44am 
Is this supposed to be a fix that we were waiting for? Sadly, it still does not launch:/
FelipeCuia Jan 9, 2014 @ 3:42am 
for about thirty minutes playing,my game crash...dont know how to fix
AbbeyManuel  [developer] Jan 10, 2014 @ 12:55am 
Rustis, Felipe, are you both on Windows?

It would be great if we could get to read any error reports, so that we work on the problems. They should be in Steam\SteamApps\common\Reus, named "errorReport <date>.txt"
Otherwise you can find them in the Event Viewer (Open in Run (Windows+R) with "eventvwr").
UrgotFantasy Jan 10, 2014 @ 6:35am 
It doesn't work for me. A window labelled "Monogame-SDL2 Window" opens and then I get a windows message "Reus has stopped working."
I am glad you guys are making progress on this. Good luck!
Solaris-Han Jan 11, 2014 @ 5:55am 
Originally posted by Mboy1100:
It doesn't work for me. A window labelled "Monogame-SDL2 Window" opens and then I get a windows message "Reus has stopped working."
I am glad you guys are making progress on this. Good luck!
This also happens to me
ziga Jan 11, 2014 @ 6:14am 
Originally posted by Mboy1100:
It doesn't work for me. A window labelled "Monogame-SDL2 Window" opens and then I get a windows message "Reus has stopped working."
I am glad you guys are making progress on this. Good luck!

I get same message .
broosk Jan 11, 2014 @ 1:06pm 
Originally posted by Mboy1100:
It doesn't work for me. A window labelled "Monogame-SDL2 Window" opens and then I get a windows message "Reus has stopped working."
I am glad you guys are making progress on this. Good luck!

Same
Astral Jan 11, 2014 @ 8:38pm 
Originally posted by Mboy1100:
It doesn't work for me. A window labelled "Monogame-SDL2 Window" opens and then I get a windows message "Reus has stopped working."
I am glad you guys are making progress on this. Good luck!

I get this message as well.

Originally posted by AbbeyManuel:
It would be great if we could get to read any error reports, so that we work on the problems. They should be in Steam\SteamApps\common\Reus, named "errorReport <date>.txt"
Otherwise you can find them in the Event Viewer (Open in Run (Windows+R) with "eventvwr").

I'd be happy to supply information that might be of use, but there was no error report file in the directory you listed. I tried looking through Event Viewer too, but couldn't find any recent ("today") reports that had anything to do with Steam or Reus.
[HOH] SkyFox Jan 13, 2014 @ 1:31pm 
I get the same error. Since the Graphics Card issue was fixed, I switched to the Beta, and whenever I start the game, the Monogame-SDL2 Window appears, then Reus immediately stops working.
I tried updating the drivers, and the .NET version, and a couple of things suggested by other users in the discussions, though I couldn't find any error reports in the files. From what I can see, it appears to be linked to a .NET problem, as I checked in EventViewer and the crashes seem to be paired. These were the reports I was able to find. I hope they help.

.NET Runtime

Application: Reus.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.EntryPointNotFoundException
Stack:
at OpenTK.Graphics.OpenGL.GL+Core.GenFramebuffers(Int32, UInt32*)
at OpenTK.Graphics.OpenGL.GL.GenFramebuffers(Int32, Int32 ByRef)
at Microsoft.Xna.Framework.SDL2_GameWindow..ctor()
at Microsoft.Xna.Framework.SDL2_GamePlatform..ctor(Microsoft.Xna.Framework.Game)
at Microsoft.Xna.Framework.GamePlatform.Create(Microsoft.Xna.Framework.Game)
at Microsoft.Xna.Framework.Game..ctor()
at Reus.Application..ctor()
at Reus.Program.ActualMain()
at Reus.Program.Main(System.String[])

And for the Reus Application itself

Faulting application name: Reus.exe, version: 1.3.1.1, time stamp: 0x52cc3ae0
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17932, time stamp: 0x50327672
Exception code: 0xe0434352
Fault offset: 0x0000c41f
Faulting process id: 0x3c8
Faulting application start time: 0x01cf10a46ed7536b
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Reus\Reus.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll

Last edited by [HOH] SkyFox; Jan 13, 2014 @ 1:36pm
SAAmarshall453 Jan 14, 2014 @ 4:32am 
nope not fixed
SAAmarshall453 Jan 15, 2014 @ 10:01am 
Originally posted by Mboy1100:
It doesn't work for me. A window labelled "Monogame-SDL2 Window" opens and then I get a windows message "Reus has stopped working."
I am glad you guys are making progress on this. Good luck!
same
Nabushi [Qc] Jan 24, 2014 @ 8:18pm 
I'm on linux Xubuntu 13.04 and the game just don't start anymore, even after opted for beta protected and file verification. No update is starting. Was playing with no problems last week.
karmik Jan 25, 2014 @ 11:38am 
Originally posted by Nabushi Qc:
I'm on linux Xubuntu 13.04 and the game just don't start anymore, even after opted for beta protected and file verification. No update is starting. Was playing with no problems last week.

I have the same problem on Ubuntu 13.10 x64. After opting out from Steam Client Beta Reus started to work again. I don't know if it is Steam client issue or Reus issue but it happens only with Reus.

Command line output:

CGameStreamThread: Added instance ID 8524 for appid 222730
CGameStreamThread: Added instance ID 8525 for appid 222730
Stacktrace:

at (wrapper managed-to-native) Steamworks.Steam.INTERNAL_Initialize (Steamworks.Steam/ManagedOverlayStatusChangeDelegate,Steamworks.Steam/ManagedUserStatsReceivedDelegate,Steamworks.Steam/ManagedUserStatsStoredDelegate,Steamworks.Steam/ManagedTextInputDismissedDelegate,Steamworks.Steam/ManagedLeaderboardFoundDelegate,Steamworks.Steam/ManagedLeaderboardInitializedDelegate,Steamworks.Steam/ManagedLeaderboardFriendScoreDownloadedDelegate,Steamworks.Steam/ManagedLeaderboardCompletedFriendScoreDownloadDelegate) <0xffffffff>
at Steamworks.Steam.Initialize () <0x0007f>
at Reus.Program.Main (string[]) <0x0000b>
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

/media/Files/eugene/Steam/SteamApps/common/Reus/lib64/libmono-2.0.so.1(+0xab388) [0x7f8b0839c388]
/media/Files/eugene/Steam/SteamApps/common/Reus/lib64/libmono-2.0.so.1(+0x10158f) [0x7f8b083f258f]
/media/Files/eugene/Steam/SteamApps/common/Reus/lib64/libmono-2.0.so.1(+0x2f65b) [0x7f8b0832065b]
/lib/x86_64-linux-gnu/libpthread.so.0(+0xfbb0) [0x7f8b079d3bb0]
/media/Files/eugene/Steam/linux64/steamclient.so(+0x966655) [0x7f8afb5da655]
/media/Files/eugene/Steam/linux64/steamclient.so(+0x1f743d) [0x7f8afae6b43d]
/lib64/ld-linux-x86-64.so.2(+0xf856) [0x7f8b08a88856]
/lib64/ld-linux-x86-64.so.2(+0xf910) [0x7f8b08a88910]
/lib64/ld-linux-x86-64.so.2(+0x13fdf) [0x7f8b08a8cfdf]
/lib64/ld-linux-x86-64.so.2(+0xf6e6) [0x7f8b08a886e6]
/lib64/ld-linux-x86-64.so.2(+0x13809) [0x7f8b08a8c809]
/lib/x86_64-linux-gnu/libdl.so.2(+0x1026) [0x7f8b07be2026]
/lib64/ld-linux-x86-64.so.2(+0xf6e6) [0x7f8b08a886e6]
/lib/x86_64-linux-gnu/libdl.so.2(+0x163c) [0x7f8b07be263c]
/lib/x86_64-linux-gnu/libdl.so.2(dlopen+0x31) [0x7f8b07be20c1]
/media/Files/eugene/Steam/SteamApps/common/Reus/lib64/libsteam_api.so(+0x6758) [0x7f8b000ec758]
/media/Files/eugene/Steam/SteamApps/common/Reus/lib64/libsteam_api.so(SteamAPI_Init+0x1d) [0x7f8b000ece7d]
/media/Files/eugene/Steam/SteamApps/common/Reus/lib64/libSteamworksNative.so(Initialize+0x28) [0x7f8b002fab38]
[0x41f71381]

Debug info from gdb:

ERROR: ld.so: object '/media/Files/eugene/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/bin/gdb: symbol lookup error: /lib/x86_64-linux-gnu/libncurses.so.5: undefined symbol: _nc_putchar

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

/media/Files/eugene/Steam/SteamApps/common/Reus/./Reus: строка 23: 8528 Аварийный останов ./Reus.bin.x86_64
CGameStreamThread: Added instance ID 8526 for appid 222730
CGameStreamThread: Added instance ID 8527 for appid 222730
CGameStreamThread: Added instance ID 8528 for appid 222730

(steam:8321): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
Last edited by karmik; Jan 25, 2014 @ 11:39am
Nabushi [Qc] Jan 25, 2014 @ 12:52pm 
Thank karmik, it run again :)
Rustis Feb 11, 2014 @ 1:19pm 
So still nothing?;/
< >
Showing 1-15 of 63 comments
Per page: 15 30 50

Reus > General Discussions > Topic Details