Rock of Ages > General Discussions > Topic Details
Void Chronos Oct 25, 2012 @ 11:20am
Crashes on launch
When i try to launch game, it shows black screen for a couple of seconds and then crashes. Can anyone help me solve this problem? Google found a few posts about crashes, but nothing of them worked.
Showing 1-15 of 95 comments
< >
[ACE] abordeu  [developer] Oct 25, 2012 @ 11:22am 
Did you skip the PhysX installation?
Void Chronos Oct 25, 2012 @ 11:24am 
It didn't appear
Void Chronos Oct 25, 2012 @ 11:27am 
After trying to launch PhysX installer from the folder, it wrote that i have newer version already installed
Last edited by Void Chronos; Oct 25, 2012 @ 11:30am
[ACE] abordeu  [developer] Oct 25, 2012 @ 11:33am 
Try verifying integrity of game cache.
Void Chronos Oct 25, 2012 @ 11:44am 
Done at the first time
WilliShaw Oct 25, 2012 @ 12:33pm 
I have read all of the forum links and done all they say plus tried installing all the Prerequisites again and it still doesn't launch and does the same as the owners game does.
TurboTortoise Oct 25, 2012 @ 12:41pm 
I have the same problem- could a patch be organised, instead of fixes that do not work, for everyone please?
[ACE] abordeu  [developer] Oct 25, 2012 @ 12:53pm 
Could you guys please post your system specs? Did you both skip/not see the PhysX installation step?
[SPOD] Usurper Oct 25, 2012 @ 1:04pm 
I am also having the same problem. I did not skip the PhysX installation step either
WilliShaw Oct 25, 2012 @ 1:41pm 
My specs are:
OS: Windows 7 Home Premium 64-bit
CPU: AMD A6-3650 APU with Radeon HD Graphics Quad Core ~2.6GHz
Ram: 8 GB
GPU: AMD Radeon HD 6530D
Void Chronos Oct 25, 2012 @ 2:21pm 
Processor Information:
Vendor: AuthenticAMD
Speed: 3221 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Windows 7 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: AMD Radeon HD 6670

DirectX Driver Name: aticfx32.dll
Driver Version: 8.982.0.0
DirectX Driver Version: 8.17.10.1140
Driver Date: 27 July 2012
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: AMD Radeon HD 6670
VendorID: 0x1002
DeviceID: 0x6758
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 26.65" x 15.00" (30.55" diag)
67.7cm x 38.1cm (77.6cm diag)
Primary Bus Type Not Detected
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Realtek HD Audio 2nd output (Re

Memory:
RAM: 8189 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Media Type: DVD
Total Hard Disk Space Available: 1994772 Mb
Largest Free Hard Disk Block: 290833 Mb
OS Install Date: Jan 01 1970
Game Controller: Microsoft PC-joystick driver detected
Henrik Oct 25, 2012 @ 2:23pm 
I'm having the exact same issue.

ATI Radeon 6970
AMD 1090t BE
8 GB DDR-3

I believe this is a ATI specific issue, I've also tried all the fixes I could find through Google. I'll try tinkering with CCC, and see if that's where the problem lies.
WilliShaw Oct 25, 2012 @ 2:26pm 
Nope no help
Showing 1-15 of 95 comments
< >
Per page: 15 30 50