Puddle > Levels > Topic Details
Green TeEeEeEea Dec 27, 2012 @ 8:24pm
Super glitchy?
So, I got it today and it ran great. No lag at all. But I would REALLY enjoy it more if it was all blurry. Like, it's all glitched out, can't see the liquid. Anything. Help?
Showing 1-11 of 11 comments
< >
Wok Dec 27, 2012 @ 11:26pm 
Just a guess: try updating the driver of your graphics card.
Green TeEeEeEea Dec 28, 2012 @ 12:20am 
This is a brand new laptop though. I don't get it. :I
Wok Dec 29, 2012 @ 2:53am 
It does not mean the driver is up to date.
Judelval Jan 5, 2013 @ 7:07am 
Brand new laptop. If you didn't build it yourself, that means the image used was probably baked six months ago. Update everything.
Green TeEeEeEea Jan 5, 2013 @ 10:43am 
How do I go about doing that?
°•👽 Louna 👽•° Jan 9, 2013 @ 10:17am 
What<s the specs^
Ocean Grown Jan 9, 2013 @ 10:31am 
Find out the makers of you're CPU, GPU, and Mobo.. Then visit each ones respective sites to update them.. When I was running into a lot of problems it was because I needed to do a BIOS update for my Mobo. There are also some programs out there that will automatically search and update you're drivers all though they aren't all that dependable or needed.
Immortal Caleb Jan 9, 2013 @ 11:34am 
The game runs smooth as silk for me and it looks great, not a single glitch so far and I'm 2 hours into the game...
Green TeEeEeEea Jan 10, 2013 @ 6:11am 
It really sucks though, I start it and it has a bunch of weird text, and when I play I get a ton of image trails
Green TeEeEeEea Jan 10, 2013 @ 6:20am 
CPU brand: Intel

Model: Celeron B820

------------------------------------------------------------------------------------------------------------------
Base GPU:

Graphics type: Integrated

Integrated GPU brand: Intel

Integrated GPU model: HD Graphics


Max GPU:

Integrated GPU brand: Intel

Integrated GPU model: HD Graphics 3000

I haven't modified any of this.
--------------------------------------------------------------------------------------------------------------------
I can't find the MOBO for it.

It's a Toshiba Satellite Pro C850, so if you could try to find it, I dunno.

And I recently did a BIOS update so.
Last edited by Green TeEeEeEea; Jan 10, 2013 @ 6:22am
SpongeJordan. Jan 10, 2013 @ 9:21am 
Google "Toshiba Satellite Pro C850 drivers"
Showing 1-11 of 11 comments
< >
Per page: 15 30 50

Puddle > Levels > Topic Details