The Cave > General Discussions > Topic Details
ReAzem Jun 28, 2013 @ 7:44pm
Everything is green (Linux).
Hey. There is some green layer over everything. Sometimes it goes away. When I press escape, the colors are fine, but when I get back in the game it turns green after a 0,5 seconds delay.

I don't know graphics and stuff, but this might be a layer that takes time to apply when getting back in the game (blur or something?) Hopefully you guys can fix it or give me a console command to prevent that layer from appearing?

All I know is I won't be able to play the game until this is fixed.

If it matters, all other Linux games work just fine on my system.

I'll take a screenie.
Edit: here you go, http://i.imgur.com/w734luG.jpg


Sys info:
Processor Information:
Vendor: GenuineIntel
Speed: 3401 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 13.04 (32 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-25-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11303000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release-i386_2013-05-08

Video Card:
Driver: ATI Technologies Inc. ATI Radeon HD 5900 Series

Driver Version: 4.2.12217 Compatibility Profile Context 12.104
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 119 Hz
VendorID: 0x1002
DeviceID: 0x689c
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3840 x 1376
Primary Display Size: 20.91" x 11.73" (23.94" diag)
53.1cm x 29.8cm (60.8cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 8048 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 104283 Mb
Largest Free Hard Disk Block: 85404 Mb

Installed software:

Recent Failure Reports:
Sat Jun 29 02:25:30 2013 GMT: file ''/tmp/dumps/assert_20130628222529_1.dmp'', upload no: ''HTTP response code said error''


Last edited by ReAzem; Jun 28, 2013 @ 7:52pm
Showing 1-15 of 16 comments
< >
bessie555 Jul 2, 2013 @ 2:28pm 
Hi

I have the exact same situation. Also the only linux game that does this.

Also running Ubuntu 13.04, but 64bit.


Here is my video card details:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cape Verde XT [Radeon HD 7770 GHz Edition] (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Device 2556
Flags: bus master, fast devsel, latency 0, IRQ 101
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at fea00000 (64-bit, non-prefetchable) [size=256K]
I/O ports at e000 [size=256]
Expansion ROM at fea40000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: fglrx_pci

Would appreciate a solution,

Thanks!
Dardy Jul 3, 2013 @ 12:27pm 
Hi All, Same problem for me under a Debian distro with Ati 6800 series video card.
I tryed with many resolutions, details and quality settings with no enanchment
I think it could be a graphic card driver issue, because this problem came when I upgraded from 12.10 to 13.4.
With catalyst 12.10 I finished the game more than once without any problem.
Last edited by Dardy; Jul 3, 2013 @ 12:30pm
bessie555 Jul 7, 2013 @ 10:42am 
Just an update - I did upgrade my ATI Drivers to the latest and still having the same issue. I did get it to work when I restored my original graphic drivers (none accelerated - I think) that came with Ubuntu 13.04.
jkaart Jul 11, 2013 @ 7:27pm 
I have also this problem with Radeon HD6850 and Ubuntu 13.04 combination.
blade22x Jul 12, 2013 @ 10:47am 
Me to with Radeon 7850 on Ubuntu 12.04 64bit.
Don Luigi Jul 12, 2013 @ 2:06pm 
I am also having this issue. The game works well with catalyst driver below version 13.4, but it doesn't work with 13.4 and 13.6 beta. I also found people complaining about this bug in the doublefine forum: http://www.doublefine.com/forums/viewthread/9148/

I would be glad if someone find a solution.
halo.jones Jul 17, 2013 @ 12:29pm 
Same here. Ati HD5760 latest Catalyst driver.
kaffeefant Jul 23, 2013 @ 4:40am 
same, hd7870, even with ati-drivers-13.6_beta on gentoo
Last edited by kaffeefant; Jul 23, 2013 @ 4:40am
MarcoDePollo Jul 24, 2013 @ 9:15am 
AMD has released a new OpenGL beta-drivers. This fixes colours, atleast for me.
http://support.amd.com/us/kbarticles/Pages/AMDCatalystOpenGL43BetaDriver.aspx
640kB Jul 25, 2013 @ 12:05pm 
I can confirm it. It also fixes the colours for me :)
ReAzem Jul 27, 2013 @ 11:47pm 
Fixed for me too, thanks!
lutzius Aug 7, 2013 @ 12:28pm 
I still had this problem with the OpenGL 4.3 beta driver,
but the new Catalyst 13.8 beta driver solved the problem.
http://support.amd.com/us/kbarticles/Pages/AMDCatalyst13-8LINBetaDriver.aspx

Using HD7750 with Ubuntu 13.4 64bit
fedik Nov 29, 2013 @ 5:27am 
is there a better solution?
than use unstable drivers just because this game
Bigmike Dec 15, 2013 @ 2:40pm 
Just an FYI (this might not be a viable option for most people) … This game is "almost playable" with the open source radeonsi driver on Ubuntu 13.10.

See my screenshots at: http://steamcommunity.com/profiles/76561198012059250/screenshots/?appid=221810

It still has some glitches and at least with my card I have to disable Bloom (similar effect to the one described by OP), High Quality Effects (locks up the card) and SSAA (unplayable slow). Other than that it runs smoothly.

It might even run better with HD 6xxx and older, because the driver for those is quite a bit more mature AFAIK.
TellNoLies Dec 23, 2013 @ 9:31pm 
I have the updated ATI drivers for linux and I also have the same issues of the green layers.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50