The Cave
The Cave > 일반 토론 > 제목 정보
le-grex 2013년 3월 10일 오전 9시 58분
The Cave on Linux, crashes after "loading".

if i try to start The Cave from Steam, the screen goes black, changes the mouse arrow to the in game design, shows a short second "Loading" and goes back to steam. If i try to start from command line: it says a segementation fault (sometimes), after ALSA lib pcm_dmix.c:1018(snd_pcm_dmix_open) unable to open slave...

It's a Debian with Kernel 3.8.1, relatively recent hardware: i5-3210M, Intel HD4000.

Can i do something about that?


< >
1-1313개 댓글 표시
TrippyJones 2013년 3월 10일 오후 5시 10분 
I'm having a similar problem. I just bought the game, and it won't go past the "loading" message at the very beginning, just after the mouse pointer shifts to the game's pointer. I'm running Ubuntu 12.04 on an Inspiron 1545 (Intel graphics, Intel Duo Core, 4 GBs ram, etc.) I tried opening it from a command line to get some info (first with ./Cave.bin.X86 and then with steam -applaunch 221280) to get some info, but I don't think I'm doing it right to find out what's wrong.

I'd be very grateful for any advice.
TrippyJones 2013년 3월 10일 오후 5시 23분 
Ok, I figured out how to run Steam in a console debugging mode. I've saved all the output if it's of any help. I saw something to the effect of "failed to load installscript" for The Cave. I also saw a segmentation fault (core dumped).
amarao 2013년 3월 10일 오후 7시 56분 
For me it simply hangs on loading message. Music plays, 109% CPU but nothing more. Wait al least 30 minutes before terminating process.
david96 2013년 3월 11일 오전 9시 01분 
For me :
your gl driver does not support arb_half_float vertex, and this title requires it
Failed to load installscript /home/david96/.local/share/Steam/SteamApps/common/TheCave/installscript.vdf Game update: AppID 221810 "The Cave", ProcID 16624, IP (steam:13919): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

I schroot -c wheezy -p steam

My config it's debian squeeze 32 bits
Alex 2013년 3월 16일 오전 5시 42분 
Confirming this issues. Judging by the reports above this might be related to the Intel driver not supporting all OpenGL extensions.

Is anyone able to try with recent Mesa (9.x) and X driver?

Oh, and by the way, GL_ARB_half_float_vertex is supported here on my system. Debian seems to compile with floating-point textures enabled by default.
Alex님이 마지막으로 수정; 2013년 3월 16일 오전 6시 15분
amarao 2013년 3월 16일 오전 11시 52분 
Now situation is really strange. I was able to run it on my laptop (Thinkpad x220 tablet), but on no desktop. Laptop contains i915 driver (linux-3.9rc2), and desktop use nouveau (opensource driver for nvidia). I all my time thought that nvidia is faster then built in graphics on intel, but seems intel capable more...
Alex 2013년 3월 16일 오후 5시 06분 
Nouveau is the open-source, clean-room reverse engineered driver for Nvidia GPUs. For nomal desktop-usage it works pretty well, but most (commercial) games won't run without issues.

I'd recommend using nvidia-glx, it's a proprietary GL implementation, but works perfectly well with "The Cave".
Alex님이 마지막으로 수정; 2013년 3월 16일 오후 5시 06분
r0gu1 2013년 3월 18일 오후 5시 02분 
The game does not start. It just gives the following message: "Your GL driver does not support EXT_texture_compression_s3tc, and this title requires it." I have Intel HD Graphics 3000. (I found reports claiming it should be enough.) I am on Fedora 18 w/ kernel 3.8.3-201.fc18.x86_64

I am a new Steam user. I installed it after it was released for Linux. The whole concept seems to be nice in general. For me the biggest peculiarity is the fact that so few games offer the possibility to try a demo. There should always be a demo available! That's the best way to see if the game works on my computer.
GZigue 2013년 3월 27일 오전 6시 58분 
Does anyone have a solution for it yet?

I have the same problem. I'm trying to run The Cave in ubuntu 12.04, and it shows the message "Your GL driver does not support EXT_texture_compression_s3tc, and this title requires it."
GZigue님이 마지막으로 수정; 2013년 3월 27일 오전 6시 59분
antcasq 2013년 3월 29일 오전 4시 12분 
Open Suse 12.2 64 bits
Intel core i3 2100T, Intel HD2000.
"Your GL driver does not support EXT_texture_compression_s3tc"...
Vedynn[Linux] 2013년 4월 10일 오전 11시 39분 
Проблем с загрузкой не заметил Ubuntu 12.10 x86 драйвер AMD 13.1 Правда fps сильно падают периодами, но не часто и пиками.
office_monkey 2013년 4월 12일 오후 6시 16분 
Xubuntu 12.04 64bit
Intel® Core™ i5-3470 CPU @ 3.20GHz
7.5 GB RAM

Got the same "Your GL driver does not support EXT_texture_compression_s3tc, and this title requires it."

As recommended here[] I installed s2tc0:
sudo apt-get install libtxc-dxtn-s2tc0:i386
Afterwards the game started with no error but crashed without a message after the loading sign appeared.

Then I added x-swat ppa as suggested[]:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update sudo apt-get dist-upgrade

Now it works.
But I had to turn off details and switch to lower resolution, because it was not running smoothly.

I'm having big trouble suddenly... GUI looks absolutly rotten, graphic driver related! I'm going kill my xubuntu/steam installation and switch to something more solid.

office_monkey님이 마지막으로 수정; 2013년 4월 17일 오후 4시 07분
Ikarovo Pero 2016년 1월 7일 오전 9시 15분 
Old discussion, I know, but it might help someone...

So, I also had this problem on my laptop with i7-4712MQ and HD 4600, running 64-bit Xubuntu 14.04. Problem was not only with The Cave, but also with other Double Fine games I acquired on Humble Bundle and later reclaimed on Steam, for example Costume Quest.

The only thing needed is simply:

sudo apt-get install libtxc-dxtn-s2tc0:i386 office_monkex said, but without anything else. So, no new repository. Just this procurement of 32-bit version of that library.
< >
1-1313개 댓글 표시
페이지당 표시 개수: 15 30 50

The Cave > 일반 토론 > 제목 정보