The Cave

The Cave

View Stats:
The Cave > General Discussions > Topic Details
chriskringel Feb 21, 2013 @ 1:55pm
[SOLVED] Linux version: Sound gone when restarting the game
Hi there!

First of all HUGE thanks for the Linux version! It runs reasonable smooth even on my older hardware. Nice job.

But there's a problem: The game's sound is completely gone with *every* single restart of the game. E.g. exiting the game, saving, and playing again at later time. There's is no sound anymore. Restarting Steam doesn't changes this. Logging out, restarting X, restarting LightDM Display manager, ...nothing. Even "sudo alsa unload/reload" (removing and reloading all sound modules, mine is: snd-intel8x0 -- never had any problems so far.)

Also when exiting the game this time (after restarting, with no sound), it crashes while exiting. It crashes pretty bad, because "killall (-15) Cave.bin.x86" won't work. But killall -10 ... or killall -9 ... ends the process.

This is repeatable for me. Funny solution/workaround to the sound issue:
Reboot. Really.

But I don't get it, what exactly the reboot triggers. After that it works, well, for once. When I have to exit the game and I want to play again, I have to reboot. But I'll probably do this for a while, because I really do like The Cave.

PS: No real problems with other Steam games, but e.g. for "Half Life (1)", Steam has to be started with SDL_AUDIODRIVER=alsa on my system. Because I haven't and won't install PulseAudio. Just basic ALSA for me. But this never made problems. Of course I started The Cave with this variable set and without it, and with unsetting it. With testing and trial and error I figured out, that it doesn't matter. After a reboot The Cave runs fine, whether I start Steam with SDL_AUDIODRIVER="" (unsetting it, or not setting at all), or with SDL_AUDIODRIVER="alsa". It works both ways fine. But only once. -- So however this might be some hint. The big question for me is what the mysterious Reboot does to workaround the problem temporarly.

Running on ubuntu 13.04 x64_86 (development branch).

Thanks in advance!
Last edited by chriskringel; Feb 22, 2013 @ 4:24pm
< >
Showing 1-4 of 4 comments
DFJustin Feb 21, 2013 @ 5:33pm 
Upcoming build we'll put out has several sound fixes listed, which we're hoping will fix the losing sound on exiting issue.
Phaota Feb 21, 2013 @ 9:29pm 
This same issue has occurred with the latest Windows version update as well.
chriskringel Feb 22, 2013 @ 5:56am 
Thanks! @DFJustin Just for information: I tested it again with working PulseAudio setup and without it. And in both cases playing with the SDL_AUDIODRIVER= variable. It has no effect. Regardless of the setup it works always once, but never when restarting (unless reboot) I posted some more information here: (But again, this made no difference. So this is very likely a bug/issue of the game itself.)
chriskringel Feb 22, 2013 @ 4:23pm 
There just has been a ~9MB update of the game. The bug is completely gone now. (I never smiled that much exiting and restarting a game.) THANKS! That's pretty fast. PS: Tested with working PulseAudio, uninstalling it and restarting the system with plain ALSA, also with SDL_AUDIODRIVER=alsa (which I use to start Steam, because it's needed for sound effects in Half Life 1). The Cave works perfectly fine now both ways and no more crashing when exiting the game. I updated the topic of this thread.
Last edited by chriskringel; Feb 22, 2013 @ 4:26pm
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

The Cave > General Discussions > Topic Details